Announcement

Collapse
No announcement yet.

Using the new perl centreon plugins

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using the new perl centreon plugins

    Hi to all.

    I have a new centos/cent-engine/cent-broker installation. The moderator Shini tells to me that use the new system of plugins

    Im not an expert on nagios and centreon, but i want to check it and learn.

    First i installed the perl requisites that Shini show me on the blog post, next download the 21-5-2014 version of the plugins, and unzipped on the libexec directory of my actual nagios plugins. On my case in /usr/local/nagios/libexec ($USER1$).

    I manually execute the command in this path: /usr/local/nagios/libexec

    Code:
    perl centreon_plugins.pl  --plugin=os::linux::snmp::plugin --mode traffic --hostname 127.0.0.1 --snmp-community mycommunit1 --snmp-version 2 --interface 2
    And works

    Code:
    OK: Interface 'eth0' Traffic In : 17.70Kb/s (0.00 %), Out : 3.90Kb/s (0.00 %)  | 'traffic_in'=17696.68b/s;;;0;1000000000 'traffic_out'=3904.24b/s;;;0;1000000000
    In the Web Envirmoment, create a Command
    Code:
    $USER1$/perl centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode traffic --hostname $HOSTADDRESS$ --snmp-community $_HOSTSNMPCOMMUNITY$ --snmp-version $_HOSTSNMPVERSION$ --interface $ARG1$
    or
    Code:
    perl $USER1$/centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode traffic --hostname $HOSTADDRESS$ --snmp-community $_HOSTSNMPCOMMUNITY$ --snmp-version $_HOSTSNMPVERSION$ --interface $ARG1$
    But i get this error

    forum-centreon-001.JPG

    Any help?

    Thanks.
    Kindest Regards.
    Last edited by Txurrispo; 20 November 2014, 17:28.

  • #2
    Autoanswer


    Code:
    $USER1$/centreon_plugins.pl --plugin=os::linux::snmp::plugin --mode traffic --hostname $HOSTADDRESS$ --snmp-community $_HOSTSNMPCOMMUNITY$ --snmp-version $_HOSTSNMPVERSION$ --interface $ARG1$

    Comment

    Working...
    X