Announcement

Collapse
No announcement yet.

Comment debugger les graphes ? [Résolu]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • barbaar
    replied
    Had a typo in /etc/portage/package.keywords. That's why I thought there was no newer packages available...

    Works now, thanks!

    Leave a comment:


  • julio
    replied
    update rrdtool in last verison there are no problem : 1.2.15

    Leave a comment:


  • barbaar
    replied
    I configged rrdtool version 1.2 in Oreon, and rrdtool --help returns:

    Code:
    www rrdDB # /usr/bin/rrdtool --help
    RRDtool 1.2.6  Copyright 1997-2005 by Tobias Oetiker <[email protected]>
                   Compiled Mon Nov 20 07:35:38 CET 2006
    I removed the --color FRAME#000000 part and do see images now

    Leave a comment:


  • DonKiShoot
    replied
    Code:
    [28/11/2006 16:47] RDDTOOL : /usr/bin/rrdtool graph - --start=1164643156 --end=1164729596 --interlaced --width=600 --height=200 --title='Graph HTTP on Host SRV92FNX' --vertical-label='Value' --color CANVAS#FFFFFF --color BACK#FEFEFE --color FONT#000000 --color MGRID#800000 --color GRID#808080 --color FRAME#000000 --color ARROW#FFFFFF --color SHADEA#C0C0C0 --color SHADEB#909090 --lower-limit 0 --rigid  DEF:v0=/usr/local/oreon/filesGeneration/graphs/simpleRenderer/rrdDB/SRV92FNX_HTTP.rrd:size:LAST  DEF:v1=/usr/local/oreon/filesGeneration/graphs/simpleRenderer/rrdDB/SRV92FNX_HTTP.rrd:time:LAST  COMMENT:" \c" COMMENT:" From  27/11/2006 16\:59 to 28/11/2006 16\:59 \c" COMMENT:" \c"  LINE2:v0#1183EE:"DS1 (B)         " GPRINT:v0:AVERAGE:"Average\:%8.2lf%s" GPRINT:v0:MIN:"Min\:%8.2lf%s" GPRINT:v0:MAX:"Max\:%8.2lf%s" GPRINT:v0:LAST:"Last\:%8.2lf%s\l" LINE2:v1#18E631:"DS2 (.739256s)  " GPRINT:v1:AVERAGE:"Average\:%8.2lf%s" GPRINT:v1:MIN:"Min\:%8.2lf%s" GPRINT:v1:MAX:"Max\:%8.2lf%s" GPRINT:v1:LAST:"Last\:%8.2lf%s\l" 2>&1
    No problem for me with that parameters.

    Are you using rrdtool 1.0 or 1.2 ? Do you correctely configure Oreon with good rrdtool version ?

    Leave a comment:


  • barbaar
    replied
    Sorry again for posting in English, my French is not to good

    I am experiencing the same rrd problem. I am using Oreon 1.3.2 and Gentoo with rrdtool rrdtool-1.2.6-r1

    This is the command that Oreon creates (and tries to execute):

    Code:
    /usr/bin/rrdtool graph - --start=1162332000 --end=1164924009 --interlaced --width=600 --height=200 --title='Graph snmpLoad on Host ldap.bart.nl' --vertical-label='Value' --color CANVAS#FFFFFF --color BACK#FEFEFE --color FONT#000000 --color MGRID#800000 --color GRID#808080 --color FRAME#000000 --color ARROW#FFFFFF --color SHADEA#C0C0C0 --color SHADEB#909090 --lower-limit 0 --rigid  DEF:v0=/usr/local/oreon/filesGeneration/graphs/simpleRenderer/rrdDB/ldap.bart.nl_snmpLoad.rrd:load_1_min:LAST  COMMENT:" \c" COMMENT:" From  31/10/2006 23\:00 to 30/11/2006 23\:00 \c" COMMENT:" \c"  LINE2:v0#1183EE:"DS1 " GPRINT:v0:AVERAGE:"Average\:%8.2lf%s" GPRINT:v0:MIN:"Min\:%8.2lf%s" GPRINT:v0:MAX:"Max\:%8.2lf%s" GPRINT:v0:LAST:"Last\:%8.2lf%s\l"

    And the resulting error:
    Code:
    ERROR: invalid color name 'FRAME'

    Any ideas?

    Leave a comment:


  • wistof
    replied
    au moins une version 1.2

    Leave a comment:


  • VolCom974
    replied
    vous conseillez donc d'installer la dernière version de rrdtool?

    Leave a comment:


  • DonKiShoot
    replied
    avant de passer en 1.2 j'avais des \ et c t moche :x

    Leave a comment:


  • wistof
    replied
    par contre, avec une version rrdtool 1.0.x, tu n'as pas des \ devant les : dans la ligne COMMENT ? :roll:

    Leave a comment:


  • bejaulin
    replied
    Hello,

    Pour moi c'est clair, les graphes doivent fonctionner vu que la directive COLORTAG FRAME de la commande rrdgraph était présente dans les versions 1.0.x de rrdtool.

    En conclusion :
    graphes Oreon OK pour les versions rrdtool 1.0.x et > 1.2.6

    Leave a comment:


  • inconnuflo
    replied
    je confirme à nouveau avec une nouvelle install

    qu'une platform Debian 3.1 utilisant que les paquets stables (meme rrdtool 1.0.49), Nagios 2.5 et oreon 1.3, fonctionne très bien :!: :!: :!: :!:

    Bien sur, j'ai respecter la procédure mis dans le wiki depuis le début :wink:

    Leave a comment:


  • inconnuflo
    replied
    Rectification
    j'ai reussi à faire fonctionner un rrdtool 1.0 avec nagios2.5 et oreon1.3rc3
    et mon graph uptime du serveur marche nickel :wink:

    Leave a comment:


  • inconnuflo
    replied
    oui a priroi la version 1.0 n'est plus supporte par oreon1.3
    il faut a tout pris installer rrdtool1.2 :wink:

    Leave a comment:


  • sebelec
    replied
    le probléme vien aussi du paquetage install nagios by oreon, le rddtool est en version 1.0.49...

    Leave a comment:


  • bejaulin
    replied
    Oups là ... toucher plus à rien ! c'est tout bon !!

    Le problème est lié à la version de RRDTool. je suis passé en 1.2.15 et maintenant le COLORTAG FRAME est bien pris en compte.

    En faite, il faut juste une version rrdtool > 1.2.6 . Pas de chance, sous Gentoo les versions de rrdtool sont encore déclarées en non stable après la 1.2.6 .

    Alors, pour nos amis sous Gentoo, ajouter la ligne suivante dans package.keywords

    Code:
    #vi /etc/portage/package.keywords
    
    net-analyzer/rrdtool            ~x86
    
    
    #emerge net-analyzer/rrdtool

    Dans les pré-requis, si vous pouvez ajouter Version de RRDTool > 1.2.6 ça serait super...

    Merci à tous.

    BJA

    PS : J'ai vraiment galéré pour ce problème, mais vive Linux et longue vie à Oreon quand même.

    Leave a comment:

Working...
X