Announcement

Collapse
No announcement yet.

[resolu]Absence de graphes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [resolu]Absence de graphes

    Bonjour,
    Lors du test check_graph_traffic.pl je remonte bien les bonnes informations sur la console Monitoring. Cependant quand je vais dans le détail des services et que je veux afficher le graphique associé, je n'ai rien.

    Les fichiers rrd sont bien générés et mis à jour, mais il semble qu'il n'y ai aucune valeur dedans.
    Code:
    [email protected] rrd]# rrdtool info 1_2.rrd
    filename = "1_2.rrd"
    rrd_version = "0003"
    step = 300
    last_update = 1153480852
    ds[a].type = "GAUGE"
    ds[a].minimal_heartbeat = 600
    ds[a].min = NaN
    ds[a].max = NaN
    ds[a].last_ds = "UNKN"
    ds[a].value = 1.1593400000e+05
    ds[a].unknown_sec = 0
    ds[b].type = "GAUGE"
    ds[b].minimal_heartbeat = 600
    ds[b].min = NaN
    ds[b].max = NaN
    ds[b].last_ds = "UNKN"
    ds[b].value = 1.4301560000e+05
    ds[b].unknown_sec = 0
    rra[0].cf = "AVERAGE"
    rra[0].rows = 8640
    rra[0].pdp_per_row = 1
    rra[0].xff = 5.0000000000e-01
    rra[0].cdp_prep[0].value = NaN
    rra[0].cdp_prep[0].unknown_datapoints = 0
    rra[0].cdp_prep[1].value = NaN
    rra[0].cdp_prep[1].unknown_datapoints = 0
    rra[1].cf = "MIN"
    rra[1].rows = 8640
    rra[1].pdp_per_row = 12
    rra[1].xff = 5.0000000000e-01
    rra[1].cdp_prep[0].value = 2.2296606667e+03
    rra[1].cdp_prep[0].unknown_datapoints = 0
    rra[1].cdp_prep[1].value = 2.7545813333e+03
    rra[1].cdp_prep[1].unknown_datapoints = 0
    rra[2].cf = "MAX"
    rra[2].rows = 8640
    rra[2].pdp_per_row = 12
    rra[2].xff = 5.0000000000e-01
    rra[2].cdp_prep[0].value = 2.3361973333e+03
    rra[2].cdp_prep[0].unknown_datapoints = 0
    rra[2].cdp_prep[1].value = 2.7827146667e+03
    rra[2].cdp_prep[1].unknown_datapoints = 0
    Car on remarque des "NaN" partout.

    Une idée ?
    Merci
    Ubuntu + Nagios 2.9 + Centreon 1.4.1

  • #2
    je teste avec les autres plugin de graph et la il me mets
    Code:
    rrd file not found
    Pourtant les fichier rrd sont bien dans /usr/local/oreon/rrd
    Ubuntu + Nagios 2.9 + Centreon 1.4.1

    Comment


    • #3
      Hello le_Zeou,

      As-tu trouvé une solution à ton pb ?

      Tu as vérifié la configuraiton d' Oreon au niveau de rrdtool ? (Option -> Options Générales -> RRDTool )

      BJA.

      Comment


      • #4
        Oui j'ai vérifié la conf. Tout est OK.

        Par contre les fichiers rrd ne se créés pas tout le temps, et pas avec la même structure de nom. parfois j'ai "1_2.rrd" et d'autre fois j'ai "2.rrd" selon le plugin utilisé.

        Mais du coté de la console rien se s'affiche.
        Ubuntu + Nagios 2.9 + Centreon 1.4.1

        Comment


        • #5
          J ai exactement le meme probleme avec le plugin check_graph_nt (toutes variables), extrait :

          rrdtool info 74_5.rrd

          filename = "74_5.rrd"
          rrd_version = "0001"
          step = 300
          last_update = 1153746132
          ds[a].type = "GAUGE"
          ds[a].minimal_heartbeat = 600
          ds[a].min = NaN
          ds[a].max = NaN
          ds[a].last_ds = "UNKN"
          ds[a].value = 0.0000000000e+00
          ds[a].unknown_sec = 132
          ds[b].type = "GAUGE"
          ds[b].minimal_heartbeat = 600
          ds[b].min = NaN
          ds[b].max = NaN
          ds[b].last_ds = "UNKN"
          ds[b].value = 0.0000000000e+00
          ds[b].unknown_sec = 132
          ds[c].type = "GAUGE"
          ds[c].minimal_heartbeat = 600
          ds[c].min = NaN
          ds[c].max = NaN
          ds[c].last_ds = "UNKN"
          ...

          alors que mon plugin check_graph_ping s'affiche sans soucis.

          Je suis sous Debian 3.1 Nagios 2.4 et Oreon 1.3RC2.
          Centreon 2.2.0, Nagios 3.2.3 | 25 Hosts 165 Services
          Modules php-Weathermap 2.0.0
          Debian 6.0 Squeeze Kernel 2.6.32-5-686
          RRDTool 1.4.3
          Apache 2.2.16, PHP 5.3.3-7+squeeze1 et MySQL 5.1.49
          HP xw8400 Bi Xeon 5150 2.66Ghz, Ram 2Go

          Comment


          • #6
            Originally posted by le_zeou
            je teste avec les autres plugin de graph et la il me mets
            Code:
            rrd file not found
            Pourtant les fichier rrd sont bien dans /usr/local/oreon/rrd
            Tu as ce problème en ligne de commande ?

            Comment


            • #7
              Non directement sur l'interface Oreon.
              Ubuntu + Nagios 2.9 + Centreon 1.4.1

              Comment


              • #8
                petite ilulstration

                Voici une petit illustration du probleme : sur la copie d ecran (tableau1.jpg en piece jointe) au niveau du monitoring, on voit bien le retour d'info du plugin check_graph_nt (les 5 services) par contre sur la copie d ecran tableau2.jpg (toujours en piece jointe) aucune information n est récupérée du .rrd et effectivement si l on fait un "rrdtool info *_*.rrd", on remarque qu aucune info n a été renseignée correctement dedans (voir plus haut).
                Attached Files
                Centreon 2.2.0, Nagios 3.2.3 | 25 Hosts 165 Services
                Modules php-Weathermap 2.0.0
                Debian 6.0 Squeeze Kernel 2.6.32-5-686
                RRDTool 1.4.3
                Apache 2.2.16, PHP 5.3.3-7+squeeze1 et MySQL 5.1.49
                HP xw8400 Bi Xeon 5150 2.66Ghz, Ram 2Go

                Comment


                • #9
                  Ca vient de la mise a jour du fichier rrd alors.
                  Tu viens de le mettre ou ca fais deja un moment que le script tourne ? car il faut attendre un peu avant de pouvoir observer les premieres valeurs.
                  Ubuntu + Nagios 2.9 + Centreon 1.4.1

                  Comment


                  • #10
                    Ca fait plusieurs jours que cela tourne, et Oreon m averti bien lorsque le seuil du warning ou du critical est atteint, donc l'info recupérée est exploitable, y a plutot un pb a la generation du .rrd par le script perl du plugin, ..., pb au niveau de pearl, manque une librairie ?




                    j ai oublié de préciser :

                    Je suis passé en 1.3RC3-1 (Nagios 2.4 Debian 3.1 RRDTOOL 1.0.49)

                    Par contre je n ai aucune pb avec le plugin check_graph_ping le graph s affiche correctement.
                    Centreon 2.2.0, Nagios 3.2.3 | 25 Hosts 165 Services
                    Modules php-Weathermap 2.0.0
                    Debian 6.0 Squeeze Kernel 2.6.32-5-686
                    RRDTool 1.4.3
                    Apache 2.2.16, PHP 5.3.3-7+squeeze1 et MySQL 5.1.49
                    HP xw8400 Bi Xeon 5150 2.66Ghz, Ram 2Go

                    Comment


                    • #11
                      Bon pour moi cela marche maintenant, en fait cela venait de l'intervalle que je laissais entre 2 collectes (15 minutes) si j'abaisse ce temps à 5 minutes le fichier RRD est correctement remplit (avant il était cohérent à la première prise puis toutes les données passaient à 0 dès la deuxième collecte)
                      Centreon 2.2.0, Nagios 3.2.3 | 25 Hosts 165 Services
                      Modules php-Weathermap 2.0.0
                      Debian 6.0 Squeeze Kernel 2.6.32-5-686
                      RRDTool 1.4.3
                      Apache 2.2.16, PHP 5.3.3-7+squeeze1 et MySQL 5.1.49
                      HP xw8400 Bi Xeon 5150 2.66Ghz, Ram 2Go

                      Comment


                      • #12
                        C'est Ok pour moi aussi.
                        Ubuntu + Nagios 2.9 + Centreon 1.4.1

                        Comment


                        • #13
                          bonjour

                          votre sujet m'intéresse car j'ai exactement le même problème avec la version 1.3RC1
                          je vais installer la 1.3 d'ici peu mais j'aimerais résoudre ce problème avant

                          j'aurais une question pour vous ou tout autre personne
                          pensez-vous que cela puisse poser un problème si le contrôle se fait toutes les minutes et non toutes les 5 minutes :?:
                          marion

                          Comment


                          • #14
                            eh oui c encore moi

                            je me disais q peut etre ce bug était dû au fait que je n'ai que la version RC1
                            est-ce que quelqu'un aurait des infos là dessus

                            merci
                            marion

                            Comment


                            • #15
                              pensez-vous que cela puisse poser un problème si le contrôle se fait toutes les minutes et non toutes les 5 minutes
                              non mais il faut ajouter le parametre "--rrdstep 60" à la ligne de commande.

                              ça crée la base rrd avec un step de 60 secondes.

                              PS il faut détruire le fichier rrd s'il existe déja et le laisser se recréer avec le nouveau parametre.

                              Comment

                              Working...
                              X