Announcement

Collapse
No announcement yet.

perfparse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • perfparse

    I have perfparse installed now. I made the perfparse database, ran the sql script to fill it up. The databse opens in Oreon views but there are no hosts in it.

    I made my process-service-perfdata to this:
    /usr/bin/printf "%b" "$TIMET$\t$HOSTNAME$\t$SERVICEDESC$\t$OUTPUT$\t$SE RVICESTATE$\t$PERFDATA$\n" | $USER2$/bin/perfparse-log2mysql -c $USER2$/etc/perfparse.cfg

    it seems to run, cause i was getting a database login error in nagios.log from it but i fixed that, no errors there. also perfparse log repeatedly says it succesfully loaded mysql storage module.

    my perfparse.cfg has - for the service_log because i am running it directly, im not using that import log from a daemon. rrd graphs seem to still work.

    all that, and my oreon views for my perfparse graphs have no hosts or services listed in the dropdowns menus, they are empty. do i need a meta service? i seen that perfparse enabled added it (along with delete retention templates) and didnt know what a meta service is. is it manditory i make one for the graphs? is that my problem?

    thanks for any help.. im almost to the finish line!

  • #2
    What I did with PerfParse is first getting it to work in Nagios with the perfparse install instructions (one problem at a time please ;-)). Only after that worked and the graphs showed up nicely in the Nagios web-interface I tried it in Oreon and I think I only had to change the settings in Configuration/nagios/perfparseCFG. For debugging you can see in the perfparse log or in the mysql database if there is something written in the sql files.

    Regards
    Menno

    Comment


    • #3
      What did you change in your perfparse cfg? My perfparse works fine in nagios, but nothing shows up in oreon.

      Comment


      • #4
        Originally posted by stinkybob
        What did you change in your perfparse cfg? My perfparse works fine in nagios, but nothing shows up in oreon.
        That's too long ago I'm afraid, I can only show you what's in my config now. I run perfparse outside Oreon at the moment, via a cron job.
        Nagios.cfg:
        process_performance_data=1
        host_perfdata_file=/usr/local/nagios/var/hostperf.log
        service_perfdata_file=/usr/local/nagios/var/serviceperf.log
        service_perfdata_file_template=$TIMET$ $HOSTNAME$ $SERVICEDESC$ $SERVICEOUTPUT$ $SERVICESTATE$ $SERVICEPERFDATA$

        Perfparse.cfg:
        Server_Port = "1976"
        Service_Log = "/usr/local/nagios/var/serviceperf.log"
        Service_Log_Position_Mark_Path = "/tmp"
        Error_Log = "perfparse.log"
        Error_Log_Rotate = "Yes"
        Error_Log_Keep_N_Days = "7"
        Drop_File = "/tmp/perfparse.drop"
        Drop_File_Rotate = "Yes"
        Drop_File_Keep_N_Days = "7"
        Lock_File = "/var/lock/perfparse.lock"
        Show_Status_Bar = "Yes"
        Do_Report = "Yes"
        Default_user_permissions_Policy = "rw"
        Default_user_permissions_Host_groups = "rw"
        Default_user_permissions_Summary = "rw"
        Output_Log_File = "Yes"
        Output_Log_Filename = "/var/log/perfparse_output_log"
        Output_Log_Rotate = "Yes"
        Output_Log_Keep_N_Days = "7"
        Use_Storage_Socket_Output = "No"
        Storage_Socket_Output_Host_Name = "localhost"
        Storage_Socket_Output_Port = "1974"
        Use_Storage_Mysql = "Yes"
        No_Raw_Data = "Yes"
        No_Bin_Data = "No"
        DB_User = "user"
        DB_Pass = "password"
        DB_Name = "perfparse"
        DB_Host = "localhost"
        Dummy_Hostname = "dummy"
        Storage_Modules_Load = "mysql"

        Regards
        Menno

        Comment

        Working...
        X