Announcement

Collapse
No announcement yet.

check_graph_traffic dont give graph

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DaskTill
    replied
    Hey @all,

    can somebody tell my how i have to configure something like check_graph_traffic. i am a really new in this section nagios vs oreon

    ./check_graph_traffic.pl -H server -C public -v 1 -g -w 85 -c 90

    returns

    ERROR: IN Bytes : Received noSuchName(2) error-status at error-index 1.

    thanks for postings

    DaskTill

    Leave a comment:


  • DonKiShoot
    replied
    it may be a bug in check_graph_traffic because by convention it's 600 if the step is 300 not 20.

    Where comme this 20 from ?

    Leave a comment:


  • mdurand
    replied
    i solve my problem

    the rrd file of check graph traffic
    i had minimal_heartbeat = 20 i changed it to 600

    and now everything is ok

    Leave a comment:


  • mdurand
    replied
    if another user cannot write in my rrd file
    (chmod go-w /usr/local/oreon/rrd/3_3.rrd)

    oreon tell me there is a problem

    unable to update '/usr/local/oreon/rrd/3_3.rrd' : opening '/usr/local/oreon/rrd/3_3.rrd': Permission denied

    but when i do chmod go-w /usr/local/oreon/rrd/3_3.rrd oreon tell me everything is ok
    even so i still have NAN in the file

    Leave a comment:


  • mdurand
    replied
    i have the same problem
    check_graph_traffic is the only plugin that don't graph anything
    the rrd file has been created but it only have "NAN"

    i have the last version : 1.3.1-1

    Leave a comment:


  • DonKiShoot
    replied
    it was just some suggest.

    i don't use this plugin. sorry :wink:

    Leave a comment:


  • abc
    replied
    sorry but what do you mean by wait??..
    increace the checking interval or time wait to see the results???!!..

    I configured it without any errors 2 days ago & till now i did not get any graph.. so what can i do or what can i check.. :cry:

    Leave a comment:


  • DonKiShoot
    replied
    are you sure you wait enough ?

    i ask that because i know that check_graph_traffic need 2 or 3 check before giving good values

    Leave a comment:


  • abc
    started a topic check_graph_traffic dont give graph

    check_graph_traffic dont give graph

    Hi,

    I have a strange problem… I use Oreon 1.3-RC1…

    From the command line all my plugins are working fine & in the Oreon “monitoring” tab I don’t have any errors…
    For my router I configured one interface with check_graph_ping command & the other with check_graph_traffic the first one is fine but I can’t get the graph for the second one; ex.:

    FastEthernet0/0
    Its check command is: check_graph_traffic
    The command output is: Traffic In : 0.00 b/s (0.0 %), Out : 0.00 b/s (0.0 %) - Total RX Bits In : 19.78 GB, Out : 4.22 Gb --- here I can not see the graph curve, its empty graph
    But for:
    FastEthernet1/0
    The check command is: check_graph_ping
    The command output is: GPING OK - rtt min/avg/max/mdev = 1.040/1.161/1.255/0.089 ms --- I can see the graph curve

    What may be the problem??!!... Can any one help me in this???!

    I thought the problem with my rrd files but I can get one graph that me it’s ok as I think…. Only my check_graph_traffic doesn’t give any graph!!!..

    Is their any explanation for this or any update for this command??!!!..
Working...
X