Announcement

Collapse
No announcement yet.

Perfparse Droping all lines

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Perfparse Droping all lines

    I have installed perfparse but it is droping all lines from service-perfdata.dat.
    I can't seem to find a plugin which returns data in a format that perfparse understands.

    Which plugins are compatible with perfparse?
    Which should be data format ?

    should the following line be correctly parsed by /srv/nagios2/bin/perfparse-log2mysql?

    1163670978 pthp62.telecom.pt FPing 0.020 0.940 FPING OK - 127.0.0.1 (loss=0%, rta=0.310000 ms) loss=0%;20;60;0;100 rta=0.000310s;0.100000;0.500000;0.000000;0.000000

    It is being droped...

    Thank you for any help...

  • #2
    I find similar problems...PerfParse still doesn't work right for me, even though I have reinstalled several times and tried different solutions while testing my installation guides.
    Since I am writing documentation for "Getting Started", if someone could post the correct configuration here, I will make sure it is recorded for all to refer to in future

    Thanks!
    Production: Nagios 2.5,Oreon 1.3.1,Perfparse 0.106.1
    Testing: Whatever I set up this week :wink:
    EVERYONE: irc.freenode.net channel #oreon!!! :-)

    Comment


    • #3
      Hmm, ok after a quick look at what you've written, I want to make an (un)educated guess. Wherever you defined the template for the service-perfdata.dat file (either in check commands or in the file_template option in nagios.cfg)...did you specify TABs between each variable?

      Eg, template definition: $TIMET$\t$HOSTNAME$\t$SERVICEDESC$\t$OUTPUT$\t$SER VICESTATE$\t$PERFDATA$

      Maybe you will get lucky and make it work, unlike me. hehe.

      Cheers,
      Dan.
      Production: Nagios 2.5,Oreon 1.3.1,Perfparse 0.106.1
      Testing: Whatever I set up this week :wink:
      EVERYONE: irc.freenode.net channel #oreon!!! :-)

      Comment


      • #4
        Thank you for your effort... but I specified tabs (\t) in the template definition.
        When I made the copy/paste they were somehow transformed in spaces.
        In the original service-perfdata.dat fields are separated by tabs.

        Comment

        Working...
        X