Announcement

Collapse
No announcement yet.

Problems with check_graph_traffic.pl on Gbit and TenGbit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems with check_graph_traffic.pl on Gbit and TenGbit

    Hi,

    i've tried to draw traffic-graphs for TenGigabit and Gigabit Interfaces on a Cisco 6500 (Sup720).

    While Cacti draws a Graph for a Gigabit-Interface with a Max of 500Mbit Oreon draws a Graph for the same Interface with a Max of 65Mbit. Both had the same timerange. Is it possible that Oreon can't handle the full throughput on Gigabit or TenGigabit Interfaces?

    I've tried to change the SNMP-Variable for the Interfaces in Oreon.conf from the standard-counters (32bit) to the snmpv2-hispeed-counters (64bit). With the standard-counters the throughput wasn't near 1mbit when Cacti drawed about 500Mbit.

    Yes the interface really has that throughput. It is the Uplink to our Primary Router...

    The max peaks occur in both graphs at right time but didn't match the max-value of each other.

    I also checked the stepping of rrd. The created service for check_graph_traffic.pl is configured with a check-interval of 5 Minutes. The .rrd file had a step of 300 Seconds.

    I've installed Oreon 1-3-1

    Regards,

    Fantasio

  • #2
    We've installed Oreon 1.3.3 but it didn't fix our Trafficproblem. After hours of testing i've realised that you guys overwrite the values in "libexec/oreon.conf" with the values from:

    /usr/local/oreon/www/include/configuration/configGenerate/oreon_pm.php

    Since I'm not a frenchspeaker the Documentation (the link for the "english-documentation" points on a french-document...) won't work on me.

    It is highly recommended for Gigabitinterfaces and TenGigabitinterfaces to use the snmpv2 Highspeedcounters (OID as below). I've tested this with a Service Checkintervall of 5 Minutes for Traffic-Interfaces. Oreon won't draw the right Trafficgraph with an Interfacethroughput of 200Mbit/s.

    This is logical. Because the SNMP-Default-Counter are 32Bit (4294967296) it is simpel to calculate:

    200mbit/s * 1000 * 1000 / 8 = 25000000 byte/s

    25000000 * 300 = 7500000000 byte/5min

    As you can see, the counter will jump over 0. At 200mbit/s it will work with the little Roundingtrick that Julio implemented in check_graph_traffic.pl .

    But if your Interface has a Throughput of 800Mbit/s the little Roundingtrick won't work.

    800mbit/s * 1000 * 1000 / 8 = 100000000 byte/s

    100000000 * 60 = 6000000000 byte/min

    With that kind of throughput, your Counter will run over 0 in less then one minute. Since one minute (60sec) is the minimum check interval the Roundingtrick won't work...

    If you have even more throughput (10 GE) you have to use the 64Bit-Counter.

    SNMP-OID:

    $ini["MIB2"]["IF_IN_OCTET"] = ".1.3.6.1.2.1.31.1.1.1.6";
    $ini["MIB2"]["IF_OUT_OCTET"] = ".1.3.6.1.2.1.31.1.1.1.10";

    Be careful, this will only work if the queried device supports SNMP Version 2 (Most Devices today support SNMP up to Version 3). You also have to set the value 2 with the -v flag of check_graph_traffic.pl (Default is 1).

    I also recommend to change the uptime OID for "other Devices":

    $ini["MIB2"]["UPTIME_OTHER"] = ".1.3.6.1.2.1.1.3.0";

    With that it will work on every cisco, hp, 3com...

    regards, Fantasio

    Comment


    • #3
      Thank you for your help :wink:
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment

      Working...
      X