Announcement

Collapse
No announcement yet.

check http

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check http

    bonjour,
    j'ai un souci que je ne comprends pas:

    je lance en local un check_http sur un serveur et j'obtient :
    ./check_http -I monip -S
    ./check_http: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

    depuis le serveur nagios j'obtiens, en lancant check_nrpe:
    ./check_nrpe -H monip -c check_http
    CHECK_NRPE: Error receiving data from daemon.

    en revanche si depuis mon serveur nagios avec un client nrpe egalement installé dessus et que je lance ./check_nrpe -H ipserver -c check_http,
    j'obtient un resultat concluant meme sans libssl.so.4.

    Mon problème est récurent sur tous les autres serveurs qui sont gérés ( environ 70 ) alors qu'ils ont tous les meme library que le serveur ...

    J'ajoute aussi que tous mes autres services marchent. Il n'y a que le check du http qui ne fonctionne pas .

    Voila,

    J'espere que mon explication n'est pas trop confuse

    merci d'avance

  • #2
    y a une mauvaise conf qq part car oreon se sert de nagios... Le "serveur nagios" est une autre machine c ca ? c'est alors qu'il te manque des lib

    error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory
    c'est ca a mon avis... pb de dependance pour les plugins..
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      je me re-explique

      je gere 70 servers.
      j'ai un server avec nagios/oreon dessus qui gere l'ensemble des servers a l'aide de nrpe. Tous les plugin marchent SAUF le check_http.

      J'ai installé nrpe sur le server qui contient nagios pour tester le http et la ca marche. je fais ./check_nrpe -H ip_server_nagios -c check_http et ca work nicely.

      En revanche, si je fais la meme manip mais que je change l'IP du server pour checker mes 69 autres servers, c la que ca chie et que ca me dit:
      CHECK_NRPE: Error receiving data from daemon.

      Je me suis dit: ok, ca marche pas avec le plugin nrpe, je vais donc tester le check_http direct sur le server de mon choix.
      je fais donc: ./check_http -H ip-server
      et j'obtiens:
      ./check_http: error while loading shared libraries: libssl.so.4: cannot open shared object file: No such file or directory

      je pige pas.
      comment je peux fixer ca si ya une histoire de dépendance ?

      Comment


      • #4
        je reviens un peu a la charge parce que la je suis bloqué et que je ne trouve aucune solution ...

        des idées ?

        Comment


        • #5
          que te dis ldd check_http?

          Perso ca donne ca:
          linux-gate.so.1 => (0xffffe000)
          libnsl.so.1 => /lib/libnsl.so.1 (0x4001f000)
          libresolv.so.2 => /lib/libresolv.so.2 (0x40035000)
          libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0x40049000)
          libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0x40079000)
          libc.so.6 => /lib/tls/libc.so.6 (0x4016a000)
          libdl.so.2 => /lib/libdl.so.2 (0x40280000)
          /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
          (Suse 9.2Pro)
          Donc on vois ici pas de pb de dépendance.
          Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

          Comment


          • #6
            voila ce que ca me dit

            ldd check_http
            libnsl.so.1 => /lib/libnsl.so.1 (0x4001a000)
            libresolv.so.2 => /lib/libresolv.so.2 (0x40030000)
            libssl.so.2 => /lib/libssl.so.2 (0x40042000)
            libcrypto.so.2 => /lib/libcrypto.so.2 (0x40072000)
            libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
            libdl.so.2 => /lib/libdl.so.2 (0x40146000)
            /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

            Comment


            • #7
              C'est le résultat sur le serveur qui ne veux pas lancer le plug_in? il n'y a pas d'erreur pourtant dans ldd.... je ne vois qu'un truc a priori ca serait les droits sur la lib, mais ca m'étonnerai ENORMEMENT .... là désolé je ne vois pas trop si même ldd ne dis rien....

              Ah si, tu as la solution du strace check_http, tu verras s'il essait de bien ouvrir le bon fichier et quand il pose problème.

              Le plug-in a été recomplié sur cette machine ou juste exporté depuis le serveur nagios?
              Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

              Comment


              • #8
                bon jsuis un boulet ...

                j'avais lancé le ldd check_http sur mon serveur nagios, la ou le chcek_http marche bien ... désolé ...

                j'ai relancé le check_http sur un serveur client nagios et j'obtient:

                ldd check_http
                libnsl.so.1 => /lib/libnsl.so.1 (0x4001a000)
                libresolv.so.2 => /lib/libresolv.so.2 (0x40030000)
                libssl.so.4 => not found
                libcrypto.so.4 => not found
                libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
                /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

                donc voila mes 2 belles erreurs ...

                comment puis-je faire maintenant pour avoir ces 2 lib ?

                Comment


                • #9
                  Ah c'est plus logique en effet

                  Bah là y a pas 10000 manière: apt-get, yast ou urpmi -i libssl ou assimilé

                  Google pour savoir laquelle il est question exactement libopenssl peut être?

                  Mais de toute manière, pourquoi lancer le chech_http sur un serveur distant? un problème de DMZ? Pourquoi aps directement sur le serveur Nagios? il sert à ca ce check
                  Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

                  Comment


                  • #10
                    bon ok ca marche now
                    merci pour ton aide

                    juste ptite question la

                    jobtient ca sur linterface graphique :
                    avec comme commande : check_http!-S ip-server
                    check_https
                    OK 15/04/05 04:55:51 12 s 1/2 Page is 483 characters

                    et quand je fais depuis el shell, j'obtient:

                    ./check_http -S ip-server
                    HTTP ok: HTTP/1.1 200 OK - 0.112 second response time |time= 0.112


                    any ideas ?

                    Comment


                    • #11
                      Ouah.... ah la non je ne vois pas trop d'où ca peut venir ca...
                      dans le checkcommande.cfg c'est le bon chemin/plugin vers check_http?
                      Normalement Nagios prend tout ce qui est à droite du | et le copie colle...
                      Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

                      Comment


                      • #12
                        SSL n'est pas disponible !

                        Bonjour,

                        Pour ma part, j'ai ceci :
                        ldd check_http
                        linux-gate.so.1 => (0xffffe000)
                        libnsl.so.1 => /lib/tls/i686/cmov/libnsl.so.1 (0xb7f0d000)
                        libresolv.so.2 => /lib/tls/i686/cmov/libresolv.so.2 (0xb7efa000)
                        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7ef5000)
                        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7dc4000)
                        /lib/ld-linux.so.2 (0xb7f32000)

                        Et du coup, ce message d'erreur :
                        ./check_http -I xxx.xxx.xxx.xxx -S
                        check_http: Option invalide - SSL n'est pas disponible

                        Comment


                        • #13
                          Salut,

                          tu as quel version des plugins nagios ?

                          Je regarde demain, il me semble que j'ai un problème similaire. Je te tiens au courant.
                          Centreon 2.x

                          Comment


                          • #14
                            Originally posted by WAtt View Post
                            Salut,
                            tu as quel version des plugins nagios ?

                            Je regarde demain, il me semble que j'ai un problème similaire. Je te tiens au courant.
                            La toute dernière :

                            Nagios 3.0.6
                            Centreon 2.0 (finale)
                            check_http v2053 (nagios-plugins 1.4.13)

                            Merci

                            Comment


                            • #15
                              J'ai essayé de recompilé les plugins avec /usr/local/src/nagios-3.0.6/configure
                              j'ai utilisé les options :
                              --with-openssl
                              --with-libssl
                              --with-libssl-dev

                              =/usr
                              =/usr/lib
                              =/usr/lib/ssl/

                              J'ai un peut tout tenté comme combinaison mais rien n'y fait !

                              Comment

                              Working...
                              X