Announcement

Collapse
No announcement yet.

check_ldap

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_ldap

    Salut tout le monde c'est encore moi...

    Je sais vous allez me dire que ce plugin a déja été traiter sur plusieurs forum. Mais la je bloque vraiment Vous allez voir

    Je ldap mon serveur samba. Bon en console je tape ./check_ldap -H X.X.X.X -b "uid=Administrateur,ou=users,dc=X;dc=X" =>
    LDAP OK - 0,007 secondes de temps de réponse|time=0,007442s;;;0,000000.
    Donc le plugin fonctionne super bien.

    Je passe sous oreon, je mets cette commande => ./check_ldap -H $HOSTADDRESS$ -b "uid=Administrateur,ou=users,dc=X;dc=X"

    Et j'associe ce service à mon serveur SAMBA qui a un annuaire LDAP. Résultat j'obtient le message "No Output!"
    Alors j'ai changé j'ai viré les " , puis remplacer par ' . Mais tjs rien...
    Voici un ls -l de mon plugin
    -rwsrwsr-x 1 root nagios 20848 2006-11-20 23:44 check_ldap

    Si quelq'un peut m'aider??? J'ai cherché sur les forums mais aucune ne résolut mon problème

  • #2
    Originally posted by LAW View Post
    Salut tout le monde c'est encore moi...

    Je sais vous allez me dire que ce plugin a déja été traiter sur plusieurs forum. Mais la je bloque vraiment Vous allez voir

    Je ldap mon serveur samba. Bon en console je tape ./check_ldap -H X.X.X.X -b "uid=Administrateur,ou=users,dc=X;dc=X" =>
    LDAP OK - 0,007 secondes de temps de réponse|time=0,007442s;;;0,000000.
    Donc le plugin fonctionne super bien.

    Je passe sous oreon, je mets cette commande => ./check_ldap -H $HOSTADDRESS$ -b "uid=Administrateur,ou=users,dc=X;dc=X"

    Et j'associe ce service à mon serveur SAMBA qui a un annuaire LDAP. Résultat j'obtient le message "No Output!"
    Alors j'ai changé j'ai viré les " , puis remplacer par ' . Mais tjs rien...
    Voici un ls -l de mon plugin
    -rwsrwsr-x 1 root nagios 20848 2006-11-20 23:44 check_ldap

    Si quelq'un peut m'aider??? J'ai cherché sur les forums mais aucune ne résolut mon problème
    J'espère que tu ne l'as pas saisi tel quel parce que Nagios aura absolument besoin du chemin absolu pour accéder au plugin (généralement fourni par la macro $USER1$).
    En outre, les permissions de ton fichier sont trop permissives : pourquoi avoir activé le suid root et le sgid nagios ? Ça ne sert absolument à rien !
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      Non j'ai pas mis toute la commande dans le poste mais si tu veux voila la commande complete.
      $USER1$/check_ldap -H $HOSTADDRESS$ -b 'uid=Administrateur,ou=users,dc=groupedeschalets;d c=com'

      J'ai activé le suid car je pensais que c'était un problème de droit d'exécution vu que en mode console je suis en root et que ca fonctionne.Et aussi parce que l'utilisateur qui execute le plugin sous console n'est pas le même que celui d'oreon.
      Mais bon même avant que j'active le suid ca ne fonctionnait pas ...

      Aucune idée???????

      Comment


      • #4
        Originally posted by LAW View Post
        Non j'ai pas mis toute la commande dans le poste mais si tu veux voila la commande complete.
        $USER1$/check_ldap -H $HOSTADDRESS$ -b 'uid=Administrateur,ou=users,dc=groupedeschalets;d c=com'

        J'ai activé le suid car je pensais que c'était un problème de droit d'exécution vu que en mode console je suis en root et que ca fonctionne.Et aussi parce que l'utilisateur qui execute le plugin sous console n'est pas le même que celui d'oreon.
        Mais bon même avant que j'active le suid ca ne fonctionnait pas ...
        Justement : il ne faut pas faire les tests en root mais TOUJOURS avec l'utilisateur de nagios. TOUJOURS !
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          Merci.
          Personne ne sait d'où vient le problème???

          Comment


          • #6
            J'ai trouvé une solution. Je la trouve un peu radicale mais bon j'avais fais la même manipulation avec un autre plugin.
            Donc je suis allé modifier le fichier /etc/sudoers puis rajouter cette ligne nagios

            ALL=NOPASSWD: /usr/lib/nagios/plugins/check_ldap *

            nagios correspondant à l'user qui va lancer le plugin. C'est radical non???
            L'important c'est que ca fonctionne.

            Comment


            • #7
              salut! j'au aussi le mem probleme... j'tester la commande en passant par l'user nagios, et ça fonctionne bien... sauf que sous nagios, j'ai toujours "no outpout" meme apres avoir appliquer ta solution...

              Comment

              Working...
              X