Announcement

Collapse
No announcement yet.

Graph Vide / check_graph_remote_storage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graph Vide / check_graph_remote_storage

    Bonjour,
    Voici mon petit problème de fin de semaine.
    Sans doute un truc tout bête, mais plus c'est gros moins ca se voit !

    Alors voila, je veux grapher l'espace disque d'une station XP.
    Pour cela j'utilise check_graph_remote_storage.
    Qui correspond à :
    $USER1$/check_graph_remote_storage.pl $HOSTADDRESS$ -d $ARG1$ -C $ARG2$ -w $ARG3$ -c $ARG4$ -v $ARG5$ -g -S $ARG6$
    Avec les arguments !2!public!80!90!1, dans Oreon/Monitoring/Service Details, j'obtiens :
    Disk OK - C:\ Label: Serial Number 3dc21e3 TOTAL: 74.52 Go USED: 10% : 7.586 Go

    En ligne de commande
    ./check_graph_remote_storage.pl -H 192.168.0.124 -d 2 -C public -w 70 -c 90 -v 1 -g
    Ce qui donne
    Disk OK - C:\ Label: Serial Number 3dc21e3 TOTAL: 74.52 Go USED: 10% : 7.586 Go

    Bon jusque la, je pense que tout va bien.
    J'ai associé ce service au modele de graph storage.
    Et lorsque je regarde Vue Oreon/SondesGraphique/Station_XP + Disk Graph ...
    Eh bien rien, nada, wallou, c'est vide.

    Et la je me demande bien ou je me suis raté.
    Last edited by stillcut; 15 March 2007, 13:42. Reason: RESOLU

  • #2
    As-tu un fichier /usr/local/oreon/rrd/? qui se crée et se remplit ... ?

    Sur ton graphe, as-tu un message XX/XX valeurs graphées ? Ou 0/0 ?

    Comment


    • #3
      Dans usr/local/oreon/rrd j'ai ca : 1_1.rrd 1_4.rrd 1_5.rrd 1.rrd
      Ds les vues oreon , je n'ai aucun graph, rien, c'est vide. quand je fais générer rien n'apparait.

      Comment


      • #4
        Et si tu vas dans Vues Oreon -> Sondes Graphiques ... ?

        Comment


        • #5
          Exactement pareil ! C'est désespérement vide.

          La je viens d'installer un check_graph_nt qui marche bien puisque dans Oreon il me remonte C: - total: 74.52 Gb - used: 7.62 Gb (10 pct) - free 66.90 Gb (90 pct).

          check_graph_nt
          $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v $ARG1$ -l $ARG2$ -s $ARG3$ -w $ARG4$ -c $ARG5$ -g -S $ARG6$
          !USEDDISKSPACE!C!None!80!90

          Par contre dans Oreon View , je le vois bien dans le menu déroulant mais si je fais généré, ca dégénere ! Y'a rien.

          Comment


          • #6
            Quelle version d'RRDTool utilises-tu ?

            Es tu sur d'avoir spécifié le bon chemin pour RRDs.pm lors de l'install d'Oreon ?

            Comment


            • #7
              RRds.pm se trouve à l'emplacement /usr/local/rrdtool/lib/perl comme prévu dans Oreon
              La version installée est rrdtool_1.049
              Last edited by stillcut; 5 March 2007, 15:09.

              Comment


              • #8
                Bon dans Oreon/Options/Options Générales/RRDTool, le chemin du bianire était erroné.
                J'ai donc fait which rrdtool pour trouver le chemin correct et corrigé celui-ci.
                Maintenant, j'ai bien un graphique ... mais vide.
                Pourtant sous le graph se trouve bien les valeurs correspondant réellement à l'espace utilisé sur le disque.

                Allez on persévère (et non pas on perd sévère).
                Merci à tous ceux qui m'ont aidé.
                Last edited by stillcut; 5 March 2007, 11:30.

                Comment


                • #9
                  Voila ce que j'obtiens



                  Y' a encore un truc qui m'echappe.

                  Comment


                  • #10
                    problème option -d??

                    Salut j'avais le même problème.
                    Dans mes arguments j'avais choisi ce que me proposait automatiquement oreon. Pour l'option -d oreon choisit automatiquement 1.
                    Vérifie en tapant en ligne de commande :
                    ./check_graph_remote_storage -H (IP de ton hôte) -C (ta communauté snmp) -v (ta version snmp) -s
                    Par exemple :
                    ./check_graph_remote_storage -H 19.0.0.210 -C public -v2 -s
                    normalement il affiche les numéros associés au disque.

                    Comment


                    • #11
                      la le pb ne vient pas des plugins mais de ton template avec des courbes blanches....
                      Julien Mathis
                      Centreon Project Leader
                      www.merethis.com |

                      Comment


                      • #12
                        courbes grises et noires

                        C'est bizarre parce que il y a aussi des courbes qui sont censées être grise et noire et elles n'apparaissent pas.

                        Comment


                        • #13
                          J'ai supprimé le service et la commande , les ai recrées , relancer tout le toutim.
                          Et ca marche !
                          Merci de vos conseils.

                          Comment

                          Working...
                          X