Announcement

Collapse
No announcement yet.

Exécution NRPE ... ou pas !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dalton63
    replied
    Bonjour,

    Pour régler le problème, il suffit d'ajouter l'adresse ip 192.168.142.133 qui est, je pense, l'ip de ton serveur oreon/nagios dans le nrpe.cfg sur ton poste windows.

    tu remplaces la ligne suivante dans nrpe.cfg :
    allowed_hosts=10.10.9.100,10.10.9.101,192.168.1.10 0

    par

    allowed_hosts=192.168.142.133, 127.0.0.1

    et ça devrait marcher.
    Voilà.

    Leave a comment:


  • johnbob
    replied
    Pour ce qui est du problème précédent, avec NRPE sous Windows, je ne l'ai toujours pas résolu à l'heure actuelle.

    C'est la seule erreur que je rencontre actuellement avec Nagios.
    Merci de me donner un coup de main

    Leave a comment:


  • johnbob
    replied
    Est-ce qu'il existe une petite doc sur la mise en place de NRPE_NT ?
    Je suis sous Windows Server 2003 pour effectuer mes tests.
    Ca ne fonctionne pas avec la version 0.8b

    Message d'erreur dans le fichier log

    Code:
    2007-04-26 15:05:16; 224; 1;Unable to start service: Failed to connect to service controller.
    2007-04-26 15:05:40; 1436; 4;Host 192.168.142.133 is not allowed to talk to us!
    2007-04-26 15:10:00; 1436; 4;Host 192.168.142.133 is not allowed to talk to us!
    2007-04-26 15:10:40; 1436; 4;Host 192.168.142.133 is not allowed to talk to us!
    Je ne vois pas exactement d'ou pourrai venir l'erreur ? (SSL?)

    A part ça, est-ce que le fonctionnement des plugins sous Windows est similaire au fonctionnement sous Linux ? (Sous rhel, nrpe parfait maintenant)

    Leave a comment:


  • johnbob
    replied
    Moi j'ai installé NRPE_NT sur un serveur 2003.
    J'ai renseigné le fichier de configuration, puis j'ai lancé le service nrpe.
    (j'ai juste décommenté les 3 commandes, et renseigner le bon répertoire)
    (j'ai lancé la commande nrpe_nt -i)
    Par contre je n'ai eu d'erreurs comme toi.

    Je voudrais maintenant savoir en local si les plugins qui sont en place checks bien.
    Je ne sais pas quelle commande taper ? ou comment le vérifier ?

    Leave a comment:


  • Pittocha
    replied
    NRTG, erreur windows

    je parle trop vite, ca marche mais j'ai un erreur qui survient au démarage du service nagios remote plugin executor dor Nt/W2K
    L'erreur survient si j'ai declaré ds mon fichier nrpe.cfg au moins un check (n'importe lequel)
    Code de l'erreur :
    Code:
    szAppName : NRPE_NT.exe     szAppVer : 0.8.0.0     szModName : unknown     
    szModVer : 0.0.0.0     offset : 0012e838
    Last edited by Pittocha; 24 April 2007, 11:55.

    Leave a comment:


  • Pittocha
    replied
    j'ai aussi la beta, et tout marche

    Leave a comment:


  • johnbob
    replied
    Merci pour mes réponses à moi même !


    (Dommage que ce forum ne soit pas plus actif...

    Leave a comment:


  • johnbob
    replied
    Je suivais bien le pdf sur la doc officielle de NRPE (dispo depuis ton lien Pittocha).

    Sauf que je travaillais avec la version 2.7.1 et non la dernière 2.8b1.
    (du coup les commandes "make install-deamon ..." ne fonctionnaient pas!)

    Je suis donc passé à la version supérieure, et toutes ces commandes passent bien.
    Effectivement, maintenant le démon NRPE n'est plus un fantôme, mais il est bien réel.
    Ce qui a pour conséquence de tout faire marcher avec la même configuration que j'avais mis en place auparavant.

    Encore une erreur bête! En fait je n'osais pas installer la version beta, mais c'est avec celle-ci que tous fonctionne automatiquement sans prise tête.

    Leave a comment:


  • Pittocha
    replied
    Non parce que je n'ai jamais vu la moindre trace de ce fameux démon NRPE !!!!
    moi ce que j'ai compris c kil faut relancer le service xinetd pour nrpe

    Moi j'ai suivis ce tuto http://nagios.sourceforge.net/docs/nrpe/NRPE.pdf
    qui est bien expliqué.
    (je suis sous red hat es4)

    et apres sur mon windows, j'ai editer le fichier nrpe.cfg
    et ds allowed_hosts= j'ai mis l'ip de mon nagios ...

    Voili, je pe pas t'en dire plus

    Leave a comment:


  • johnbob
    replied
    Je suppose que l'erreur viends du démon NRPE qui n'est surement pas démarré.
    Dans le fichier /etc/xinetd.d/nrpe :

    Code:
    server          = /usr/local/nagios/sbin/
    Dois-je préciser le nom du démon exacte ? Non parce que je n'ai jamais vu la moindre trace de ce fameux démon NRPE !!!!
    (Même en essayant plusieurs installations différentes : sources, rpm, versions, ...)

    En fait, ce qui m'aiderai le plus, ce sont des extarits de ficihiers cde conf de l'oragnisation de Nagios. J'ai déjà vu cette doc (sous forme d'une arbirescence PHP) sur le site NagiosExchange, mais impossible de retrouver le lien !

    Merci de m'aiguiller un peu ...:confused:

    Leave a comment:


  • johnbob
    started a topic Exécution NRPE ... ou pas !

    Exécution NRPE ... ou pas !

    Bonjour,
    A terme je souhaite installer pour mon parc informatique Nagios+Oreon, je suis en ce moment en phase de tests. (Un serveur + Un client)

    Nagios fonctionne correctement, c'est un bon début, maintenant j'essaye de mettre en place les plugins pour approfondir la chose. --> NRPE

    J'utilise un client RedHat EL 4,
    et j'ai installé Nagios Plugins + NRPE

    Je veux simplement arriver à faire fonctionner NRPE ... complexe :confused:
    Voilà ma démarche afin de tester d'abord le fonctionnement en local (machine 192.168.141.131).

    COMMANDES
    ./check_nrpe -H localhost -c check_load
    CHECK_NRPE: Error Could not complete SSl Handshake.

    ./check_nrpe -n -H localhost -c check_load
    CHECK_NRPE: Error receiving data from daemon.

    CONFIGURATIONS
    netstat -at
    Code:
    tcp        0      0 *:nrpe          *:*            LISTEN
    cat /etc/xinetd.d/nrpe
    Code:
    # default: on
            # description: NRPE
            service nrpe
            {
                    flags           = REUSE
                    socket_type     = stream
                    wait            = no
                    user            = nagios
                    server          = /usr/local/nagios/sbin/
                    server_args     = -c /usr/local/nagios/etc/nrpe.cfg --inetd
                    log_on_failure  += USERID
                    disable         = no
                    only_from       = 192.168.142.133
            }
    cat nrpe.cfg
    Code:
    pid_file=/var/run/nrpe.pid
    server_port=5666
    server_address=192.168.142.131
    nrpe_user=nagios
    nrpe_group=nagios
    allowed_hosts=192.168.142.133
    dont_blame_nrpe=0
    debug=1
    command_timeout=60
    connection_timeout=300
    
    command[check_users]=/usr/local/nagios/libexec/check_users -w 5 -c 10
    command[check_load]=/usr/local/nagios/libexec/check_load -w 15,10,5 -c 30,25,20
    command[check_disk1]=/usr/local/nagios/libexec/check_disk -w 20 -c 10 -p /dev/hda1
    command[check_disk2]=/usr/local/nagios/libexec/check_disk -w 20 -c 10 -p /dev/hdb1
    command[check_zombie_procs]=/usr/local/nagios/libexec/check_procs -w 5 -c 10 -s Z
    command[check_total_procs]=/usr/local/nagios/libexec/check_procs -w 150 -c 200
    
    command[check_users]=/usr/local/nagios/libexec/check_users -w $ARG1$ -c $ARG2$
    command[check_load]=/usr/local/nagios/libexec/check_load -w $ARG1$ -c $ARG2$
    command[check_disk]=/usr/local/nagios/libexec/check_disk -w $ARG1$ -c $ARG2$ -p $ARG3$
    command[check_procs]=/usr/local/nagios/libexec/check_procs -w $ARG1$ -c $ARG2$ -s $ARG3$

    cat /etc/hosts.allow

    Code:
    all : all : allow
    J'ai lu plusieurs tutoriels et plusieurs docs, sans trouver la solution a mon problème.
    L'erreur est surement toute bête, mais si quelqu'un pouvait m'orienter ... je serai soulagé !!!

    ============================ >>
    Soulagé :-D ca marche bien sous Linux
    Solution : utilisation de la dernière version beta NRPE + lecture assidue de la doc NRPE officielle + mêmes version des plugins Serveur/Clients

    Mais sous Windows mainteant ? NRPE_NT ??? (en bas du topic)
    Last edited by johnbob; 26 April 2007, 15:42.
Working...
X