Announcement

Collapse
No announcement yet.

Oreon arguments "Unknown -S Service ID"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • anouar
    replied
    meme probleme, j'ai remarqué aussi que ya deux points rouge et bleu à l'extremité droite du graphe.
    je crois c à cause de perfparse!!!!
    des suggestions
    merci

    Leave a comment:


  • flox
    replied
    Merci JP13,
    la commande:

    Code:
    /usr/bin/perl $USER1$/check_ts.pl -H $HOSTADDRESS$ -i $ARG1$ -w $ARG2$ -c $ARG3$ -C public  -v 2c -g -S $ARG4$
    permet re récupéré la valeur, cependant il n'y a aucun graph.

    Des idées?

    Leave a comment:


  • JP13
    replied
    J'avais eu le même pb: en fait il faut que tu rajoute /usr/bin/perl dans ta commande

    Dans Oreon, configuration commande...

    Tu prend ta commande et tu place : /usr/bin/perl $USER1$ -H $HOSTADDRESS$......

    Sauvegarde et regénère les fichiers , normalement ca devrait marché

    Leave a comment:


  • wistof
    replied
    Hello,

    comment as-tu nommé ta commande dans Oreon ?

    Leave a comment:


  • flox
    replied
    Oula je suis fatigué moi lol,
    cependant meme avec ces nouveaux paramètres j'ai une erreur:

    Code:
    **ePN /usr/share/nagios2/plugins/eventhandlers/check_ts.pl: "Option S requires an argument".
    pourtant le paramètre passer et correcte-S $ARG4$

    ?

    Leave a comment:


  • clementthersiquel
    replied
    Je comprend pas pourquoi tu passe en parametre des variables qui sont deja renseignee dans ta commande. Il y a en effet 4 arguments dans ta commande dont un comme tu l'as dit qu'il ne faut pas renseigner donc il en reste 3.
    Tes parametres doivent etre:
    Code:
    !10101!90!95

    Leave a comment:


  • flox
    started a topic Oreon arguments "Unknown -S Service ID"

    Oreon arguments "Unknown -S Service ID"

    Bonjour,
    j'essai de modifier le script "check_graph_traffic.pl", afin qu'il puisse comptabiliser le traffic total d'un switch.
    Voila ce que j'ai fait:

    Code:
    cp check_graph_traffic.pl check_graph_sw.pl
    chmod 777 check_graph_sw.pl
    chown www-data:nagios check_graph_sw.pl
    A cette étape je n'est pas encore toucher au script en lui meme mais j'ai deja des probleme.

    En effet si je test le script:
    - Il fonctionne bien en ligne de commande
    - Il ne fonctionne pas sous oreon

    erreur:
    Code:
    Unknown -S Service ID expected... or it doesn't exist, try another id - number
    ma commande:
    Code:
    $USER1$/check_ts.pl -H $HOSTADDRESS$ -i $ARG1$ -w $ARG2$ -c $ARG3$ -C public  -v 2c -g -S $ARG4$
    mes paramètres:
    Code:
    !10101!90!95!public!2c
    Si je remplace le $ARG4$ par une valeur le j'observe le chiffre mais pas le graph

    -> le -S comme --ServiceID, est normalement délivré automatiquement par Oreon.

    Je précise que le script de base sur lequel j'ai basé ma copie fonctionne très bien, avec les graphs.

    Si quelqu'un à une idée

    Merci d'avance


    sur un problème:
Working...
X