Announcement

Collapse
No announcement yet.

check_graph_remote_storage KO ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_graph_remote_storage KO ?

    bonjour à tous,

    alors la , je pige plus rien, j'ai tous bien fait comme il est demandé
    j'ai créer une commande : check_graph_disk , dont les parametres sont ceux-ci:
    $USER1$/check_graph_remote_storage.pl -H $HOSTADDRESS$ -C [my community] -d $ARG1$ -w $ARG2$ -c $ARG3$ -f -g -S $ARG4$

    j'ai ensuite créer un service check_remote_disk avec ceci comme parametres:
    !4!80!90

    la j'ai bien l'ID de service crée par OREON, mais par contre mon check n'est jamais executé
    dans le fichier /etc/nagios/services.cfg j'ai ça :

    # 'check_remote_disk' service definition 4
    # ID_OREON:'74'
    define service{
    host_name [my hostname]
    service_description check_remote_disk
    is_volatile 0
    check_command check_graph_disk!4!80!90!28_74
    max_check_attempts 10
    normal_check_interval 5
    retry_check_interval 1
    check_period 24x7
    notification_interval 960
    notification_period 24x7
    notification_options w,u,c,r
    notifications_enabled 1
    contact_groups admins
    stalking_options o,w,u,c
    }

    et la commande n'est jamais exécuté et dans mes logs j'ai ça :
    Jun 11 11:06:56 pegase nagios: Warning: The check of service 'check_remote_disk' on host
    [my hostname] looks like it was orphaned (results never came back). I'm scheduling an immediate check of the service...

    et rebelotte, la commande ne s'executé jamais, les droits sur le script sont :
    -rwxrwxr-x 1 apache nagios 10954 jun 7 13:52 check_graph_remote_storage.pl

    comme tous les autres plugins, et c'est le seul qui ne s'execute pas

    help !!
    il en va dans ma santé psychologique

  • #2
    Salut, ca n'a rien a voir mais as-tu testé en ligne de commande?

    # ./check_graph_remote_storage.pl -H IpDeTaMachine -C TaCommunaute -d 4 -w 80 -c 90

    Comment


    • #3
      absolument et voila ce que j'ai comme réponse pour exemple :
      ./check_graph_remote_storage.pl -H [hostname] -C [my community] -d 4 -w 80 -c 90 -f -g -S 28_68

      j'ai ça comme réponse:
      Disk OK - / TOTAL: 59.039 Go USED: 13% : 8.238 Go|size=63393075200o used=8845418496;707633479680;796087664640

      Comment


      • #4
        Salut, en relisant bien il y a un truc qui colle pas :
        tu utilises check_graph_remote_storage.pl et tes log parlent de :

        'check_remote_disk'

        il n'y a aucun rapport entre les 2...

        Comment


        • #5
          c'est normal :-)
          check_remote_disk c'est le nom du service que j'ai crée et qui lie la commande check_graph_remote_storage.pl a mon serveur avec les parametres qui vont bien.

          Comment


          • #6
            LOL, désolé

            Sinon il y quoi dans ton 'check_command check_graph_disk' ??

            Comment


            • #7
              y'a ça :
              $USER1$/check_graph_remote_storage.pl -H $HOSTADDRESS$ -C [my community] -d $ARG1$ -w $ARG2$ -c $ARG3$ -f -g -S $ARG4$

              Comment


              • #8
                Salut , j'essai d'aider mais je me rend compte que j'ai bien fumé en fait

                T'as essayé de rajouter l'option -v?

                -v $ARGn$

                Pour la version snmp.

                Comment


                • #9
                  Re, je viens de tester ta commande et ca marche chez moi...je vois pas d'ou vient le probleme. C'est pas une erreur de definition ni de droit.

                  Comment


                  • #10
                    pareil, j'ai tous cassé, tous refait et toujours pareil, j'avoue ne rien comprendre

                    Comment


                    • #11
                      :evil: :evil:

                      j'ai trouvé
                      il me manquais le -v1 dans ma commande
                      bon maintenant ça marche, mais il me manque les graphs
                      je continue a chercher.

                      Comment


                      • #12
                        Salut, content pour toi. Pour les graphes je te conseille de suivre les procédures disponibles sur le wiki.
                        Tu devras :
                        1/ Patcher oreon 1.4 jusqu'au patch 5 (reprend le wiki depuis tout en bas)
                        2/ Activer perfdata
                        3/ Configurer ODS

                        Bon courage

                        Comment

                        Working...
                        X