Announcement

Collapse
No announcement yet.

check_centreon_snmp_loadaverage

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_centreon_snmp_loadaverage

    J'ai un soucis avec ce plugin : L'hote a bien été crée, renvoie les infos de host-alive et est bien UP, mais je me prends ca lors d'un check cpu :

    ./check_centreon_snmp_loadaverage -H 192.168.65.103 -c 2,4,6 -w 1,3,5
    UNKNOWN: No response from remote host '192.168.65.103'.
    suse-exp:/usr/local/nagios/libexec # ./check_centreon_snmp_loadaverage -H localhost -c 2,4,6 -w 1,3,5
    load average: 0.08, 0.30, 0.36.|load1=0.08 load5=0.30 load15=0.36
    Y'a t-il un service specifique a lancer sur l'hote ? Une idée de ce qui ne va pas ? merci d'avance.
    Centreon 1.4
    Nagios 2.9
    Suse 10.2

  • #2
    Il semble qu'il n'y ait pas de serveur SNMP sur le serveur contacté. Il y a, soit un démon à lancer (Linux/UNIX), soit un service à démarrer (Win*) sur le serveur cible.

    Comment


    • #3
      C'est une machine Ubuntu, le démon SNMP est bien lancé. One idea ?
      Centreon 1.4
      Nagios 2.9
      Suse 10.2

      Comment


      • #4
        As tu essayé un petit "snmpwalk" depuis ta machine Nagios/Centreon vers le serveur cible ?
        Si tu n'arrives pas à avoir une liste de valeurs, ce n'est pas la peine d'aller chercher plus loin, il y a un problème de communication. Sinon, reviens me voir :-)

        Comment


        • #5
          Et puis si tu pouvais préciser l'exemple que tu donnes, car je ne comprends pas sur quel serveur tu te trouves pour la première et la seconde ligne.

          Comment


          • #6
            snmpwalk -v 1 -c public 192.168.65.103
            Timeout: No Response from 192.168.65.103


            c'est une ubuntu basique, avec le paq snmpd qui tourne.
            Centreon 1.4
            Nagios 2.9
            Suse 10.2

            Comment


            • #7
              Alors, c'est qu'il doit y avoir quelque chose à changer dans la configuration de snmpd (/etc/snmp/snmpd.conf ou quelque chose d'approchant).
              J'ai, entre autres, ce genre de ligne:

              view systemview included .1

              pour donner accès en lecture à l'arborescence entière.

              Par contre, mon aide va être plus réduite, car je n'y connais pas grand chose en configuration snmpd.

              Comment


              • #8
                wé j'ai bien une ligne qui ressemble a ca pourtant :

                view all systemview included .1
                view system included .iso .org .dod etc..
                Centreon 1.4
                Nagios 2.9
                Suse 10.2

                Comment


                • #9
                  Et dans les "access" ?
                  Moi j'ai ceci qui fait le lien entre un groupe et la visibilité:

                  access notConfigGroup "" any noauth exact systemview none none

                  Comment


                  • #10
                    c'est dingue ca. J'ai rajouté cette option et redemarrer, rien n'y fait
                    Centreon 1.4
                    Nagios 2.9
                    Suse 10.2

                    Comment


                    • #11
                      Fais un 'netstat -anup |grep snmpd'

                      Si ton demon ecoute sur l'ip 127.0.0.1 tu dois editer le fichier /etc/default/snmpd : a la ligne "SNMPDOPTS" enleve le "127.0.0.1" et ensuite relance ton demon

                      Comment


                      • #12
                        Bien en effet ca ecoutait juste l interface locale, mais meme en modifiant j'ai tjs l'impression que ca marche aps (et le netstat me retourne bien 0.0.0.0 cette fois ci ) :

                        Code:
                        ./check_centreon_snmp_loadaverage -H 192.168.65.103 -c 2,4,6 -w 1,3,5
                        UNKNOWN: No response from remote host '192.168.65.103'.
                        Centreon 1.4
                        Nagios 2.9
                        Suse 10.2

                        Comment


                        • #13
                          la ça semble etre un probleme de communauté snmp. Rajoute l'option "-C ta_communauté".

                          Comment

                          Working...
                          X