Announcement

Collapse
No announcement yet.

[REGLE] Pb RRD Oreon 1.2.2RC2 Nagios 1.2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • jerome
    replied
    Rooooooaaaaaaaahhhhhhh Merci Wistof!!!!

    Effectivement, il n'y avait plus le -S $ARG5$, pourtant il me semblait bien l'avoir mis ^^

    Merci pour tout, ce fut epique mais pas ininterressant, je comprends mieux le fonctionnement de la bete maintenant


    Je regle le prob!

    Merci à tous ceux qui m'ont aider à solutionner ce problème!

    Leave a comment:


  • wistof
    replied
    si tu as '1.rrd' c'est que ta 'check_command' 'check_graph_nt' n'est pas compléte, par exemple, tu dois avoir quelque chose du genre :
    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v $ARG1$ -l $ARG2$ -w $ARG3$ -c $ARG4$ -g -S
    car '1' est la valeur par défaut si l'option '-S' est spécifié sans argument

    peux-tu nous redonner la syntaxe de ton 'check_graph_nt', ainsi que le bloc coorespondant à ton service dans le fichier 'services.cfg' (pour voir se que génére Oreon)

    Leave a comment:


  • jerome
    replied
    Des nouvelles du front

    Nagios Plugins 1.4.1 installés, et meme fonctionnels!

    NSclient marche bien sur mes client windows.
    Maintenant j'ai le meme message que toi Wistof :
    CPU Load 0% (10 min average)

    Par contre, toujours pas de rrd à l'horizon

    Plus de message d'erreur dans nagios.log
    Mais dans apache, l'eternel :
    ERROR: opening '/usr/local/oreon/rrd/133.rrd': No such file or directory
    Je confirme, il n'y a toujours que le 1.rrd.

    Leave a comment:


  • jerome
    replied
    allé c'est parti alors

    Leave a comment:


  • templuche
    replied
    Je dois le reinstaller depuis le pack de plugins nagios 1.4 tu penses?
    Oui, je te le conseille très fortement. De toute façon tu n's plus rien à perdre maitenant
    Surtout que la version 1.4.1 est sortie cette nuit...

    Leave a comment:


  • wistof
    replied
    sauf erreur de ma part, check_nt fonctionne uniquement avec pNsclient.

    Essaye d'installer les plugins Nagios 1.4, sinon au pire des cas, on doit retravailler le plugin graph check_nt

    Leave a comment:


  • jerome
    replied
    pour pNSCLient, je parle du formatage de reponse différent par rapport à la reponse qu'obtient wistof.

    Effectivement mon check_nt renvoie :
    check_nt (nagios-plugins 1.3.1) 1.7

    Je dois le reinstaller depuis le pack de plugins nagios 1.4 tu penses?

    Leave a comment:


  • templuche
    replied
    Bonjour,

    Ca vient peut etre de ca, car moi j'utilise pNSCLient.
    nsclient marche bien car tu as eu une réponse. C'est un problème de configuration ou du plugin graphique.

    Tu dis utiliser les plugins 1.4 mais la version retournée par check_nt est la 1.3.1??? Moi j'ai ça:
    Code:
    check_nt (nagios-plugins 1.4) 1.39

    Leave a comment:


  • jerome
    replied
    OK, merci templuche, t'as l'oeil!!!!

    C'est modifié et ca marche pas mieux...mais j'ai encore un nouveau message....si ca continue, le matin quand je vais me lever, la premiere question que jevais me poser sera : vite, c'est quoi le nouveau message

    Wistof => c'est quoi comme version de NRPE Windows que tu utilises?Ca vient peut etre de ca, car moi j'utilise pNSCLient.

    Leave a comment:


  • templuche
    replied
    Bonjour,

    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v $ARG1$ -l $ARG2$ -w $ARG3$ -c $ARG4$ -g -S $ARG5$ !CPULOAD!10,75,90!50!70
    Si je comprends bien, cette ligne est la ligne complète définie dans la partie Configuration->command->check->add. C'est cela? Il ne faut pas passer !CPULOAD!10,75,90!50!70 dans la partie Configuration->command->check->add mais lorsque tu définis ton service ou ton service template, dans la case check_command_arguments.

    Leave a comment:


  • wistof
    replied
    hummmm...

    chez moi, j'ai ça :
    CPU Load 2% (10 min average)
    il me semble qu'on avait déja rencontré le problème

    -> http://www.oreon.org/Forum/viewtopic.php?p=3450

    qui n'avait pas été résolu d'ailleurs...

    je regarde ça de plus près ce soir....

    Leave a comment:


  • jerome
    replied
    Ca m'a l'air tout bon :

    [email protected]:/usr/local/nagios/libexec$ ./check_nt -H 10.1.10.211 -p 1248 -v CPULOAD -l 10,75,90 -w 50 -c 70
    CPU Load (10 min. 14%)

    Leave a comment:


  • wistof
    replied
    ça m'a l'air correct...

    si tu lances 'check_nt' en ligne de commande avec les arguments spécifiés, ça donne quoi ?

    Leave a comment:


  • jerome
    replied
    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v $ARG1$ -l $ARG2$ -w $ARG3$ -c $ARG4$ -g -S $ARG5$ !CPULOAD!10,75,90!50!70

    On va bien finir par y'arriver lol

    Leave a comment:


  • wistof
    replied
    Originally posted by jerome
    Could not parse arguments
    quels sont tes arguments ?

    Leave a comment:

Working...
X