Announcement

Collapse
No announcement yet.

check_snmp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_snmp

    Hello,
    I have a problem with check_snmp command.
    Agent snmp properties:
    address : 192.168.1.114
    port : 4700
    community : myCommunity

    So i do that :
    Code:
    [[email protected] libexec]$ ./check_snmp -H 192.168.1.114 -p 4700 -C myCommunity -P 2c -o 1.3.6.1.4.1.4890.1.1.14.0
    SNMP problème - Pas de données reçues de l'hôte
    Commande: /usr/bin/snmpget -t 1 -r 5 -m '' -v 2c -c myCommunity 192.168.1.114:4700  1.3.6.1.4.1.4890.1.1.14.0
    Whereas when i do a snmpget request it works.
    So where is the problem ?

    Thanks

  • #2
    Isn't it .1.3.6.1.4.1.4890.1.1.14.0 instead?
    Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

    Comment


    • #3
      No,
      that change anything

      Comment


      • #4
        Can you try with snmp v1?
        Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

        Comment


        • #5
          yes i try with snmp v1 and with a default agent and it doesn't work
          what can i do

          Comment


          • #6
            Can you give us the command line you use for the snmpget?
            Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

            Comment


            • #7
              First thanks for your answers.

              snmpget request for system description (default snmp agent) :
              Code:
              [email protected]:~$ snmpget -v 2c -c public localhost 1.3.6.1.2.1.1.1.0
              SNMPv2-MIB::sysDescr.0 = STRING: Linux stag008 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686
              check_snmp request :
              Code:
              [[email protected] libexec]$ ./check_snmp -H localhost -o 1.3.6.1.2.1.1.1.0
              SNMP problème - Pas de données reçues de l'hôte
              Commande: /usr/bin/snmpget -t 1 -r 5 -m '' -v 1 -c public 127.0.0.1:161  1.3.6.1.2.1.1.1.0

              Comment


              • #8
                And if you launch:
                /usr/bin/snmpget -t 1 -r 5 -m '' -v 2c -c public 127.0.0.1:161 1.3.6.1.2.1.1.1.0
                or
                /usr/bin/snmpget -t 1 -r 5 -v 2c -c public 127.0.0.1:161 1.3.6.1.2.1.1.1.0
                ?
                Auteur de Shinken, outil de supervision compatible avec Nagios et orientée supervision distribuée hautement disponible et mulitplateforme.

                Comment


                • #9
                  I have already try and it work.
                  I think my check_snmp plugin is broken because i try to do that (wrong oid) :
                  Code:
                  ./check_snmp -H localhost -o 465465464646
                  and i have the same error.So maybe check_snmp doesn't take the parameter oid.
                  Where can i found the check_snmp plugin ?
                  Can you send me the plugin if it work for you ?

                  Comment


                  • #10
                    Originally posted by mac_fly65 View Post
                    First thanks for your answers.

                    snmpget request for system description (default snmp agent) :
                    Code:
                    [email protected]:~$ snmpget -v 2c -c public localhost 1.3.6.1.2.1.1.1.0
                    SNMPv2-MIB::sysDescr.0 = STRING: Linux stag008 2.6.24-19-generic #1 SMP Fri Jul 11 23:41:49 UTC 2008 i686
                    check_snmp request :
                    Code:
                    [[email protected] libexec]$ ./check_snmp -H localhost -o 1.3.6.1.2.1.1.1.0
                    SNMP problème - Pas de données reçues de l'hôte
                    Commande: /usr/bin/snmpget -t 1 -r 5 -m '' -v 1 -c public 127.0.0.1:161  1.3.6.1.2.1.1.1.0
                    Is your SNMP port is set to 4700 ?
                    Raphaël 'SurcouF' Bordet
                    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
                    Dons Paypal

                    Comment


                    • #11
                      Hello,

                      i have an agent on 4700 udp port and and an other with default port(161).
                      But i don't understand why do you want to know that?

                      tchao.

                      Comment

                      Working...
                      X