Announcement

Collapse
No announcement yet.

Erreur "Can't locate utils.pm "

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Erreur "Can't locate utils.pm "

    Bonjour a vous tous,

    Je viens tous juste de finir l'installation d'Oreon, et j'ai déja un probleme que je n'arrive pas a resoudre malgré plusieurs recherches.
    J'utilise une Debian sarge avec Oreon Version v1.2.3-RC1.
    L'install c'est bien passée mais lorsque j'essai en ligne de commande de lancer un plugin par exemple:
    /usr/local/nagios/libexec#./check_graph_nt.pl
    j'ai une erreur :
    Can't locate utils.pm in @INC (@INC contains: /usr/local/nagios/libexec /etc/perl /usr/local/lib/perl/5.8.7 /usr/local/share/perl/5.8.7 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at ./check_graph_nt.pl line 29.
    BEGIN failed--compilation aborted at ./check_graph_nt.pl line 29.
    Je n 'ai pas un probleme de droit d'apres moi mais la je coince ...
    Merci de votre aide

  • #2
    as tu bien installé les plugins nagios ?

    utils.pm est dans les plugins nagios
    StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
    Dons Paypal

    Comment


    • #3
      oui je pense qu'ils sont bien installé.
      Par contre apres quelques recherches je crois que mon probleme viens de perl Config::Inifiles mais je ne sais pas quoi faire de plus!!!!
      J'ai bien le fichier Utils.pm dans ma machine!!!!
      Je continu a chercher et merci pour votre aide .

      Comment


      • #4
        http://forum.oreon-project.org/viewt...onfig+inifiles
        StatusMap Module - NDO Tools Module - ImportCSV Module - SNMP-UI Module - PDFReports Module
        Dons Paypal

        Comment


        • #5
          J'avais deja essayé avec cpan>install Config::Infiles.
          Mais ca me donne toujours la meme erreur donc ca ne dois pas etre ca le probleme!
          je ne decourage pas!

          Comment


          • #6
            Originally posted by barachno
            J'avais deja essayé avec cpan>install Config::Infiles.
            Mais ca me donne toujours la meme erreur donc ca ne dois pas etre ca le probleme!
            je ne decourage pas!
            soit tu précèdes ta commande de la variable d'environnement PERL5LIB, soit tu édites fichier oreon.pm qui doit définir l'emplacement des plugins nagios et donc de utils.pm:

            $ PERL5LIB=$PERL5LIB:/usr/lib/nagios/plugins /usr/lib/nagios/plugins/check_snmp ...
            Raphaël 'SurcouF' Bordet
            Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
            Dons Paypal

            Comment


            • #7
              Merci je vais essayer, mais avant je refais une install car j'ai fait pas mal de degat avec CPAN!!!!!!
              Je reinstall et je vous tiens au courant rapidement.
              Merci beaucoup

              Comment


              • #8
                J'ai essayé les 2 solutions et je me retrouve toujours avec cette fichu erreur.
                Je continu a chercher des que j'ai des news je vous tiens au courant
                merci

                Comment


                • #9
                  Tu as bien géréer ton fichiers des sondes dans Options>Sondes ?

                  Tu n'as pas de pb de chemin d'accès dans Options>Générales ?
                  Ubuntu 8.04
                  Nagios 3.2 + nagios-plugins-1.4.14
                  ndoutils-1.4b9
                  Centreon 2.1.8
                  centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                  Comment


                  • #10
                    Oui j'ai verifié mon fichier de sondes et bien géneré et tous mes chemins dans le menu general sont ok!!!!
                    ne me manque ,t' il pas une librairie.
                    Pourtant j'ai suivi la procedure d'install a la lettre.

                    Comment


                    • #11
                      Bonjour,

                      Fais nous un:
                      Code:
                      ls -l /usr/local/nagios/libexec

                      Comment


                      • #12
                        Je pensais que j'avais un probleme de droit donc j'ai fais un chmod 777
                        mais ca ne change rien!!!

                        La commande me donne ca :
                        supervision:/# ls -l /usr/local/nagios/libexec
                        total 244
                        -rwxrwxrwx 1 david david 5103 2005-11-04 12:17 check_graph_cisco_nb_connect.pl
                        -rwxrwxrwx 1 www-data www-data 6568 2005-11-04 11:26 check_graph_dell_temperature.pl
                        -rwxrwxrwx 1 www-data www-data 5885 2005-11-04 11:26 check_graph_http.pl
                        -rwxrwxrwx 1 www-data www-data 6047 2005-11-04 12:17 check_graph_load_average.pl
                        -rwxrwxrwx 1 www-data www-data 15252 2005-11-04 13:09 check_graph_nt.pl
                        -rwxrwxrwx 1 www-data www-data 5518 2005-11-04 12:17 check_graph_ping.pl
                        -rwxrwxrwx 1 www-data www-data 6735 2005-11-04 12:17 check_graph_process.pl
                        -rwxrwxrwx 1 www-data www-data 9607 2005-11-04 12:17 check_graph_remote_storage.pl
                        -rwxrwxrwx 1 www-data www-data 4019 2005-11-04 11:26 check_graph_tcp.pl
                        -rwxrwxrwx 1 www-data www-data 13235 2005-11-04 11:26 check_graph_traffic2.pl
                        -rwxrwxrwx 1 www-data www-data 11299 2005-11-04 12:17 check_graph_traffic.pl
                        -rwxrwxrwx 1 www-data www-data 6023 2005-11-04 11:26 check_graph_uptime.pl
                        -rwxrwxrwx 1 www-data www-data 15856 2005-11-04 11:26 check_snmp_cpfw.pl
                        -rwxrwxrwx 1 www-data www-data 17741 2005-11-04 11:26 check_snmp_load.pl
                        -rwxrwxrwx 1 www-data www-data 17287 2005-11-04 11:26 check_snmp_mem.pl
                        -rwxrwxrwx 1 www-data www-data 20192 2005-11-04 11:26 check_snmp_process.pl
                        -rwxrwxrwx 1 www-data www-data 23443 2005-11-04 11:26 check_snmp_storage.pl
                        -rwxrwxrwx 1 www-data www-data 11978 2005-11-04 11:26 check_snmp_win.pl
                        -rwxrwxrwx 1 root root 1460 2005-11-04 13:11 oreon.conf
                        -rwxrwxrwx 1 root root 5004 2005-11-04 13:30 oreon.pm
                        -rwxrwxrwx 1 root root 3188 2005-11-04 12:20 Utils.pm

                        Comment


                        • #13
                          Bonjour,

                          C'est pas Utils.pm mais utils.pm !!!

                          Comment


                          • #14
                            Oui je sais mais j'avais deja modifié Utils.pm en utils.pm
                            mais j'ai cette erreur maintenant :

                            supervision:/usr/local/nagios/libexec# ./check_graph_nt.pl
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 69.
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 75.
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 84.
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 89.
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 106.
                            Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 144.
                            BEGIN not safe after errors--compilation aborted at ./check_graph_nt.pl line 150.

                            donc je ne sais pas quoi faire...
                            Merci pour votre aide...

                            Comment


                            • #15
                              J'ai refais une install sur mon portable avec comme difference c'est Ubuntu le systeme et j'ai mis php5.
                              La par contre ya pas de probleme tout marche bien mais par contre sur mon portable ou ca marche les plugins sont dans :
                              /usr/lib/nagios/plugins/
                              et dans mon server c'est dans :
                              /usr/local/nagios/libexec et la se ne marche pas???

                              Et j'ai lancer les meme installation.????
                              donc j'ai deja avancé sur mon probleme!!

                              Comment

                              Working...
                              X