Announcement

Collapse
No announcement yet.

Erreur "Can't locate utils.pm "

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • _kezar_
    replied
    Perso j'ai une ubuntu et j'ai eu exactement le même problème.
    J'ai ajouté export PERL5LIB="/usr/lib/nagios/plugins/"; a la fin de mon bash.bashrc (dans /etc) je sais pas si toi ça va t'aider mais moi j'ai plus eu de problème pour ça.

    Leave a comment:


  • julio
    replied
    sinon donne lui des adresse en HTTP en donnant bien le proxy si t'en as un et apres sur le site de cpan choppe les adresse de site cpan en http et donne lui quand il te les demande, ou alors direct dans son fichier de conf.

    Leave a comment:


  • wistof
    replied
    hello,

    vérifie que ta machine peut faire du ftp (peut que tu as un firewall en amont qui te bloque)

    Leave a comment:


  • nath972
    replied
    Bonjour

    j'ai le meme souci mais et la premiere mise en route de CPAN je plante sur

    You have no /root/.cpan/sources/MIRRORED.BY
    I'm trying to fetch one
    CPAN: LWP::UserAgent loaded ok
    Fetching with LWP:
    ftp://ftp.perl.org/pub/CPAN/MIRRORED.BY
    Fetching with LWP:
    ftp://ftp.perl.org/pub/CPAN/MIRRORED.BY.gz
    Fetching with Net::FTP:
    ftp://ftp.perl.org/pub/CPAN/MIRRORED.BY
    Timeout at /usr/lib/perl5/5.8.3/Net/FTP.pm line 490

    Avez-vous une idée ? J'avais, dans une précedente install, mis a jour les module a la main et ça m'avait tous planté.

    Leave a comment:


  • barachno
    replied
    J'ai refais une install sur mon portable avec comme difference c'est Ubuntu le systeme et j'ai mis php5.
    La par contre ya pas de probleme tout marche bien mais par contre sur mon portable ou ca marche les plugins sont dans :
    /usr/lib/nagios/plugins/
    et dans mon server c'est dans :
    /usr/local/nagios/libexec et la se ne marche pas???

    Et j'ai lancer les meme installation.????
    donc j'ai deja avancé sur mon probleme!!

    Leave a comment:


  • barachno
    replied
    Oui je sais mais j'avais deja modifié Utils.pm en utils.pm
    mais j'ai cette erreur maintenant :

    supervision:/usr/local/nagios/libexec# ./check_graph_nt.pl
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 69.
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 75.
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 84.
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 89.
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 106.
    Global symbol "%ERRORS" requires explicit package name at ./check_graph_nt.pl line 144.
    BEGIN not safe after errors--compilation aborted at ./check_graph_nt.pl line 150.

    donc je ne sais pas quoi faire...
    Merci pour votre aide...

    Leave a comment:


  • templuche
    replied
    Bonjour,

    C'est pas Utils.pm mais utils.pm !!!

    Leave a comment:


  • barachno
    replied
    Je pensais que j'avais un probleme de droit donc j'ai fais un chmod 777
    mais ca ne change rien!!!

    La commande me donne ca :
    supervision:/# ls -l /usr/local/nagios/libexec
    total 244
    -rwxrwxrwx 1 david david 5103 2005-11-04 12:17 check_graph_cisco_nb_connect.pl
    -rwxrwxrwx 1 www-data www-data 6568 2005-11-04 11:26 check_graph_dell_temperature.pl
    -rwxrwxrwx 1 www-data www-data 5885 2005-11-04 11:26 check_graph_http.pl
    -rwxrwxrwx 1 www-data www-data 6047 2005-11-04 12:17 check_graph_load_average.pl
    -rwxrwxrwx 1 www-data www-data 15252 2005-11-04 13:09 check_graph_nt.pl
    -rwxrwxrwx 1 www-data www-data 5518 2005-11-04 12:17 check_graph_ping.pl
    -rwxrwxrwx 1 www-data www-data 6735 2005-11-04 12:17 check_graph_process.pl
    -rwxrwxrwx 1 www-data www-data 9607 2005-11-04 12:17 check_graph_remote_storage.pl
    -rwxrwxrwx 1 www-data www-data 4019 2005-11-04 11:26 check_graph_tcp.pl
    -rwxrwxrwx 1 www-data www-data 13235 2005-11-04 11:26 check_graph_traffic2.pl
    -rwxrwxrwx 1 www-data www-data 11299 2005-11-04 12:17 check_graph_traffic.pl
    -rwxrwxrwx 1 www-data www-data 6023 2005-11-04 11:26 check_graph_uptime.pl
    -rwxrwxrwx 1 www-data www-data 15856 2005-11-04 11:26 check_snmp_cpfw.pl
    -rwxrwxrwx 1 www-data www-data 17741 2005-11-04 11:26 check_snmp_load.pl
    -rwxrwxrwx 1 www-data www-data 17287 2005-11-04 11:26 check_snmp_mem.pl
    -rwxrwxrwx 1 www-data www-data 20192 2005-11-04 11:26 check_snmp_process.pl
    -rwxrwxrwx 1 www-data www-data 23443 2005-11-04 11:26 check_snmp_storage.pl
    -rwxrwxrwx 1 www-data www-data 11978 2005-11-04 11:26 check_snmp_win.pl
    -rwxrwxrwx 1 root root 1460 2005-11-04 13:11 oreon.conf
    -rwxrwxrwx 1 root root 5004 2005-11-04 13:30 oreon.pm
    -rwxrwxrwx 1 root root 3188 2005-11-04 12:20 Utils.pm

    Leave a comment:


  • templuche
    replied
    Bonjour,

    Fais nous un:
    Code:
    ls -l /usr/local/nagios/libexec

    Leave a comment:


  • barachno
    replied
    Oui j'ai verifié mon fichier de sondes et bien géneré et tous mes chemins dans le menu general sont ok!!!!
    ne me manque ,t' il pas une librairie.
    Pourtant j'ai suivi la procedure d'install a la lettre.

    Leave a comment:


  • inconnuflo
    replied
    Tu as bien géréer ton fichiers des sondes dans Options>Sondes ?

    Tu n'as pas de pb de chemin d'accès dans Options>Générales ?

    Leave a comment:


  • barachno
    replied
    J'ai essayé les 2 solutions et je me retrouve toujours avec cette fichu erreur.
    Je continu a chercher des que j'ai des news je vous tiens au courant
    merci

    Leave a comment:


  • barachno
    replied
    Merci je vais essayer, mais avant je refais une install car j'ai fait pas mal de degat avec CPAN!!!!!!
    Je reinstall et je vous tiens au courant rapidement.
    Merci beaucoup

    Leave a comment:


  • surcouf
    replied
    Originally posted by barachno
    J'avais deja essayé avec cpan>install Config::Infiles.
    Mais ca me donne toujours la meme erreur donc ca ne dois pas etre ca le probleme!
    je ne decourage pas!
    soit tu précèdes ta commande de la variable d'environnement PERL5LIB, soit tu édites fichier oreon.pm qui doit définir l'emplacement des plugins nagios et donc de utils.pm:

    $ PERL5LIB=$PERL5LIB:/usr/lib/nagios/plugins /usr/lib/nagios/plugins/check_snmp ...

    Leave a comment:


  • barachno
    replied
    J'avais deja essayé avec cpan>install Config::Infiles.
    Mais ca me donne toujours la meme erreur donc ca ne dois pas etre ca le probleme!
    je ne decourage pas!

    Leave a comment:

Working...
X