Announcement

Collapse
No announcement yet.

[REGLE]Pas de lien/incrementation rrd....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • julio
    replied
    J'ai gagné !! C'etait un test ? si on avait su que ct une si petit connerie, on aurait demandé direct les conf d'abord... va falloir qu'on fasse un mode operatoire pour ce genre de bug.

    1 envoyer vos conf.
    2 expliquer la sitation particuliere si y en a une...
    3 ....

    Leave a comment:


  • boobz
    replied
    y aurai pas un pb... arg1 est donc vide... enleve un "!"... pourkoi ya ca ? C ki ki les a rentré tes arg ?
    J'ai honte ops:

    En tout cas un grand MERCI à tous les forumers...
    A charge de revanche :wink:

    Leave a comment:


  • julio
    replied
    check_command check_graph_cpu!!11
    y aurai pas un pb... arg1 est donc vide... enleve un "!"... pourkoi ya ca ? C ki ki les a rentré tes arg ?

    Leave a comment:


  • boobz
    replied
    top top top^
    je viens de refaire le test...... ops:
    Là le 12.rrd s'est bien créé tout est parfait....
    Le 1er qui dit que c'est moi qui avait fait une erreur de synthaxe ..... :evil:

    Pas trop compris, je vais regarder là ou ca clochait, je ferai un feedback...
    ++

    Leave a comment:


  • wistof
    replied
    c'est vraiment bizarre

    si les plugins créaient des '1.rrd', c'est qu'il ne tient pas compte de l'argument, ou il ne reconnait pas l'option.

    lorsque tu utilises :
    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v USEDDISKSPACE -l C -w 75 -c 90 -g -S $ARG1$
    sans arguments et que tu généres tes fichiers, comment est généré la ligne dans ton services.cfg ?

    Leave a comment:


  • boobz
    replied
    Bon j'ai finallement reussis a me depatouiller de tout ca....
    mon probleme est bien l'incrementation des graph .rrd et/ou des liens rrd/graphique dans ma base....
    Tout fonctionne sauf que je dois moi meme incrementer mon argument -S, mon 1er graph a pour argument en dure 1, mon 2nd graph a comme argument en dure 2 etc.....

    En fait soit dans mon plugin (pas retouché celui là), la variable -S n'est pas géré/incrementer soit elle n'est pas incrementer dans la base sql....

    Ca fonctionne bien, mais je ne suis pas a l'abri d'erreur de saisis donc je cherche encore a resoudre mon probleme (qui n'est plus bloquant)...Et je suis toujours en train d'installer 1 2nd serveur de test opur valider tout ca...
    ++

    Leave a comment:


  • julio
    replied
    oui ou alors les commandes en check_graph aussi je crois.... mais ca devrait marcher apres..

    Leave a comment:


  • boobz
    replied
    tu as renommé tes plugins ou alors tes commandes... nan ? ca ne commence plus par check_graph ?
    Oui en effet ops: .....
    Ceci dit ca le fait aussi quand je veux mettre en place 2 graphs avec le check_graph_nt.pl (donc sans customisation)....
    Je suis en train de reinstall sur un poste different voir si mon soucis persiste...
    Merci , si je dois renommer mes plugin ca sera avec check_graphXXXX :wink:
    ++

    Leave a comment:


  • julio
    replied
    tu as renommé tes plugins ou alors tes commandes... nan ? ca ne commence plus par check_graph ?

    Leave a comment:


  • boobz
    replied
    Rebonjour,
    Il ne faut surtout pas que tu renseigne l'argument lié à l'option"-S", c'est Oreon qui la renseigne automatiquement.
    Ca j'ai bien compris, si je ne precise rien tous mes graphs se nomment 1.rrd donc j'ai des erreurs de tous les cotés pour cause de mise a jour impossible

    En fait, il recupère la clé (qui est un N°) dans la base mysql et l'attribut à l'arguement -S.
    C'est donc là qu'est mon soucis....Mais je ne sais comment le resoudre....

    De plus, il NE FAUT SURTOUT PAS, créer le graphique en shell.
    Sinon tu vas etre bon à détruire ton service, redémarrer Nagios, recréer ton service et Redemarrer.
    Je ne créé pas le graphique en shell, tout est fait via oreon....Je modofie les arguments au niveau des services oreon...

    Merci encore pour l'aide apporté...
    :wink:

    A bientot

    Leave a comment:


  • inconnuflo
    replied
    Il ne faut surtout pas que tu renseigne l'argument lié à l'option"-S", c'est Oreon qui la renseigne automatiquement.
    En fait, il recupère la clé (qui est un N°) dans la base mysql et l'attribut à l'arguement -S.

    Ensuite, il faut attendre un peu, afin ke le plugin collecte qq info.

    De plus, il NE FAUT SURTOUT PAS, créer le graphique en shell.
    Sinon tu vas etre bon à détruire ton service, redémarrer Nagios, recréer ton service et Redemarrer.

    Leave a comment:


  • boobz
    replied
    Re: Pas de lien/incrementation rrd....

    [quote="wistof"]
    Originally posted by boobz


    A mon avis, tu utilises mal le plugin (mais je peux me tromper)

    quand tu utilises la check_command
    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v USEDDISKSPACE -l C -w 75 -c 90 -g -S $ARG1$
    je suppose que tu mets
    !1
    et c'est pas bien

    c'est Oreon qui remplace ton $ARG1 pour toi, comme un grand, avec l'id de ton service dans ta table de la base de données. Donc, tu mets pas d'arguments.
    Bonjour,
    non j'ai bien compris l'utilisation du plugin, si au niveau de la variable je laisse vide (donc je laisse a oreon le choix), il créé tout en 1.rrd (d'ou mon soucis "pas d'incrementation").
    Si lors d'un test je met une valeur en dure au niveau $ARG1$, il me créé bien le .rrd mais qui devient inaccessible sous oreon...

    :roll:
    Bon j'y retourne, merci pour vos indications....
    ++

    Leave a comment:


  • inconnuflo
    replied
    regarde aussi sur le wiki, tout est expliquer pour ce plugin

    Leave a comment:


  • wistof
    replied
    Re: Pas de lien/incrementation rrd....

    Originally posted by boobz
    Par ailleurs, quand je saisis l'argument -S avec comme valeur 2 (pour l'exemple), ca fonctionne, aucun message d'erreur, le 2.rrd est créé est s'incremente....Par contre au niveau Oreon, je n'ai pas accès a ce graph...comme s'il n'existait pas.....
    A mon avis, tu utilises mal le plugin (mais je peux me tromper)

    quand tu utilises la check_command
    $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v USEDDISKSPACE -l C -w 75 -c 90 -g -S $ARG1$
    je suppose que tu mets
    !1
    et c'est pas bien

    c'est Oreon qui remplace ton $ARG1 pour toi, comme un grand, avec l'id de ton service dans ta table de la base de données. Donc, tu mets pas d'arguments.

    Leave a comment:


  • inconnuflo
    replied
    Verifie les droits sur le repertoire "rrd" et le propritaire

    Leave a comment:

Working...
X