Announcement

Collapse
No announcement yet.

[Résolu]probleme pour grapher Cpu snmp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu]probleme pour grapher Cpu snmp

    Bonjour,

    il me fait une erreur sur ce plugin :

    voici le check :check_graph_load_average
    $USER1$/check_graph_load_average.pl $HOSTADDRESS$ -v $ARG1$ -W -C $ARG2$ -g -S $ARG3$

    argument: !1!public


    erreur: UNKNOWN: Received noSuchName(2) error-status at error-index 1.

    Mon but :
    Je voudrais en snmp remonter un graph de la charge du cpu d'un Windows 2003.
    avec une alerte par mail en cas de monter en charge de plus 80%
    est-ce que j'utilise le bon plugin et si c'est le cas ou je me suis encore vautré...

    merci pour votre aide :wink:
    Oreon 1.4
    Débian Etch
    Nagios 2.9

  • #2
    ton snmp est bien configuré ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      oui, je pense car je check deja les disque dur + la memoire+ quantité de personnes logué + process antivirus .
      Oreon 1.4
      Débian Etch
      Nagios 2.9

      Comment


      • #4
        Bonjour,

        Windows, la charge CPU il ne connait pas. Là tu essaies de récupérer une information qui n'existe pas dans l'agent MS. Ce plugin ne fonctionne que sur les machines faisant tourner Net-SNMP. Essaye plutôt check_nt avec les compteurs de performances.

        Comment


        • #5
          arff Oki bon je met de suite la dessus


          merci
          Oreon 1.4
          Débian Etch
          Nagios 2.9

          Comment


          • #6
            Originally posted by stephy
            oui, je pense car je check deja les disque dur + la memoire+ quantité de personnes logué + process antivirus .
            Ça ne veut pas pour autant dire que tout est activé.
            Est-ce que la commande ci-dessous renvoit quelque chose:

            Code:
            $ snmpwalk -v 1 -c <communauté> <hôte windows> .1.3.6.1.2.1.25.3.3.1
            Si non, c'est que ton agent SNMP est mal configuré.
            Raphaël 'SurcouF' Bordet
            Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
            Dons Paypal

            Comment


            • #7
              Bonjour,

              voici la reponse au test, cela fonctionne

              ~# snmpwalk -c public X.X.X.X .1.3.6.1.2.1.25.3.3.1
              HOST-RESOURCES-MIB::hrProcessorFrwID.2 = OID: SNMPv2-SMI::zeroDotZero
              HOST-RESOURCES-MIB::hrProcessorLoad.2 = INTEGER: 2
              Oreon 1.4
              Débian Etch
              Nagios 2.9

              Comment

              Working...
              X