Announcement

Collapse
No announcement yet.

problème avec des commandes persos

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pepito
    replied
    Bon ca y est ça marche...

    Pour faire fonctionner, j'ai effacé tous mes services et mes commandes check ( :cry: ) et je les ai recréés...

    C'est tout propre et ça tourne pour de vrai

    Vivement la 1.2.3 finale pour la fin des petits bugs génants mais à part ça, ça roule!

    Leave a comment:


  • pepito
    replied
    Originally posted by DonKiShoot
    $USERx$ est propre à nagios, so RTFM :wink:
    arf!

    Je l'ai lu mais y a de GROS passages que j'ai sauté c'est vrai :roll:
    autant pour moi

    Leave a comment:


  • DonKiShoot
    replied
    check_graph est une obligation pour qu'oreon sache qu'il y a des graph associé.

    $USERx$ est propre à nagios, so RTFM :wink:

    Leave a comment:


  • pepito
    replied
    bon ca n'a pas marché...

    Mes services tournent bien car ils renvoyent les bonnes valeurs (sauf RAM et disque dur qui veulent tous écrire dans le fichier 1.rrd) mais aucun ne graphe...

    Je suis un peu déboussolé là!

    Leave a comment:


  • pepito
    replied
    ok c'est fait...
    j'ai plus qu'à attendre voir si ca fonctionne. C'est une limitation de oreon ou de nagios l'obligation de faire commencer la commance par check??

    J'ai une autre question...
    Est ce que les variables enregistrées dans le fichier resources.cfg doivent etre appelée forcément $USERx$ ou bien on peut les appeler $TITI$ ou $TOTO$ ?


    Merci pour ta réponse en tout cas

    Leave a comment:


  • wistof
    replied
    hello,

    appelle ta commande
    check_graph_espace_disque

    Leave a comment:


  • pepito
    started a topic problème avec des commandes persos

    problème avec des commandes persos

    salut,

    je me suis créé plein de petites commandes perso pour me faciliter le travail du genre
    Code:
    define command{
            command_name                    graph_espace_disque
            command_line                   $USER1$/check_graph_nt.pl -H $HOSTADDRESS$ -p 1248 -v USEDDISKSPACE -l $ARG1$ -s $REQUESTPASSWORD$ -w 80 -c 90 -g -S $ARG2$
    }
    Comme ca, je n'ai plus qu'à ajouter à un hôte le service graph_espace_disque en mettant comme paramètre dans oreon !nom_du_disque et hop il me fait tout... enfin normalement!

    En fait quand j'utilise cette commande dans plusieurs services, la valeur du -S n'est pas généré automatiquement par oreon!
    Du coup je me retrouve avec tous les services qui essaye de grapher sur le fichier 1.rrd et badaboum!

    Et puis j'ai aussi d'autre commande comme
    Code:
    define command{
            command_name                    graph_ping
            command_line                   $USER1$/check_graph_ping.pl -H $HOSTADDRESS$ -w 200,20% -c 500,40% -n 5 -g -S $ARG1$
    }
    qui m'évite d'avoir à mettre le moindre le paramètre.
    Celle la elle fonctionne mais elle n'essaye meme pas de grapher (pas de petit carré orange dans le tableau de surveillance...)


    J'aurai bien besoin d'aide svp...
Working...
X