No announcement yet.

Centreon 2.3.7, No Export/Generate

  • Filter
  • Time
  • Show
Clear All
new posts

  • Centreon 2.3.7, No Export/Generate


    Sorry about the newbie questions but I have been banging my head against this wall for a few days now and despite much googling etc am no further forward.

    I am building up a centreon, setup for use at work, initially as a proof of concept, with a view to rolling it out in anger after review, by those upstairs.

    The build is currently:-

    Debian Squeeze, fully updated etc.
    Nagios 3.3.1, compiled installed and working OK
    ndoutils 1.5, compiled installed and working OK
    Nagios plugins 1.4.15
    Apache 2 standard debian issue.
    Percona Server Server 5.5 and percona client libs

    All the above is working great and I can use the nagios front end and see data dropping into the ndo DB called nagios OK.

    I have installed , re-installed re-re-re installed, configured, tweaked, rummaged through source and logs files, widened file permisions etc and re-re-re-re-re-reinstalled a newly downloaded copy again and again. But no matter what can not get past the initial export/generate of centreon 2.3.7.

    centreon builds and appears to install OK, I have worked through it so many times now that all of the little bits to fall over have been sorted.

    I can log on OK and get some centreon pages, admittedly no nagios status of any kind at all, but as I have not completed the initial config and export/generate I guess this is sort of to be expected.

    The initial configs are all good after checking though them but when I click on the export button it gets to 10% the bar turns red and then nothing any further.

    The console claims to have initialised the environment OK generating the files though is just a few dots and nothing more.

    The sql errors log is just a mass of "Unknown" sql errors.

    Is there any chance of someone in the know working though this with me to get the initial set-up complete. Centreon looks ideal for our use, but if we cannot even get past proof of concept it is dead in the water.....

    All help gratefully received.

    Cheers Andy kirby

  • #2
    SQL Strict Modes

    Ok part of the fix.

    Apparently we run the percona server in a fairly strict mode and it spits out it's dummy if the quotes in query are not fully ANSI compliant.

    The fix to get the export to work is to modify the percona/mysql config.


    Look for the sql_mode line and remove the ANSI_QUOTES text from it.

    Restart the server and the exports now work.

    The Centreon config is now showing up some nagios config and nagios has picked up the config that centreon has passed to it, I can confirm this looking at the nagios logs.

    However we have no status info in the top bar just question marks and there is no hosts, services or other of the things I would expect it to have pulled out of the ndo db.


    • #3
      SQL Modes

      Ok fixed the rest of the errors by forcing the mysql/percona install into its default modes.
      To do this comment out the sql_mode line in my.cnf


      • #4
        No hosts or services.

        OK I now get something other than question marks in the top bar I get 0's lots of them.

        On the home page I get summary views where I have a total number of hosts 0, form which 1 is up ?????? Go figure.

        Similarly the services show totals of 0 OK and 0 in unknown of which there are 1 OK Disabled and 3 Unknown Disabled.

        There are no Hosts in the hosts view similarly no services in the services view, but i do get ping graphs for the stuff i cannot see and other graphs too.

        NDO is working great with nagios,

        No idea what is going off here, any ideas ??

        BTW tried the ACL fix, no change


        • #5
          Hi !

          Have you tried to logout/login ? And to close your browser ?
          I had an issue like this : 0 hosts, 0 Services displayed, but re-displayed after closing my browser and relogged-in myself

          Check your nagios.log to see if there is really some activity


          • #6
            Yup tried login/logout and restarts no difference.

            I have put the original nagios stuff in a tar file and imported. no difference.

            nagios log is completely happy
            [1336043360] Auto-save of retention data completed successfully.

            Is all I get unless I restart nagios and it then shows it is offloading to ndo fine.

            Centreon's top bar icons for the poler show two up as red.

            with messages:-

            Pollers Central, Central not running, Checking the poller config the status is running ????

            Some database poller updates are not active; check your nagios platform. Checking nagios it is all running fine, except the snmp based checks which centreon has insisted on configuring for the local services. We are not running SNMP and on the install I elected not to install it.

            All of my work here is on the same server all apps are clean builds with defaults, there are no remote pollers yet. It is all local.

            Having spent days on this and still not having a working setup I am slowly coming around to the idea that Centreon might be something of a chocolate teapot and I might be better looking into alternatives. A big shame as It looked so great at first.


            • #7
              Only monitoring left to fix


              I have pretty much got the loading sorted. something the documentation really doesn't make clear is that even on a local nagios install the nagios config files need copying to the machine running the centreon gui and importing that way. This could do to be made very clear. it will save folk a lot of time.

              What I am left with is the winge about the poller not working etc, No monitoring can't see any hosts or services. No totals on the top bar stats. Not sure if this is CGI related or database related.

              Once I got the hang of the configuration it is'nt too bad and is useful to have templates and see all the config options, should make nagios admin a lot easier.

              If only I persuade the monitoring to work.


              • #8

                After a lot of thrashing about it looks like ndo 1.5 is incompatible with centreon as it does not populate the hosts and services tables in the ndo database. The centreon broker I am not even going to attempt as it appears unless you speak french assistance and useful documentation is unlikely.

                Interestingly enough if you are upgrading an existing installation it will appear to work as there will be legacy hosts and services left in the host and services tables. Any new ones added will not appear and if the database is purged they will all have gone from the monitoring views.

                Again these are simple things that if documented where they can easily be seen/found by someone starting a clean build would be of immense benefit to the community. Maybe even a recommended this works list the latest compatible versions for the parts that make up a centreon/nagios installation. Whilst it is impossible to control them all. A note of what is the most up to date combination that works would save everyone a lot of time.

                Finding that ndo 1.5 is incompatible requires that you first work it out in order to ask the right questions via google. Until that point nothing indicated it was so and non of those in the know responded here.

                Having worked it out and asked the question it appears it is very much known about within the developer group....... Thanks guys.