Announcement

Collapse
No announcement yet.

[Resolu] Oreon sous Red Hat Enterprise ???

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • romsworld
    replied
    merci pour la commande. Ca peut toujours servir

    Autrement, j'ai installer une fedora 5, et la tout fonctionne pil poil :lol:

    Leave a comment:


  • tetatoto
    replied
    tu peux installer les 2 rpm en même temps afin de résoudre les dépendances croisées:

    Code:
    rpm -ivh php*.rpm

    Leave a comment:


  • romsworld
    replied
    Ma machine ne peux pas acceder au net.

    Je suis je pense dans la pire des situations. C'est pour ca qu'il vaut mieux que je prenne une distrib a jour quitte a devoir reinstaller les composants de mon serveur actuel.

    Leave a comment:


  • inconnuflo
    replied
    je crois (n'etant pas expert sous red hat) qu'avec rmpi ou yum tu peux gérer les dépendances

    Leave a comment:


  • romsworld
    replied
    Merci,

    Mais j'ai encore une fois un nouveau probleme. C vraiment la misere ce foutu PHP, du moins pour les anciennes versions.

    J'install PHP, il me dit qu'il me faut php-pear. et evidement.. je vous le donne en 1000 , qd je met php-pear, il me sort qu'il me faut php !

    Alors basta, je change de distrib, je vais en prendre une plus recente, une mandriva par exemple, ou une fedora pi ca ira tres bien, au moins je trouverai tous les paquages possible et innimaginable !

    Leave a comment:


  • tetatoto
    replied
    Oups, désolé.
    Le php-snmp est officlellement sur RHEL depuis la 4.

    Leave a comment:


  • julio
    replied
    héhé ! tic !
    Attached Files

    Leave a comment:


  • romsworld
    replied
    hé non ! c bien ca mon pb ! c'est que php-snmp n'existe pas dans la Redhat entreprise 3.

    Si quelqu'un a ce paquage, ou qu'il a reussi a installer OREON sur une Entreprise 3, merci de me contacter, car la je n'ai vraiment plus d'idée, a par changer de distrib ! :?


    EDIT : Ce foutu paquet php-snmp, est il vriament necessaire ??? A quoi sert il au juste ?

    Leave a comment:


  • tetatoto
    replied
    Bonjour,

    Pour une RHEL 3,

    - php-pear appartient au paquet php. Pour le vérifier, il faut taper:
    Code:
    % which pear
    - php-snmp est un paquet de la RHEL 3. Il est soit sur les CD, soit disponible sur Red Hat Network (RHN).

    @+

    Leave a comment:


  • romsworld
    replied
    Originally posted by tetatoto

    Si tu n'as pas accès, voici les paquets que j'ai dû mettre en oeuvre sur une RHEL 3:
    • fping-2.4-1.b2.1.el3.rf.i386.rpm
      gd-devel-1.8.4-12.3.1.i386.rpm
      libmcrypt-2.5.7-1.dag.rhel3.i386.rpm
      libpng-devel-1.2.2-25.i386.rpm
      nagios-1.2-2.1.el3.rf.i386.rpm
      nagios-nsca-2.5-2.1.el3.rf.i386.rpm
      nagios-plugins-1.4.1-1.1.el3.rf.i386.rpm
      nagios-plugins-nrpe-2.3-2.1.el3.rf.i386.rpm
      net-snmp-perl-5.0.9-2.30E.19.i386.rpm
      net-snmp-utils-5.0.9-2.30E.19.i386.rpm
      openssl096b-0.9.6b-16.i386.rpm
      oreon-1.2.3_RC2-3.fc3_rhel3.i386.rpm
      perl-Config-IniFiles-2.39-1.1.el3.rf.noarch.rpm
      perl-Crypt-DES-2.05-3.1.el3.rf.i386.rpm
      perl-Digest-HMAC-1.01-11.1.noarch.rpm
      perl-Digest-SHA1-2.10-1.1.el3.rf.i386.rpm
      perl-GD-1.41-1.rhel3.dag.i386.rpm
      perl-Net-SNMP-5.2.0-1.1.el3.rf.noarch.rpm
      perl-rrdtool-1.0.50-3.el3.rf.i386.rpm
      perl-SNMP-Simple-0.02-1.1.el3.rf.noarch.rpm
      perl-Socket6-0.19-1.1.el3.rf.i386.rpm
      perl-Time-HiRes-1.38-3.i386.rpm
      rrdtool-1.0.50-2.1.el3.rf.i386.rpm

    Ils ne sont pas triés et proviennent soient de Red Hat, soient de dag.
    tu remarqueras le RPM oreon-1.2.3 qui n'est pas (encore) officiel mais qui marche très bien chez moi.

    Si tu le veux le RPM directement, envoi moi un mail:

    staphane(dot)langlet(at)cnamts(dot)fr

    @+

    J'ai reussi a intaller toutes les dépendances sauf :

    php-pear
    php-snmp

    Je n'arrive pas a trouvé les rpm pour la redhat ent 3.
    J'ai par defaut php-4.3.2-11.ent.i386.rpm
    J'ai reussi a installer php-mysql.

    Mais pour php pear et snmp, c'est introuvable, ou alors ce sont des versions trop ou pas assez recente. Bref c'est le drame snif.

    Merci

    Leave a comment:


  • romsworld
    replied
    hihi a l'ancienne !

    BOn, je n'ai pas Internet sur cette machine, et je ne pourrai jamais l'avoir.

    Donc... je vais me debrouiller en recherchant tous les RPM.

    Juste une question ? J'ai vu qu'il y avait pas mal de dépendance avc PEAR. As tu eu des problemes concernant cela.

    J'ai jamais rien compris a ce truc la. On ne trouve jamais de RPM pour pear et c'est tres embettant !

    Si quelqu'un pouvais m'expliquer pkoi

    Leave a comment:


  • pepito
    replied
    faites ça à l'ancienne

    moi j'ai tout compilé, un par un, parceque ces messieurs ont perdus leur licence pour le support Enterprise donc pas de up2date

    Leave a comment:


  • tetatoto
    replied
    Yum est disponible à cette adresse:
    http://dag.wieers.com/packages/yum/

    Si tu as un accès internet sur ton serveur en RHEL, tu configures ton pour accéder au site de dag:
    http://dag.wieers.com/home-made/apt/FAQ.php#B
    (voir en B4)

    Si tu n'as pas accès, voici les paquets que j'ai dû mettre en oeuvre sur une RHEL 3:
    • fping-2.4-1.b2.1.el3.rf.i386.rpm
      gd-devel-1.8.4-12.3.1.i386.rpm
      libmcrypt-2.5.7-1.dag.rhel3.i386.rpm
      libpng-devel-1.2.2-25.i386.rpm
      nagios-1.2-2.1.el3.rf.i386.rpm
      nagios-nsca-2.5-2.1.el3.rf.i386.rpm
      nagios-plugins-1.4.1-1.1.el3.rf.i386.rpm
      nagios-plugins-nrpe-2.3-2.1.el3.rf.i386.rpm
      net-snmp-perl-5.0.9-2.30E.19.i386.rpm
      net-snmp-utils-5.0.9-2.30E.19.i386.rpm
      openssl096b-0.9.6b-16.i386.rpm
      oreon-1.2.3_RC2-3.fc3_rhel3.i386.rpm
      perl-Config-IniFiles-2.39-1.1.el3.rf.noarch.rpm
      perl-Crypt-DES-2.05-3.1.el3.rf.i386.rpm
      perl-Digest-HMAC-1.01-11.1.noarch.rpm
      perl-Digest-SHA1-2.10-1.1.el3.rf.i386.rpm
      perl-GD-1.41-1.rhel3.dag.i386.rpm
      perl-Net-SNMP-5.2.0-1.1.el3.rf.noarch.rpm
      perl-rrdtool-1.0.50-3.el3.rf.i386.rpm
      perl-SNMP-Simple-0.02-1.1.el3.rf.noarch.rpm
      perl-Socket6-0.19-1.1.el3.rf.i386.rpm
      perl-Time-HiRes-1.38-3.i386.rpm
      rrdtool-1.0.50-2.1.el3.rf.i386.rpm

    Ils ne sont pas triés et proviennent soient de Red Hat, soient de dag.
    tu remarqueras le RPM oreon-1.2.3 qui n'est pas (encore) officiel mais qui marche très bien chez moi.

    Si tu le veux le RPM directement, envoi moi un mail:

    staphane(dot)langlet(at)cnamts(dot)fr

    @+

    Leave a comment:


  • Or3L
    replied
    tu peux installer yum ou rpm-get.

    Leave a comment:


  • romsworld
    replied
    Je rencontre le meme pb. Je suis sous Redhat Entreprise 3, et je suis en train de m'amuser a recuperer tous les RPM ! et c'est pas du gateau !

    N'y aurait il pas un package avec tout ce dont on aurait besoin ??

    Tks

    Leave a comment:

Working...
X