Announcement

Collapse
No announcement yet.

Erreur mysql.so lors de l'install de la 1.2.3RC3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Erreur mysql.so lors de l'install de la 1.2.3RC3

    Bonjour,

    Je tente d'installer la version 1.2.3RC3 d'oreon sur une fedora 2 mais lors de l'étape 4 (Verifying Configuration) il me met l'erreur : "Critical: mysql.so not loaded in php.ini" . Pourtant Apache, PHP, Mysql sont bien installés, ainsi que php-mysql. J'ai bien le fichier mysql.so dans le repertoire des extensions de PHP.

    Une petite idée ?
    Merci
    Ubuntu + Nagios 2.9 + Centreon 1.4.1

  • #2
    bonjour
    dans ton fichier (...)/php/php.ini

    tu as une ligne a decommenter (de memoire ), c'est mysql.so

    et redemmarrer apache je pense et ca doit etre bon.
    Linux sarge --> nagios 1.2 --> 35 équipements, 91 services aux fesses d'oreon 1.2.3 RC2

    Comment


    • #3
      Et bien non ca ne suffit pas apparament....

      Il ma bien trouvé snmp.so mais le mysql.so il en veut pas.....
      Ubuntu + Nagios 2.9 + Centreon 1.4.1

      Comment


      • #4
        rajoute la ligne

        extension=mysql.so
        apres ton

        extension=snmp.so


        si ca marche pas c'est que tu as mal installer le couple php*Mysql
        Linux sarge --> nagios 1.2 --> 35 équipements, 91 services aux fesses d'oreon 1.2.3 RC2

        Comment


        • #5
          Oui j'ai déjà les lignes :

          extension=mysql.so
          extension=snmp.so

          dans mon fichier php.ini..

          Et même après un redémarrage j'ai toujours le message d'erreur.
          Ubuntu + Nagios 2.9 + Centreon 1.4.1

          Comment


          • #6
            salut!

            j'ai installé oreon sur une redhat et j'ai aussi bien galéré!!
            Regarde ce que te donne la ligne de commande
            Code:
            php -m
            qui te donne la liste des modules compilés avec php.

            Regarde aussi dans la fonction phpinfo() (à mettre dans un fichier php et à visualiser dans un navigateur) comment a été compilé php et l'extension mysql...

            Perso, gd était compilé avec l'option "shared"
            Code:
            ./configure .... --with-gd=shared ...
            et j'avais l'erreur "gd.so introuvable"

            J'ai bien bataillé pour m'en sortir!
            Au menu, recompile de gd (donc toi ça serait mysql) et recompile de php entre autre!!
            Ou alors trouve les rpms qui vont bien (perso je trouve que c'est de la vraie merde, vive Suse et sa gestion des paquets!)

            J'ai gardé en copie la ligne de commande du configure de php qui fonctionne si tu te sent le courage...

            Moi contrairement à toi, je n'avais pas du tout de fichier .so donc ca ne vient peut etre pas de là...
            Et sinon, je te souhaite bon courage
            RedHat Advanced Server 4.0
            Nagios 2.3.1
            Oreon 1.3b1

            Comment


            • #7
              normalement il faut utiliser les packages RPM sur redhat, c plus propre et pas de pb de dependances... enfin moi c toujours comme ca que je fais...
              Julien Mathis
              Centreon Project Leader
              www.merethis.com |

              Comment


              • #8
                Ouais sur ce point on est d'accord.
                J'utilise bien les paquets RPMs, que ce soit pour MySQL, pour PHP ou pour le module Php-mysql...

                Je vais tester en compilant manuellement php et mysql on vera bien..

                Merci
                Ubuntu + Nagios 2.9 + Centreon 1.4.1

                Comment


                • #9
                  la commande php -m me donne :

                  PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php4/mysql.so' - /usr/lib/mysql/libmysqlclient.so.10: symbol __fprintf_chk, version GLIBC_2.3.4 not defined in file libc.so.6 with link time reference in Unknown on line 0

                  ca doit venir de la...
                  Ubuntu + Nagios 2.9 + Centreon 1.4.1

                  Comment


                  • #10
                    bon courrage
                    Linux sarge --> nagios 1.2 --> 35 équipements, 91 services aux fesses d'oreon 1.2.3 RC2

                    Comment


                    • #11
                      c'est ce que j'avais comme erreur avec gd quand j'ai rajouté la ligne ex=gd.so dans le fichier php.ini ...

                      Bon courage!
                      RedHat Advanced Server 4.0
                      Nagios 2.3.1
                      Oreon 1.3b1

                      Comment


                      • #12
                        ops: C'était ca ops:

                        Merci (je susi un noob je le sais)

                        Comment

                        Working...
                        X