Announcement

Collapse
No announcement yet.

Issue with Broker

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with Broker

    Hi,

    I've installed Nagios3.5.0 with Centreon2.4.1 and Broker 2.4.3 on Centos6 and I've issue making the broker run properly.

    The broker start correctly, but when i check the logs, these lines repeating every minutes :
    Code:
    [1365410369] error:   SQL: could not open SQL database: Driver not loaded Driver not loaded
    [1365410369] error:   storage: could not connect to Centreon Storage database

    I've check the configuration of the broker and try the same paramters throught mysql command lines. Connexion is ok.

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <centreonBroker>
     <instance><![CDATA[2]]></instance>
     <instance_name><![CDATA[central]]></instance_name>
     <module_directory><![CDATA[/usr/local/lib/centreon-broker]]></module_directory>
     <event_queue_max_size><![CDATA[50000]]></event_queue_max_size>
     <input>
      <name><![CDATA[Central Master]]></name>
      <port><![CDATA[5668]]></port>
      <protocol><![CDATA[ndo]]></protocol>
      <tls><![CDATA[no]]></tls>
      <compression><![CDATA[no]]></compression>
      <type><![CDATA[ipv4]]></type>
     </input>
     <logger>
      <name><![CDATA[/usr/local/centreon/log/centreon-broker/central-broker.log]]></name>
      <config><![CDATA[yes]]></config>
      <debug><![CDATA[no]]></debug>
      <error><![CDATA[yes]]></error>
      <info><![CDATA[no]]></info>
      <level><![CDATA[low]]></level>
      <type><![CDATA[file]]></type>
     </logger>
     <output>
      <name><![CDATA[Broker SQL]]></name>
      <db_type><![CDATA[mysql]]></db_type>
      <db_host><![CDATA[localhost]]></db_host>
      <db_port><![CDATA[3306]]></db_port>
      <db_user><![CDATA[centreon]]></db_user>
      <db_password><![CDATA[MONMOTDEPASSE]]></db_password>
      <db_name><![CDATA[centreon_storage]]></db_name>
      <check_replication><![CDATA[no]]></check_replication>
      <type><![CDATA[sql]]></type>
     </output>
     <output>
      <name><![CDATA[Perfdata Master]]></name>
      <interval><![CDATA[60]]></interval>
      <length><![CDATA[15552000]]></length>
      <db_type><![CDATA[mysql]]></db_type>
      <db_host><![CDATA[localhost]]></db_host>
      <db_port><![CDATA[3306]]></db_port>
      <db_user><![CDATA[centreon]]></db_user>
      <db_password><![CDATA[MONMOTDEPASSE]]></db_password>
      <db_name><![CDATA[centreon_storage]]></db_name>
      <check_replication><![CDATA[no]]></check_replication>
      <type><![CDATA[storage]]></type>
     </output>
     <output>
      <name><![CDATA[RRD-File]]></name>
      <metrics_path><![CDATA[/var/lib/centreon/metrics/]]></metrics_path>
      <status_path><![CDATA[/var/lib/centreon/status/]]></status_path>
      <type><![CDATA[rrd]]></type>
     </output>
    </centreonBroker>

    Have any idea of what could cause theses error messages ?
    Last edited by dmn; 9 April 2013, 15:03. Reason: FIX

  • #2
    So, I find how to fix this. It was missing some libs. I've installed qt-mysql package and this error dispeared.

    Therefore, i found another one. When starting Nagios :
    Error: Function nebmodule_init() in module '/usr/local/lib/cbmod.so' returned an error. Module will be unloaded.
    Will search about this, but if someone has already the reason of this error, this could be helpfull.

    Comment


    • #3
      Fix too.
      That was an permission error with the central-broker log file. Just do a chmod on the file and the module load correctly in Nagios now.

      Therefore, still have issue with my configuration but i don't know where. So i fix this thread, and will reopen a new one if neccesary.

      Comment

      Working...
      X