Announcement

Collapse
No announcement yet.

Probleme installation Nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probleme installation Nagios

    bonjour,

    voici mon problème :

    J'ai tenté d'installer Oreon+Nagios sous Debian en suivant la procédure officielle sur le site www.oreon-project.org

    Tout s'est apparemment déroulé correctement
    J'ai accès à l'interface WEB de oreon

    cependant : Répertoire du binaire de Nagios : /usr/local/nagios/bin/
    non trouvé car inexistant !!??

    pareil pour : Répertoire des images de Nagios et Mailer(celui la on le mettra de coté ca parait déja plus logique)

    Autre probleme : /etc/init.d/nagios est inexistant, donc impossible de lancer Nagios, le relancer etc...

    Merci de m'indiquer si quelqu'un connait le probleme, et comment je peux m'en sortir

    Lucas

  • #2
    tu es sur que tu as installer Nagios parcequ'on dirait que tu les a pas installer.

    Le package tu l'as récupéré sur oreon project?
    au cas ou, pour telecharger nagios by oreon: http://download.oreon-project.org/index.php?id=8

    donne nous plus de precision sur la facons dont tu as fais ton installation...
    Debian Sarge 3.1
    Noyau 2.6.8-2-386
    Nagios 1.2
    Oreon 1.2.3-RC4

    Comment


    • #3
      J'ai eu a peu pret les memes soucis que toi lorsque j'ai tente mon install par la methode apt. j'ai recommence l'install a la main et la c'est passe comme une lettre a la poste.

      Comment


      • #4
        j'ai suivi la procédure d'installation de Nagios décrite dans le document suivant :
        http://download.oreon-project.org/Do...nagiosV1.3.pdf

        en utilisant le fichier "install.sh"

        du site d'oréon

        donc je sais pas d'ou ca vient...

        Comment


        • #5
          tu as un repertoire nagios dans /usr/local/?

          apt install l'executable dans le repertoire bin ou sbin je sais plus. j'ai egalement eu le meme problème que Thomas.:?
          si jamais, retelecharge les sources de nagios sur le site d'oreon avec le liens que je t'ai donné plus haut et retente une install ou bien mieux encore, avant de retenter l'install, supprime le repertoire nagios et reinstall nagios.
          par contre, je crois que tu vas etre obligé de refaire l'install d'oreon par la suite et il me semble que j'avais un peu galéré quand je l'ai fait. :?

          Le fait est que si tu as installer nagios a partir de apt tu fais:
          apt-get remove --purge nagios...
          et tu reinstall avec le package du site d'oreon-project.
          normalement il marche correctement.:roll:

          tiens nous au courant!!!
          Debian Sarge 3.1
          Noyau 2.6.8-2-386
          Nagios 1.2
          Oreon 1.2.3-RC4

          Comment


          • #6
            merci pour ces infos, le truc c'est que comme indiqué dans la doc d'install j'ai bien pris le fichier d'install de nagios sur le site d'oréon sans passer par le "apt-get"

            je vais réessayer une install complete sur une debian 2.4, sachant que mon 1er essai était sur une 2.6, peut etre que ca vient de la....

            je vous tient au courant de la suite des évenements

            Lucas

            Comment


            • #7
              Originally posted by Lucas
              merci pour ces infos, le truc c'est que comme indiqué dans la doc d'install j'ai bien pris le fichier d'install de nagios sur le site d'oréon sans passer par le "apt-get"

              je vais réessayer une install complete sur une debian 2.4, sachant que mon 1er essai était sur une 2.6, peut etre que ca vient de la....

              je vous tient au courant de la suite des évenements

              Lucas
              J'ai le meme probleme avec l'installeur oreon, pas de nagios du tout ???
              quelqu'un aurait il un installeur qui fonctionne ??
              merci

              Comment


              • #8
                probleme resolus avec l installeur

                j'ai troiuvé, il faut faire un apt-get install g++ pour pouvoir compiler nagios et tous les autres produits d'ailleurs relancer l installeur ...

                Comment


                • #9
                  Bon toujours le meme problme

                  j'ai repris l'install sur une debian 2.4

                  tout se passe bien jusqu'a l'install de nagios
                  comme indiqué dans le .pdf sur le site d'oreon, je change le fichier "install.sh" de l'install de nagios

                  ensuite je lance ./install.sh

                  la pas de prob, jusqu'a "voulez vous installer nagios-1.2?"
                  réponse : yes

                  la il me dit qu'il peut pas accéder au fichier /home/local/nagios/etc
                  donc la je me dis que c'est un boulet parce que c'est lui qui est sensé le créer, donc l'install se stoppe : 1er problème

                  je me dis je vais lui faire plaisir je vais lui créer son dossier : je crée /home/local/nagios/etc, je relance l'install de nagios

                  la il me dit tout est bon, entrez un mot de passe pour nagioadmin
                  puis : "voulez vous redemarrer le serveur nagios?"
                  réponse : yes

                  et la : "unable to restart server"
                  pas étonnant parce que le fichier /etc/init.d/nagios n'a pas été crée

                  donc voila, ca bloque ici alors que j'ai suivi scrupuleusement la démarche...

                  si quelqu'un a une solution , je suis grandement preneur
                  Merci

                  Lucas

                  Comment


                  • #10
                    salut lucas, tu es bien parti d'une debian sarge 3.1, tu as bien fais tes apt-get install make sudo gcc g++ ??

                    Comment


                    • #11
                      je suis bien sur une sarge 3.1

                      g++ est obligatoire?

                      je l'avais pas mis au début comme il était pas indiqué....

                      si je fais ca au début et que je refais tout tu penses que c'est bon?

                      Lucas

                      Comment


                      • #12
                        Originally posted by Lucas
                        je suis bien sur une sarge 3.1

                        g++ est obligatoire?

                        je l'avais pas mis au début comme il était pas indiqué....

                        si je fais ca au début et que je refais tout tu penses que c'est bon?

                        Lucas
                        oui c'est sur, le g++ sert a compiler les sources, j'etais comme toi, je l'ai installé, tout relancé ./install.sh et tout roule maintenant, si il manque juste dans la doc 2 atp-get install a faire une fois que tu as fini :
                        apt-get install php4-snmp snmp snmpd
                        et pis c bon tout fonctionne nickel .... Ya plus qu'a

                        Comment


                        • #13
                          ok, j'ai tout refait en rajoutant le g++

                          apparemment ca passe mieux, meme si y'a qq trucs qui trainent ;-)

                          merci beaucoup

                          Lucas

                          Comment

                          Working...
                          X