Announcement

Collapse
No announcement yet.

check_graph_traffic.pl

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • check_graph_traffic.pl

    Hopa,

    j'ai farfouillé le forum, je n'ai pas trouvé de solution en français ni anglais à mon problème. Si j'avais juste mal fouillé, je m'en excuse.

    Vala le problème : sur un check_grap_traffic.pl, sur l'interface qui m'interesse (wan1) j'obtiens le message suivant (oui la commande est bien tappée, pas la peine de chercher de ce côté là ) :

    CRITICAL: Interface speed equal 0! Interface must be down.
    Notons que sur l'interface ethernet (en0) tout se déroule correctement.
    Sur Cacti, tout est analysé correctement, en0 comme wan1. Ca me fait dire que ce n'est pas du coté de snmp, ni de rrdtool ni de mon routeur qu'est le problème : ça doit être quelque part dans Oreon.

    J'ai pas mal cherché sur google et sur le forum, je suis allé voir le code du plugin, mais c'est du perl (on va pas dire que je n'y connais rien, mais y'a des choses spécifiques à perl qui font que je ne comprends pas le module)
    J'avoue que je commence vraiment à désespérer.

    Si quelqu'un savait m'aider, ça serait aimable, merci par avance

  • #2
    Re: check_graph_traffic.pl

    Originally posted by Champignon
    Hopa,

    j'ai farfouillé le forum, je n'ai pas trouvé de solution en français ni anglais à mon problème. Si j'avais juste mal fouillé, je m'en excuse.

    Vala le problème : sur un check_grap_traffic.pl, sur l'interface qui m'interesse (wan1) j'obtiens le message suivant (oui la commande est bien tappée, pas la peine de chercher de ce côté là ) :

    CRITICAL: Interface speed equal 0! Interface must be down.
    Juste pour valider au niveau SNMP, peux-tu exécuter les commandes suivantes :

    Code:
    $ snmpwalk -v 1 -c public tonrouteur ifDescr
    Code:
    $ snmpwalk -v 1 -c public tonrouteur ifSpeed
    Code:
    $ snmpwalk -v 1 -c public tonrouteur ifHighSpeed
    Raphaël 'SurcouF' Bordet
    Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
    Dons Paypal

    Comment


    • #3
      ha oauis le pb c'est qu'il trouve la vitesse de ton interface a 0 dons pas possible pour lui de calculer le pourcentage de bande passante... au pire il faudrait alors le faire alerter par rapport au traffic et pas par rapport au %age du traffic.
      Julien Mathis
      Centreon Project Leader
      www.merethis.com |

      Comment


      • #4
        Originally posted by julio
        ha oauis le pb c'est qu'il trouve la vitesse de ton interface a 0 dons pas possible pour lui de calculer le pourcentage de bande passante... au pire il faudrait alors le faire alerter par rapport au traffic et pas par rapport au %age du traffic.
        Oui, surtout que d'après le code, il n'est pas possible de préciser cette vitesse...
        Cela étant, l'interface d'un équipement dont la vitesse est équal à zéro signifirait que l'objet n'a aucune notion de bande passante...
        Raphaël 'SurcouF' Bordet
        Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
        Dons Paypal

        Comment


        • #5
          bonjour,

          sur certains routeurs tu doit definir toi même le parametre descriptif de la bande passante max d'une interface

          Ex: sur un cisco en mode config sur un interface:

          ROUTEUR(config-if)#bandwith 128 [en kilobits /s]

          ceci est juste un parametre indicatif et sert justement aux mesures de débit.

          xsp

          Comment


          • #6
            Merci à tous de vos réponses.

            J'avais déjà effectué les tests snmp "à la main", ils étaient positif. Merci quand même de l'avoir proposé ^^

            Je pense que xspoon doit avoir la bonne réponse. Je suis en train de fouiller la config des routeurs (des netopia 3346 ent) pour voir où je peux trouver cette #[email protected]!~ d'option.

            Je vous tiens informés

            Comment


            • #7
              Bon en réalité c'est un bricolage un chouillat barbare avec des vpn, des connexions atm multiples et tout un bordel monstre.
              En gros, il connait sa bande passante WAN globale, mais comme y'a plein de liens, il ne sait pas dire la bande passante allouée à chacun des liens .

              A mes yeux de jeune diplomé ça me parait totalement suréaliste comme montage, mais p'tet que c'est normal. Comme surcouf, je me demande bien comment il peut gérer la bande passante dans ces conditions

              Comment

              Working...
              X