Announcement

Collapse
No announcement yet.

Oreon working but can't get monitoring

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Oreon working but can't get monitoring

    Finally I got my oreon install and gui to show up. When i login using administrator to oreon. I can click everywhere fine. How do I IMPORT all my nagios settings to oreon??? can I even do that???

    -Parvinder Bhasin

  • #2
    Sure you can.
    Go to Configuration - Nagios - Load, and then (in my own experience) is better you import your nagios cfg files one by one.
    First of all, load your checkcommands.cfg and misccommands.cfg (selecting Check Command if you are loading the first one, or Notification Command if you're loading the second one in Command Type).
    Then import contacts.cfg, contactgroups.cfg, timeperiods.cfg, hosts.cfg, hostgroups.cfg, services.cfg, servicegroups.cfg, escalations.cfg and dependencies.cfg.
    When you finish loading all these files, import the rest: nagios.cfg and resource.cfg.
    Try to load too cgi.cfg, but in my case this file was not loaded, so I had to modify the one Oreon installs defaultly to match my configuration.

    After all these, you must assure all configuration is loaded correctly, beginning with nagios.cfg fields. Compare it to your configuration in nagios.cfg. Then you could try to generate the Oreon config files from DB.

    Go to Configuration - Nagios - Generate and select the following:

    Generate Files Yes
    Relations between Elements None
    Include Comments No
    Export in XML too No
    Run Nagios debug (-v) Yes
    Move Export Files No
    Restart Nagios No

    And look carefully about Nagios errors in debug result. If all is correct, you are prepared to run Oreon, and you could do it changing Restart Nagios to Yes and waiting

    Hope it helps ...
    [Linux 2.4.20-28.7 - RedHat 7.2]
    [Linux 2.6.16.21-0.25 - OpenSuSE 10.1]
    [Apache 1.3.x, PHP 5.x, MySQL 5.x]
    [Apache 2.2.x, PHP 5.x, MySQL 5.x]
    [Nagios 1.4.1+Nagmin -Production-, Nagios 2.5+Oreon 1.3.1-1 -PreProduction-, Nagios 2.5+Oreon 1.3.1-1 -Testing-]

    Comment


    • #3
      Thanks CIH!!! I followed your instructions.

      I am new to nagios too but I think i have got now good handle on nagios. Here is my situation:

      I only have 1 main config file that is called minimal.cfg. ( is this right way or not?)
      I did try to follow your instructions, however I don't have separte files for hosts, services etc, I am just using minimal.cfg file. Should I distribute it??

      When I export with whatever I have I get the following message while generating :

      Nagios 2.2
      Copyright (c) 1999-2006 Ethan Galstad (http://www.nagios.org)
      Last Modified: 04-07-2006
      License: GPL

      Reading configuration data...

      Error in configuration file '/usr/local/oreon/www/../filesGeneration/nagiosCFG/nagiosCFG.DEBUG' - Line 51 (UNKNOWN VARIABLE)

      ***> The name of the main configuration file looks suspicious...

      Make sure you are specifying the name of the MAIN configuration file on
      the command line and not the name of another configuration file. The
      main configuration file is typically '/usr/local/nagios/etc/nagios.cfg'

      ***> One or more problems was encountered while processing the config files...

      Check your configuration file(s) to ensure that they contain valid
      directives and data defintions. If you are upgrading from a previous
      version of Nagios, you should be aware that some variables/definitions
      may have been removed or modified in this version. Make sure to read
      the HTML documentation regarding the config files, as well as the
      'Whats New' section to find out what has changed.

      Comment


      • #4
        OK!! I read a comment somewhere which stated to remove comments...now I do see all my hosts exported but now how do i run with this config???

        I mean I still don't see any hosts under monitoring. When I try to generate...with nagios restart I still get the above (previous reply) output.

        I really appreciate all the help. Thanks a bunch.

        -Parvinder Bhasin

        Comment


        • #5
          hi!
          it is a partial solution but it can be helpful if you are in hurry
          go to :
          filesGeneration/nagiosCFG/nagiosCFG.DEBUG
          edit this file and rename the variable : log_passive_service_checks by
          log_passive_checks
          and restart your nagios with :
          /etc/init.d/nagios restart

          i expect that can be helpful
          windows XP pro
          VM

          Comment


          • #6
            Hi there again!

            If the workaround that kyo suggests does not work, try to change that variable in the nagios config page in Oreon. that's the way to mantain that variable changed every time you export the files from DB.

            Anyway, I have never worked with all config in a unique file. I don't know which method is better, but i'm used to have all configs in separate files because is better for me for searching things ... I have 33 hosts ans +600 services hock:

            I'm right now in trouble because my Oreon could not generate the files in the right way, and don't know how to manage it ... but anyway, if your problems persist, let us know.

            Later!
            [Linux 2.4.20-28.7 - RedHat 7.2]
            [Linux 2.6.16.21-0.25 - OpenSuSE 10.1]
            [Apache 1.3.x, PHP 5.x, MySQL 5.x]
            [Apache 2.2.x, PHP 5.x, MySQL 5.x]
            [Nagios 1.4.1+Nagmin -Production-, Nagios 2.5+Oreon 1.3.1-1 -PreProduction-, Nagios 2.5+Oreon 1.3.1-1 -Testing-]

            Comment


            • #7
              Thanks CIH and kyo!!!

              I have finally gotten the Generate files section to work without errors. But what do i do now??? When i click on Monitoring, i don't see my hosts there or anwhere in the services???

              What's going on? Why are my hosts that I SEE under configuration don't show up under the monitoring tab?? Please help!! really appreciate everyone's help in this. Thx.

              Comment


              • #8
                YIPEEEEEEEEE Got it working. The thing i wasn't doing was checking the MOOVE FILES while generating. When i did that...BAM!!!! it worked DUH!!!!

                Thanks guys for helping me out on this.
                Can't wait to graph...some of the data

                -Parvinder Bhasin

                Comment


                • #9
                  Oh! Move files ... common error, happened to me too. Fine to read someone else is working with Oreon at least!
                  I managed to get it work too now, so happy again

                  Later!
                  [Linux 2.4.20-28.7 - RedHat 7.2]
                  [Linux 2.6.16.21-0.25 - OpenSuSE 10.1]
                  [Apache 1.3.x, PHP 5.x, MySQL 5.x]
                  [Apache 2.2.x, PHP 5.x, MySQL 5.x]
                  [Nagios 1.4.1+Nagmin -Production-, Nagios 2.5+Oreon 1.3.1-1 -PreProduction-, Nagios 2.5+Oreon 1.3.1-1 -Testing-]

                  Comment

                  Working...
                  X