Announcement

Collapse
No announcement yet.

apache2: 404 not found

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • apache2: 404 not found

    Bonjour,
    J'ai besoin de votre aide, ça fait deux jours que je suis sur ce problème et je sature. :evil:

    D'abord c'est la seconde fois que j'installe centreon, la première fois c'étais sur un redhat avec un httpd qui fonctionne.

    Là, sur ubuntu 13.10 j'ai un problème d'accès à centreon (404 not found), avec Apache2.
    J'ai installé: Nagios 3.2, centreon 2.4, ndo1.4b9

    Donc j'ai un fichier centreon.conf dans /etc/apache2/conf.d, dans lequel j'ai:
    Code:
    ##
    ## Section add by Centreon Install Setup
    ##
    
    Alias /centreon /usr/local/centreon/www/
    <Directory "/usr/local/centreon/www">
        Options Indexes
        AllowOverride AuthConfig Options
        Order allow,deny
        Allow from all
    </Directory>
    Et j'ai bien mon centreon ici : /usr/local/centreon/www/

    Mes groupes:
    Code:
    www-data:x:33:
    nagios:x:999:www-data,centreon,nagios
    nagcmd:x:1001:nagios,www-data
    centreon:x:998:www-data,nagios
    De plus mon apache2 tourne bien puisque j'ai installé un phpmyadmin qui fonctionne. J'ai aussi biensur redemarré apache2, et il me signale AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message. qui je pense n'ai pas lié au probème.

    Je ne connais pas vraiment apache2, mais le .conf phpmyadmin est dans /etc/apache2/conf-available et dans /etc/apache2/conf-enabled, et non dans le conf.d alors que centreon.conf et seulement dans le conf.d, j'essaie d'exploiter cette piste mais avec l'installe de centreon je ne trouve aucun tutos ou il préconise de faire des modifs à ce niveau.

    Si quelqu'un à une idée je suis preneur.

    Edit, si je met le centreon.conf dans con-available et conf-enabled: j'ai plus 404 mais
    Forbidden

    You don't have permission to access /centreon on this server.

    Puis un ls-l dans /etc/apache2/conf-available

    -rw-r--r-- 1 root root 239 avril 3 10:36 centreon.conf
    -rw-r--r-- 1 root root 315 juil. 20 2013 charset.conf
    -rw-r--r-- 1 root root 127 août 11 2013 javascript-common.conf
    -rw-r--r-- 1 root root 3224 juil. 20 2013 localized-error-pages.conf
    -rw-r--r-- 1 root root 189 juil. 20 2013 other-vhosts-access-log.conf
    -rw-r--r-- 1 root root 1344 févr. 28 21:20 php5-cgi.conf
    lrwxrwxrwx 1 root root 28 avril 2 15:02 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
    -rw-r--r-- 1 root root 2190 juil. 20 2013 security.conf
    -rw-r--r-- 1 root root 458 juil. 20 2013 serve-cgi-bin.conf
    Last edited by apodog; 3rd April 2014, 12:00.

  • #2
    D'après ta conf, tous les fichier sont dans "/etc/apache2/conf-available/". Mets-y centreon.conf dedans
    Centreon Syslog Module Manager/Developper
    Centreon E2S Module Manager/Developper
    Centreon Enterprise Server (2.x / 3.x) : Centreon Engine 1.3.x / 1.4.x, Centreon Broker 2.6.x / 2.8.x , Centreon 2.x, Centreon-Syslog 1.5.x, Centreon E2S 2.0
    Nagios 3.x et NDOutil 1.x

    Comment


    • #3
      Ok j'ai copié centreon.conf dans conf-available et conf-enabled, j'ai ça dans available-conf :
      Code:
      # ls -l
      -rw-r--r-- 1 root root  239 avril  3 10:36 centreon.conf
      -rw-r--r-- 1 root root  315 juil. 20  2013 charset.conf
      -rw-r--r-- 1 root root  127 août  11  2013 javascript-common.conf
      -rw-r--r-- 1 root root 3224 juil. 20  2013 localized-error-pages.conf
      -rw-r--r-- 1 root root  189 juil. 20  2013 other-vhosts-access-log.conf
      -rw-r--r-- 1 root root 1344 févr. 28 21:20 php5-cgi.conf
      lrwxrwxrwx 1 root root   28 avril  2 15:02 phpmyadmin.conf -> ../../phpmyadmin/apache.conf
      -rw-r--r-- 1 root root 2190 juil. 20  2013 security.conf
      -rw-r--r-- 1 root root  458 juil. 20  2013 serve-cgi-bin.conf
      un restart de apache2, et j'ai
      Code:
      Forbidden
      
      You don't have permission to access /centreon on this server.
      donc j'ai fait un chmod 777 centreon.conf, pour avoir les même droit que phpmyadmin qui fonctionne dans conf-available et conf-enabled et un restart mais pareil .

      Voila le error.log
      Code:
      [Thu Apr 03 11:03:32.278919 2014] [mpm_prefork:notice] [pid 42226] AH00163: Apache/2.4.6 (Ubuntu) PHP/5.5.3-1ubuntu2.2 configured -- resuming normal operations
      [Thu Apr 03 11:03:32.279007 2014] [core:notice] [pid 42226] AH00094: Command line: '/usr/sbin/apache2'
      [Thu Apr 03 11:03:34.559700 2014] [authz_core:error] [pid 42230] [client 172.16.112.152:53031] AH01630: client denied by server configuration: /usr/local/centreon/www/
      Donc il ne veut pas que j'accede depuis un autre poste, alors qu mon centreon.conf est sous cette forme
      Code:
      Alias /centreon /usr/local/centreon/www/
      <Directory "/usr/local/centreon/www">
          Options Indexes
          AllowOverride AuthConfig Options
          Order allow,deny
          Allow from all
      </Directory>
      J'autorise bien tout le monde à acceder dans ce dernier?
      Last edited by apodog; 3rd April 2014, 11:35.

      Comment


      • #4
        J'ai trouvvvvvvvvvvvvvvvéééééééééé.

        J'ai la version 2.4 de apache et en passant de la 2.2 à 2.4 il y a des changements:
        version 2.2 :

        Order allow,deny
        Allow from all
        version 2.4 :

        Require all granted

        Comment


        • #5
          Bonjour, j'ai constaté le même problème avecla version de Centreon 2.4.1. J'ai suivi les différents commentaires de forum. Après avoir modifié le fichier conf-available avec Require all granted et après avoir redémaré le service apache2 !!! Je n'arrive toujours pas à accéder à l'interface web de centreon sur mon serveur. J'ai toujours le message d'erruer suivant : You don't have permission to access /centreon on this server.

          Comment

          Working...
          X