Announcement

Collapse
No announcement yet.

DB Error: unknown option portability ?? BUG de la 1.3 beta

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DonKiShoot
    replied
    Etrange car cette option dont'il parle existe bien dans la version que tu as d'installé :

    Code:
    » Summary	» License
    Database Abstraction Layer	PHP License
    » Current Release
    1.7.6 (stable) was released on 2005-04-11 (Changelog)
    » Description
    DB is a database abstraction layer providing:
    * an OO-style query API
    * portability features that make programs written for one DBMS work with other DBMS's
    * a DSN (data source name) format for specifying database servers
    * prepare/execute (bind) emulation for databases that don't support it natively
    * a result object for each query response
    * portable error codes
    * sequence emulation
    * sequential and non-sequential row fetching as well as bulk fetching
    * formats fetched rows as associative arrays, ordered arrays or objects
    * row limit support
    * transactions support
    * table information interface
    * DocBook and phpDocumentor API documentation
    
    DB layers itself on top of PHP's existing
    database extensions.
    
    Drivers for the following extensions pass
    the complete test suite and provide
    interchangeability when all of DB's
    portability options are enabled:
    
    fbsql, ibase, informix, msql, mssql,
    mysql, mysqli, oci8, odbc, pgsql,
    sqlite and sybase.
    
    There is also a driver for the dbase
    extension, but it can't be used
    interchangeably because dbase doesn't
    support many standard DBMS features.
    
    DB is compatible with both PHP 4 and PHP 5.
    » Maintainers	» More Information
    
        * Stig Bakken [Wishlist] (developer)
        * Thomas V.V.Cox [Wishlist] (developer)
        * Daniel Convissor [Wishlist] (lead)
        * Lukas Smith [Wishlist] (helper)
    
    	
    
        * Browse the source tree
        * RSS release feed
        * View Download Statistics
    
    » Packages that depend on DB
    
        * DB_ldap
        * Tree
        * Translation
        * LiveUser
        * Auth_PrefManager
        * DB_QueryTool
        * HTTP_Session
        * DB_ldap2
        * Auth
        * Services_Weather
        * Translation2
        * DB_Table
        * LiveUser_Admin
        * DB_odbtp
        * HTTP_SessionServer
        * XML_Query2XML
        * Structures_DataGrid_DataSource_DB
        * Structures_DataGrid_DataSource_DBQuery
        * DB_ado
        * Log
        * DB_DataObject
    Peut-être une vieille version de DB qui traine quelquepart :idea:

    Leave a comment:


  • bobothebest
    replied
    DB Error: unknown option portability ??

    jaurai aimé une solution pour mon cas puisque je nai pas trop le choix
    En effet, la machine Linux SUSE surlaquelle je travaille est en fet un serveur hock:
    impossible de formater :!:
    donc merci comme meme..
    mais jai toujours très besoin dune solution
    alors je cherche :roll:

    Leave a comment:


  • romsworld
    replied
    moi j'ai changé de distrib depuis le temps ! j'ai mis fedora 4. ou pte la 5 j'ai un doute maintenant et ca marche nikel

    Leave a comment:


  • bobothebest
    replied
    option portability

    maintenant on est deux :lol:
    bizarre cette erreur.sa fait longtemps que ta ce problème hock:
    si ta trouvé la solution ..alors stp envoi moi la répense
    cest tres gentil
    merci

    Leave a comment:


  • DB Error: unknown option portability ?? BUG de la 1.3 beta

    Bonjour,

    Je viens de finir l'installer d'oreon, tout est OK en vert d'apres l'install

    Une fois l'installation fini, il me dit : DB Error: unknown option portability lorsque je vais sur la page http://ip/oreon/

    Je suis sous Redhat EL3.

    Avec la oreon-1.2.3-RC4.tar.gz, aucun soucis.

    Pour INFO :

    pear -V
    PEAR Version: 1.1
    PHP Version: 4.3.2
    Zend Engine Version: 1.3.0

    Voici la liste des paquages PEAR que j'ai mis.

    Auth_SASL-1.0.1.tgz
    Date-1.4.6.tgz
    DB-1.7.6.tgz
    DB_DataObject-1.8.4.tgz
    HTML_Table-1.6.1.tgz
    DB_DataObject_FormBuilder-1.0.0RC4.tgz
    HTML_Common-1.2.2.tgz
    HTML_QuickForm-3.2.5.tgz
    HTML_QuickForm_advmultiselect-1.2.0.tgz
    Image_Canvas-0.3.0.tgz
    Image_Color-1.0.2.tgz
    Numbers_Roman-0.2.0.tgz
    Numbers_Words-0.14.0.tgz
    Image_Graph-0.7.2.tgz
    Image_GraphViz-1.2.0.tgz
    Mail_Mime-1.3.1.tgz
    MDB2-2.0.2.tgz
    Net_Ping-2.4.1.tgz
    Net_Traceroute-0.21.tgz
    Validate-0.6.3.tgz
    XML_RPC-1.4.8.tgz

    Merci
Working...
X