Announcement

Collapse
No announcement yet.

Can't generate Nagios-Files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't generate Nagios-Files

    Hi.

    Due to a hardware-issue on my centreon server I needed to reinstall (centreon 2.5.2) and reimport the database.
    Everything worked well, all hosts, services etc. are available.

    But when I try to generate the Monitoring Engine Files, I receive following error:

    Code:
    Progress (10%)
    Preparing environment... OK Generating files... NOK Aborted. [ - ] default Nagios Core 3.4.4 Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors Copyright (c) 1999-2009 Ethan Galstad Last Modified: 01-12-2013 - License: GPL Reading configuration data... Error in configuration file '/usr/share/centreon/filesGeneration/nagiosCFG/1/nagiosCFG.DEBUG' - Line 29 (UNKNOWN VARIABLE) Error processing main config file! ***> The name of the main configuration file looks suspicious... Make sure you are specifying the name of the MAIN configuration file on the command line and not the name of another configuration file. The main configuration file is typically '/usr/local/nagios/etc/nagios.cfg' ***> One or more problems was encountered while processing the config files... Check your configuration file(s) to ensure that they contain valid directives and data defintions. If you are upgrading from a previous version of Nagios, you should be aware that some variables/definitions may have been removed or modified in this version. Make sure to read the HTML documentation regarding the config files, as well as the 'Whats New' section to find out what has changed.
    Already looked into the file and line 29 contains following: use_check_result_path=0

    Looked around and searched and tried, but found no hint or solution...

    Any hints where to search or how to fix ?

    Best regards,

    Bergmann4711

  • #2
    same error, but in line 39, same variable
    any fix?
    thanks

    Comment


    • #3
      if I delete it, it generates a new error with a new variable

      Comment

      Working...
      X