Announcement

Collapse
No announcement yet.

Utiliser Centreon pour superviser un switch CISCO.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Utiliser Centreon pour superviser un switch CISCO.

    Bonjour à tous,

    J'ai très récemment fait la découverte de Centreon. Cherchant un logiciel performant de supervision afin d'effectuer la supervision de mon parc informatique (majoritairement composé de switch CISCO) j'ai décidé d'essayer de l'utiliser.
    Le téléchargement et l'installation du serveur n'ont posé aucun problème...
    Mais je ne parviens pas à me servir de centreon, et ce malgré toute la doc disponible.

    Je souhaiterai superviser au moins un switch cisco. Voici comment j'ai procédé jusque là :
    Je me suis rendu dans l'onglet "configuration", "hôtes", "ajout". J'y ai renseigné le nom de mon switch, l'adresse IP, la communauté SNMP ainsi que la version, le modèle, le serveur de supervision (par défaut, pas vraiment le choix de toute façon)... J'ai rempli les autres valeurs avec un peu moins de certitude. Pour la commande, j'ai utilisé le plugin disponible ici : check_snmp_netint.pl (je l'ai bien intégré au serveur et il est bien disponible dans ma liste de commande)
    Après avoir fait cela, je n'obtiens... absolument rien. Mon switch est bien visible dans le menu de configuration, mais pas ailleurs.
    Par exemple dans le menu "supervision", "hôtes", "hôtes", je ne vois que le serveur centreon et mon switch est absent.
    Pour la conf SNMP est bonne (test snmpwalk depuis le serveur).

    Comment faire apparaître mon switch dans la vue de supervision, et comment obtenir une supervision de ce dernier ? (Graphiques, logs....)
    J'ai fouillé partout dans les docs sans pouvoir trouver de vrai guide qui mène étape par étape à la supervision d'un item (hors supervision par mail). La plupart des guides se contente de décrire chaque menu sans en préciser l'utilité.


    Merci d'avance pour votre aide, à bientôt. (C'est assez urgent, si je pouvais avoir une réponse un minimum rapide... Merci !)

  • #2
    Bonsoir,

    Avez-vous pensé à générer et exporter la configuration ?

    Cordialement.
    /!\Pas de support en message privé - No support in private message/!\

    "Il se faut entraider, c'est la loi de la nature." © Jean de La Fontaine

    Comment


    • #3
      Au risque de paraître un peu simplet...
      Je n'ai justement pas trouvé de fonction "générer" la configuration. Ni exporter.

      Pour info, j'utilise la version Centreon 2.5.4.


      EDIT : A moins que vous ne parliez de cette manip : Configuration => Moteur de Supervision => Cocher générer les fichiers => Exporter.Ca je l'ai fais. Sans changement.
      Last edited by CentreonsUser; 30th January 2015, 10:22.

      Comment


      • #4
        Bonjour,

        Vous pourrez trouver de l'aide sur la documentation en ligne : http://documentation-fr.centreon.com...eur/index.html

        Cordialement.
        /!\Pas de support en message privé - No support in private message/!\

        "Il se faut entraider, c'est la loi de la nature." © Jean de La Fontaine

        Comment


        • #5
          Bonjour,

          Désolé pour ma réponse tardive. Je me sers déjà de cette documentation mais je n'arrive toujours pas à générer la configuration.
          En fait, j'ai bien configuré mon switch dans l'interface "configuration". J'ai bien rajouté mon centreon dans les access-list de mon switch... Mais mon switch ne veut pas s'afficher dans l'onglet "Accueil" - "Vues" etc...

          Comment


          • #6
            Je trouve aussi très étrange que la switch ne s'affiche pas dans votre console de Vues.
            Si tu as fait cette manip (Configuration => Moteur de Supervision => Cocher générer les fichiers => Exporter), tu devrais voir les services s'afficher dans les 2 petites barres en haut.
            Si ca ne fonctionne pas, il y a surement quelque chose que tu as oublié de faire.
            Il faudrait que tu mettes de captures d'écrans et que tu nous montres ton débugage.

            Au plaisir.

            Sébastien

            Comment


            • #7
              Merci de ta réponse.
              J'ai oublié de préciser avant que lorsque j'utilise la fonction "générer", un tableau apparaît en dessous avec ces informations :
              Progression (0%)
              Préparation de l'environnement... OK
              Génération des fichiers...
              Et ça reste bloqué comme ça. La progression reste à 0%.
              Mon problème vient donc très probablement de là !

              Quant aux screens, je ne crains de ne pas pouvoir en fournir actuellement... En espérant que mon problème puisse être résolu sans.

              Comment


              • #8
                Bonjour,

                Pouvez-vous regarder les logs de votre service web afin de voir s'il n'y a pas une erreur qui bloque la génération et l'export de la configuration ?

                Cordialement.
                /!\Pas de support en message privé - No support in private message/!\

                "Il se faut entraider, c'est la loi de la nature." © Jean de La Fontaine

                Comment

                Working...
                X