Announcement

Collapse
No announcement yet.

What is wrong in my configuration ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What is wrong in my configuration ?

    Hi,

    I migrated my old nagios3 + centreon server (debian) to centreon-engine + centreon (centos).
    I read this explanation of centreon-engin (http://www.centreon.fr/Article-Produ...eon-Engine/faq) which motivated me to migrate.

    I used the rpm packages to reinstall the server, and everything seemed to be fine.
    I installed the centreon web interface too (following the usual procedure : install.sh -i)

    I can connect to my web interface, only centreon-server is present. So everything is cool. But the problem is localized : the central poller seems to be misconfigured.

    - when I was exporting the configuration files, centreon broker configuration (named central-broker-master didn't find the config file name : central-broker.xml ) it didn't find it.

    - The central poller is not running

    - I see this in the log every 10 secondes

    Code:
    ==> /var/log/centreon-broker/central-module-master.log <==
    error:   TCP: could not connect to localhost:5669: Connection refused
    error:   TCP: could not connect to localhost:5669: Connection refused
    Could you help me ?

    Cheers

  • #2
    Hello,

    The cbmod.so charged by Centreon-Engine Module can not connect with the CBD demon.
    Can you provide us with the CBD log files?

    Regards.
    /!\Pas de support en message privé - No support in private message/!\

    "Il se faut entraider, c'est la loi de la nature." © Jean de La Fontaine

    Comment


    • #3
      Hi,

      I don't understand at all.
      Yesterday I stopped my VM and tried to install the CES virtual appliance.
      Today I tried to boot up my VM and and the central poller is runing...

      The only thing I did is to remove the IP address (127.0.0.1) into the Central poller as described in another thread.

      I only have one mistake in logAnalyser.log (but I read in another thread, that's normal. It is included into the Core even if I don't use NDO) :

      Code:
      2015-02-11 08:49:02 - This script is only suitable for NDO
      ----------------------

      I still have a huge problem using clapi.
      I exported the configuration from my old centreon server. And I tried to import it into the new server (using centreon-engine).
      The import worked well but it modified many things into the Configuration and administration panels lik : Configuration > Monitoring engine / Configuration > Centreon / Administration > ...
      I only want to import Hosts, services, users, commands. That's all...

      Do you know how to export only what I really want ?
      Last edited by shensi; 11th February 2015, 11:36.

      Comment


      • #4
        Hello guys,
        Any ideas ?

        Comment

        Working...
        X