No announcement yet.

What is wrong in my configuration ?

  • Filter
  • Time
  • Show
Clear All
new posts

  • What is wrong in my configuration ?


    I migrated my old nagios3 + centreon server (debian) to centreon-engine + centreon (centos).
    I read this explanation of centreon-engin ( which motivated me to migrate.

    I used the rpm packages to reinstall the server, and everything seemed to be fine.
    I installed the centreon web interface too (following the usual procedure : -i)

    I can connect to my web interface, only centreon-server is present. So everything is cool. But the problem is localized : the central poller seems to be misconfigured.

    - when I was exporting the configuration files, centreon broker configuration (named central-broker-master didn't find the config file name : central-broker.xml ) it didn't find it.

    - The central poller is not running

    - I see this in the log every 10 secondes

    ==> /var/log/centreon-broker/central-module-master.log <==
    error:   TCP: could not connect to localhost:5669: Connection refused
    error:   TCP: could not connect to localhost:5669: Connection refused
    Could you help me ?


  • #2

    The charged by Centreon-Engine Module can not connect with the CBD demon.
    Can you provide us with the CBD log files?

    /!\Pas de support en message privé - No support in private message/!\

    "Il se faut entraider, c'est la loi de la nature." © Jean de La Fontaine


    • #3

      I don't understand at all.
      Yesterday I stopped my VM and tried to install the CES virtual appliance.
      Today I tried to boot up my VM and and the central poller is runing...

      The only thing I did is to remove the IP address ( into the Central poller as described in another thread.

      I only have one mistake in logAnalyser.log (but I read in another thread, that's normal. It is included into the Core even if I don't use NDO) :

      2015-02-11 08:49:02 - This script is only suitable for NDO

      I still have a huge problem using clapi.
      I exported the configuration from my old centreon server. And I tried to import it into the new server (using centreon-engine).
      The import worked well but it modified many things into the Configuration and administration panels lik : Configuration > Monitoring engine / Configuration > Centreon / Administration > ...
      I only want to import Hosts, services, users, commands. That's all...

      Do you know how to export only what I really want ?
      Last edited by shensi; 11 February 2015, 10:36.


      • #4
        Hello guys,
        Any ideas ?