Announcement

Collapse
No announcement yet.

[RESOLVED] CES 3.1 - "Error: Could not connect to database" after setup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [RESOLVED] CES 3.1 - "Error: Could not connect to database" after setup

    I just downloaded and installed CES 3.1 as described here. Everything went well up until the last bit. Instead of going to the login screen, it goes to an error message (you can see it here). If I login to the server, I can connect to the MySQL using the username and password from the setup with no problem. Not sure where to go from here.

    EDIT: in centcore.log I'm seeing this error over and over:
    2015-03-02 21:04:27 - MySQL error : cannot connect to database centreon: Access denied for user 'centreon'@'localhost' (using password: YES) (caller: centreon::common::db:/usr/share/perl5/vendor_perl/centreon/common/db.pm:266)

    Which is really strange since using that user (centreon) I can access the database 'centreon' from the command line with no issue. I looked in conf.pm and I'm seeing the correct db_user and db_passwd.
    Last edited by mscfadmin; 3rd March 2015, 05:31.

  • #2
    Well, I reinstalled and everything worked this time. The only thing I did different was use only alpha characters in the DB password. Previously there was a "$" in the password. Not sure if that is what mattered, but it works now.

    Comment


    • #3
      Hi mscfadmin,

      had the same Problem when installing the new Centreon-3.4.1 from ISO.
      It's the same behaviour in this version if you use some special characters in Password.

      Your topic helped me to solve my Problem. Thanks
      Regards

      Comment

      Working...
      X