Announcement

Collapse
No announcement yet.

[RGLE] URGENT:ERREUR JpGraph - php-gd manquant

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [RGLE] URGENT:ERREUR JpGraph - php-gd manquant

    J'ai bien installé oreon,et install_nagios_by-oreon:
    les images ne s'affichent pas et me donnent l'erreur suivant:

    JpGraph Error: Can't create truecolor image. Check that you really have GD2 library installed.

    Est-ce je dois installé un package sur le serveur où est hébergé nagios et oreon qui n'est autre qu'un linux redhart 9
    ou bien sur ma machine sous windows 2000

    Merci pour votre réponse

  • #2
    sur le serveur uniquement... Il manque une dependance GD pour les jpgraph...
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Cad koi!?
      Quel package ke je dois installé ou bien comment je doi procéder?

      Comment


      • #4
        Les pre-requis pour l'installation de OREON sont :

        * Nagios 1.x
        * Nagios-plugins
        * make gcc
        * sudo
        * Mysql-3.x.x
        * php-4.x.x
        * php-mysql
        * apache 2.x
        * php-mysql
        * gd
        * gd-devel
        * libpng
        * libpng-devel
        * RRDTool


        La plateforme doit donc etre configuree avec un serveur web gerant le php et mysql. Ne pas oublier non plus que l'installation doit s'effectuer en root.

        Source: http://oreon.org/oreon.php?p=3
        Nagios 1.2
        Oreon v1.2.2-RC3

        Comment


        • #5
          installe le paquet php-gd

          Comment


          • #6
            skywolker : j'ai vérifié tous ces prérequis ils sont là tous
            climat : j'ai essayé de récuperer le rpm php-gd mais j'arrive pas à le trouver sur le net pour ma distribution redhat 9. Où je px le récuperer ?Sinon comment je px faire pour résourdre ce problème

            Merci pour vos retours

            Comment


            • #7
              moi j'ai une mandrake et j'ai fait un urpmi php-gd.

              mais si tu as un outils graphique pour telecharger les paquets cherche les trucs gd et tu devrais trouver le php-gd.

              sinon desolé pour toi !

              Comment


              • #8
                php-gd n'existe pas pour la redhat 9 apparement donc a part compiler gd et recompiler php avec support gd, je ne vois pas trop.

                Tu peux toujours tester des rpm php-gd assez ancien en esperant que ca foute pas ta machine par terre :wink:
                Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                Fedora Core 5 - 2.6.20-1.2320

                Comment

                Working...
                X