Announcement

Collapse
No announcement yet.

Pb generation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pb generation

    Bonjour,

    J'ai suivi le wiki pour le paramétrage de oreon mais lorsque je génère les fichiers de conf je n'obtiens aucune réponse

    sauf si je coche déplacer les fichiers

    cgi.cfg - déplacement OK
    checkcommands.cfg - déplacement OK
    contactgroups.cfg - déplacement OK
    contacts.cfg - déplacement OK
    dependencies.cfg - déplacement OK
    escalations.cfg - déplacement OK
    hostextinfo.cfg - déplacement OK
    hostgroups.cfg - déplacement OK
    hosts.cfg - déplacement OK
    misccommands.cfg - déplacement OK
    nagios.cfg - déplacement OK
    resource.cfg - déplacement OK
    serviceextinfo.cfg - déplacement OK
    services.cfg - déplacement OK
    timeperiods.cfg - déplacement OK

    et donc rien dans le monitoring.....

    FEDORA 3 - OREON 1.3 RC2

  • #2
    tu as bien fait redemarrer le serveur nagios aussi ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Oui je coche la case redemarrer nagios mais rien n'y fait

      Comment


      • #4
        haha le sudo est bien configuré ?
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Hello

          Originally posted by julio
          haha le sudo est bien configuré ?
          Justement... est ce que le sudo mal configuré peut empécher les cfg de se regénérer ?

          J'ai le même pb. Quand je clique sur le "Générer", tout est ok sauf que je n'ai rien, l'ensemble est vide d'hôtes, de services...

          Comment


          • #6
            fais tu : "deplacer les conf" ?
            Julien Mathis
            Centreon Project Leader
            www.merethis.com |

            Comment


            • #7
              Originally posted by julio
              fais tu : "deplacer les conf" ?
              parfois oui, parfois non... le même résultat se présente. Mais je confirme que le pb provient du sudoers

              EDIT : ah non pardon, je viens de regarder l'error.log et j'ai ce message quand je veux déplacer les fichiers :

              Code:
              [Wed Jul 12 11:01:25 2006] [error] [client 192.168.2.189] PHP Fatal error:  Only variables can be passed by reference in /usr/local/oreon/www/include/configuration/configGenerate/formGenerateFiles.php on line 146, referer: [url]http://nagios.xxx.fr/oreon/oreon.php?p=607[/url]
              la ligne 146 est :

              if ($ret["move"]["move"]) {
              $msg .= "
              ";
              foreach (glob($nagiosCFGPath ."*.cfg") as $filename) {
              $bool = copy($filename , $oreon->Nagioscfg["cfg_dir"].basename($filename));
              $filename = array_pop(explode("/", $filename));
              $bool ? $msg .= $filename.$lang['gen_mvOk']."
              " : $msg .= $filename.$lang['gen_mvKo']."
              ";

              Comment

              Working...
              X