Announcement

Collapse
No announcement yet.

[Résolu] probleme de graph RC2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu] probleme de graph RC2

    Bonjour,

    J'aurais voulu verifier avant de vous embeter si j'ai tous les modules PEAR necessaire pour le bon fonctionnement d'oreon.

    J'ai aucun graph par contre j'ai mes camenberts .

    il y avait un post qui regroupais tous les modules pear pour oreon, mais je n'arriveplus à mettre la main dessus.

    voici mes modules installer:

    Installed packages, channel pear.php.net:
    =========================================
    Package Version State
    Archive_Tar 1.3.1 stable
    Auth_SASL 1.0.2 stable
    Console_Getopt 1.2 stable
    DB 1.7.6 stable
    DB_DataObject 1.8.4 stable
    DB_DataObject_FormBuilder 1.0.0RC4 beta
    Date 1.4.6 stable
    HTML_Common 1.2.2 stable
    HTML_QuickForm 3.2.6 stable
    HTML_QuickForm_advmultiselect 1.2.0 stable
    HTML_Table 1.7.2 stable
    HTTP 1.4.0 stable
    Image_Canvas 0.2.4 alpha
    Image_Color 1.0.2 stable
    Image_Graph 0.7.1 alpha
    Image_GraphViz 1.2.1 stable
    MDB2 2.1.0 stable
    Mail 1.1.10 stable
    Mail_Mime 1.3.1 stable
    Net_Ping 2.4.1 stable
    Net_SMTP 1.2.8 stable
    Net_Socket 1.0.6 stable
    Net_Traceroute 0.21 alpha
    Numbers_Roman 0.2.0 stable
    Numbers_Words 0.14.0 beta
    PEAR 1.4.9 stable
    Validate 0.6.3 beta
    XML_Parser 1.2.7 stable
    XML_RPC 1.5.0 stable

    J'ai regardé pas mal de post qui pourrais concerner mon problème, mais je ne trouve pas les mêmes symptomes.
    Oreon 1.4
    Débian Etch
    Nagios 2.9

  • #2
    tu as la liste de tous les pré-requis necessaire au bon fonctionnement de oreon

    http://www.oreon-project.org/pre-req...eon-1.3.x.html
    :P

    EDIT : de rien 8)
    windows XP pro
    VM

    Comment


    • #3
      pff je rentre de week et deja fatigué elle va etre longue cette semaine

      Merci Kyo
      Oreon 1.4
      Débian Etch
      Nagios 2.9

      Comment


      • #4
        J'ai tout vérifier j'ai même des paquets en + .

        voici mon problème, j'ai une croix rouge à la place de mes ou mon graph (l'image n'est pas accessible ou bien ?).

        J'ai bien des bases RRD.

        Quelqu'un pourait-il m'aiguiller plz ?
        Oreon 1.4
        Débian Etch
        Nagios 2.9

        Comment


        • #5
          verifie que tu as bien rrdtool d'installer pour verifier
          va dans le repertoire rrd
          et tape
          #> rrdtool info "et un fichier .rrd"

          exemple moi jai :

          #> rrdtool info 2_3.rrd

          rrdtool info 2_3.rrd
          filename = "2_3.rrd"
          rrd_version = "0003"
          step = 300
          last_update = 1153131139
          ds[a].type = "GAUGE"
          ds[a].minimal_heartbeat = 600
          ds[a].min = NaN
          ds[a].max = NaN
          ds[a].last_ds = "UNKN"
          ds[a].value = 1.7508000000e+01
          ds[a].unknown_sec = 0
          rra[0].cf = "AVERAGE"
          rra[0].rows = 8640
          rra[0].pdp_per_row = 1
          rra[0].xff = 5.0000000000e-01
          rra[0].cdp_prep[0].value = NaN
          rra[0].cdp_prep[0].unknown_datapoints = 0
          rra[1].cf = "MIN"
          rra[1].rows = 8640
          rra[1].pdp_per_row = 12
          rra[1].xff = 5.0000000000e-01
          rra[1].cdp_prep[0].value = 1.1996000000e-01
          rra[1].cdp_prep[0].unknown_datapoints = 0
          rra[2].cf = "MAX"
          rra[2].rows = 8640
          rra[2].pdp_per_row = 12
          rra[2].xff = 5.0000000000e-01
          rra[2].cdp_prep[0].value = 1.2467000000e-01
          rra[2].cdp_prep[0].unknown_datapoints = 0

          si ca marche bah tu devrais pouvoir grapher aussi
          donc attend un moment histoire que tes bases rrd se remplissent

          sinon verifie les droits sur rrd
          droit en ecriture pour luser nagios et le groupe nagios

          verifie que les champs son correctement renseigner dans option => option general
          8)
          good luck
          windows XP pro
          VM

          Comment


          • #6
            j'ai bien rrdtool-1.0.49 d'installé
            j'ai des fichier rrd au nombre de 3
            1 host et 2 services
            mais quand je tape rrdtool info 1_1.rrd
            -bash: rrdtool: command not found

            hop

            apt-get install rrdtool
            il m'a installer la rrdtool 1.0.49-1
            A content Rosko

            rrdtool info 1_1.rrd

            filename = "1_1.rrd"
            rrd_version = "0001"
            step = 300
            last_update = 1153136109
            ds[a].type = "GAUGE"
            ds[a].minimal_heartbeat = 600
            ds[a].min = NaN
            ds[a].max = NaN
            ds[a].last_ds = "UNKN"
            ds[a].value = 9.8191800000e+04
            ds[a].unknown_sec = 0
            ds[b].type = "GAUGE"
            ds[b].minimal_heartbeat = 600
            ds[b].min = NaN
            ds[b].max = NaN
            ds[b].last_ds = "UNKN"
            ds[b].value = 5.9310000000e+02
            ds[b].unknown_sec = 0
            rra[0].cf = "AVERAGE"
            rra[0].rows = 8640
            rra[0].pdp_per_row = 1
            rra[0].xff = 5.0000000000e-01
            rra[0].cdp_prep[0].value = NaN
            rra[0].cdp_prep[0].unknown_datapoints = 0
            rra[0].cdp_prep[1].value = NaN
            rra[0].cdp_prep[1].unknown_datapoints = 0
            rra[1].cf = "MIN"
            rra[1].rows = 8640
            rra[1].pdp_per_row = 12
            rra[1].xff = 5.0000000000e-01
            rra[1].cdp_prep[0].value = 5.8325700000e+03
            rra[1].cdp_prep[0].unknown_datapoints = 0
            rra[1].cdp_prep[1].value = 6.7903333333e+01
            rra[1].cdp_prep[1].unknown_datapoints = 0
            rra[2].cf = "MAX"
            rra[2].rows = 8640
            rra[2].pdp_per_row = 12
            rra[2].xff = 5.0000000000e-01
            rra[2].cdp_prep[0].value = 1.0286825000e+04
            rra[2].cdp_prep[0].unknown_datapoints = 0
            rra[2].cdp_prep[1].value = 6.8888666667e+01
            rra[2].cdp_prep[1].unknown_datapoints = 0

            Youpi ca marche j'ai du bidouiller un peu .

            super grand mici Kyo
            Oreon 1.4
            Débian Etch
            Nagios 2.9

            Comment


            • #7
              bon bon bah si tu as tes graph y'a plus qu'a mettre resolu sur ton post ^^
              windows XP pro
              VM

              Comment


              • #8
                Euh juste pour info : quand vous parlez des "bases rrd", s'agit-il d'une bd dans mysql ?

                parce que mon usine à gaz n'arrive pas à créer des fichiers rrd (ie : 2_3.rrd).
                Et je me prends sauvagement la tête dessus :/

                ++

                Comment


                • #9
                  les bases rrd son les fichiers contenu dans RRD dans le repertoire de oreon

                  si tu te prend la tete dessus
                  veille a ce que le repetoire ait les droits
                  user : nagios
                  group : nagios

                  et les droit en ecriture 775

                  voila :wink:
                  windows XP pro
                  VM

                  Comment


                  • #10
                    c'est ce que j'ai entrepris en premier

                    Mais ça ne donne rien :/

                    Comment

                    Working...
                    X