Announcement

Collapse
No announcement yet.

Impossible d'acceder à l'interface graphique pour l'instal

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impossible d'acceder à l'interface graphique pour l'instal

    Bonjour à tous,


    Je solicite votre aide, car étant débutant dans le monde de Linux, je n'arrive pas à lire des fichiers en PHP.
    Je m'explique.

    J'ai suivi le tuto afin d'installer Nagios avec l'environnement OREON http://wiki.oreon-project.org/wakka.php?wiki=SeTupFR
    Mais au moment d'acceder à l'interface web pour continuer l'installation, lorsque je fait http://monip/oreon/ au lieu de m'envoyer sur une interface, il me proose de télécharger le fichier sachant que c'est un .PHTML

    Je sais que vous trouverez sa un peu idiot mais je vois pas trop ...

    Pourriez vous m'aider svp, merci d'avance,

  • #2
    quelle distrib ? quel version de PHP ? php est bien loadé par apache ?
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Hello,

      Ce n'est pas bien grave... Ton serveur apache n'interprète pas le PHP.

      - Quelle est ta distribution Linux ?

      Typiquement pour Gentoo, tu dois ajouter le module PHP dans

      Code:
      /etc/conf.d/apache2
      
      APACHE2_OPTS="-D DEFAULT_VHOST -D NAGIOS -D PHP5 -D PERL"

      Comment


      • #4
        Je suis sur une Ubuntu Dapper 6.06LTS.
        Je tourne PHP5 APACHE2.

        Quand je fais http://monipj'arrive sur la page des dossier présent dans /var/www (apache, phpmyadmin...), et dès l'instant ou je veut afficher une page PHP, Il me demande si je veut télécharger le fichier.

        Comment


        • #5
          Originally posted by akalaan
          Je suis sur une Ubuntu Dapper 6.06LTS.
          Je tourne PHP5 APACHE2.

          Quand je fais http://monipj'arrive sur la page des dossier présent dans /var/www (apache, phpmyadmin...), et dès l'instant ou je veut afficher une page PHP, Il me demande si je veut télécharger le fichier.
          Que donne la commande suivante:

          Code:
          aptitude search libapache2-mod* |grep ^i
          Raphaël 'SurcouF' Bordet
          Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
          Dons Paypal

          Comment


          • #6
            Sa mouline pendant 5-6 secondes et ca revient au prompt

            Comment


            • #7
              tout d'abord petit misa jour des source de apt-get :

              Code:
              vi /etc/apt/sources.list
              
              rajoute sa :
              
              deb http://packages.dotdeb.org stable all
              deb-src http://packages.dotdeb.org stable all
              ensuite tu fais un :

              Code:
              apt-get update
              et

              Code:
              apt-get install libapache2-mod-php5
              [/code]

              Comment

              Working...
              X