Announcement

Collapse
No announcement yet.

Perfparse

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Perfparse

    I have a new install of Oreon on an existing nagios 2 system that was already running perfparse. Perfparse is still receiving data, but I can't seem to get any graphs to come up when I try them through the oreon interfaces.

    When I click on the mini graph icon in the monitoring section i get a message that says "Database unavailable". When I click through the "Oreon' Views" I get no hosts or services showing up at all.

    Any ideas as to what I should be checking?

    Thanks,
    -Bob

  • #2
    Does your perfparse store in database ?
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      yes. they store in a mysql database on the localhost. The database has data in it, and nagios is still writing data to it. Just nothing from oreon.

      Comment


      • #4
        there was a problem in the cfg_perfparse table that set perfparse_enabled to off. I fixed that but now i have the dreaded "Problem with Perfparse Database connection : DB Error: connect failed".

        I created another user for the database and tried the OLD_PASSWORD method and I still can't connect.

        Any ideas as to what I should try now?

        Comment


        • #5
          This was a database permissions issue. I recreated the user account that oreon was using to read that database and it worked fine.

          Everything is good except my graphs are all empty.

          Comment

          Working...
          X