Announcement

Collapse
No announcement yet.

Orean-1.3 Nagios2.5 Setup .Cannot access web page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Orean-1.3 Nagios2.5 Setup .Cannot access web page

    Hi i have downloaded the nagios and oreon install from the net and gone through the installer problem free.

    however I cannot finish installatio as i acnnot access the wesite

    http://servername/oreon/
    or
    http://servername/oreon/install/setup.php

    I can access http://servername/ which shows apache is running
    I can also acced http://servername/nagios/ which shows nagioa installed ok


    Ant ideas . I am quite new to all this .


    regards


    ED

  • #2
    Sorry I am using Debian sarge linux with a 2.4.28 kernel.

    Comment


    • #3
      do you restart your apache ?
      is there any configuration add who have been made by Oreon installer in your apache config ? Something like "alias /oreon /usr/local/oreon/www" etc .... ???
      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
      Fedora Core 5 - 2.6.20-1.2320

      Comment


      • #4
        Duplicated posts ... ok, I answer here too ;P

        Please, post attached apache error log file to make a better idea of what is happening. Also post attached httpd.conf file to see if you're setting up apache part correctly.
        [Linux 2.4.20-28.7 - RedHat 7.2]
        [Linux 2.6.16.21-0.25 - OpenSuSE 10.1]
        [Apache 1.3.x, PHP 5.x, MySQL 5.x]
        [Apache 2.2.x, PHP 5.x, MySQL 5.x]
        [Nagios 1.4.1+Nagmin -Production-, Nagios 2.5+Oreon 1.3.1-1 -PreProduction-, Nagios 2.5+Oreon 1.3.1-1 -Testing-]

        Comment


        • #5
          I have attached the config. one thing I have noticed is that the /etc/apache2/http.conf only has entries made by the nagios installer.

          This is here for backwards compatability reasons and to support
          # installing 3rd party modules directly via apxs2, rather than
          # through the /etc/apache2/mods-{available,enabled} mechanism.
          #
          #LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so
          #Section added by Oreon Team

          ScriptAlias /nagios/cgi-bin /usr/local/nagios/sbin

          <Directory "/usr/local/nagios/sbin">
          Options ExecCGI
          AllowOverride None
          Order allow,deny
          Allow from all
          AuthName "Nagios Access"
          AuthType Basic
          AuthUserFile /usr/local/nagios/etc/htpasswd.users
          Require valid-user
          </Directory>

          Alias /nagios /usr/local/nagios/share

          <Directory "/usr/local/nagios/share">
          Options None
          AllowOverride None
          Order allow,deny
          Allow from all
          AuthName "Nagios Access"
          AuthType Basic
          AuthUserFile /usr/local/nagios/etc/htpasswd.users
          Require valid-user
          </Directory>

          Comment


          • #6
            there is no /etc/httpd/conf.d/oreon.conf ?
            Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
            Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
            Fedora Core 5 - 2.6.20-1.2320

            Comment


            • #7
              No the notes tell you to delete it

              http://www.debianhelp.co.uk/oreon.htm

              Comment


              • #8
                ok i see ! but how to tell apache where found oreon's files ???

                It's very strange. hock:

                Maybe a French debiannist may help you. Wait and see :wink:
                Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                Fedora Core 5 - 2.6.20-1.2320

                Comment


                • #9
                  Manage to get it working. looks like a PDH4 Apache2 configuation .

                  Very good website http://www.debianhelp.co.uk/apachephp.htm

                  -----------------------------------------------------------------------------------

                  DirectoryIndex index.html index.htm index.shtml index.cgi index.pl index.php index.php4 index.xhtml

                  and add these two lines in the section where you can find AddType and AddHandler directives

                  AddHandler php-script .php4
                  Action php-script /cgi-bin/php4

                  This will make sure that PHP files with the extension .php4 are executed as CGI. PHP files with the extension .php will be run by the Apache2-PHP5 module.

                  Next, we have to enable a few Apache modules, like for example the actions module otherwise we cannot run PHP4 as CGI

                  #a2enmod actions ssl rewrite suexec include

                  Now you need to restart your apache server using the following command

                  #/etc/init.d/apache2 restart

                  Comment

                  Working...
                  X