Announcement

Collapse
No announcement yet.

Missing Pie Charts on front page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing Pie Charts on front page

    I recently installed 1.3RC3-1 and must have missed some thing. I have no pie charts on the home page. Does anyone know what I missed, and how to fix it?

    thanks.

  • #2
    Check gd install ...

    Zby-)

    Comment


    • #3
      If you check the image properties, you can watch the url and launch it in an other web navigator. Check and tell us the msg.
      Romain Le Merlus
      Centreon Forge
      MERETHIS

      Comment


      • #4
        I realized that I didn't have gd installed when I installed Oreon. I've since installed it. Should I re-run the Oreon install script to get it working? Is there another way?

        Thanks.

        Comment


        • #5
          no if gd is correctely installed.

          gd for php ?

          since restart apache
          Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
          Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
          Fedora Core 5 - 2.6.20-1.2320

          Comment


          • #6
            I'm running Ubuntu Linux (Dapper) and have php4-gd installed via apt-get. I thought I had alll the php/pear items installed too.

            To debug this, I replaced pie_chart_service.php with an image file, and the image showed up on the web page as expected. I then tried running pie_chart_service.php from the command line and got:
            Code:
            # php pie_chart_service.php
            
            Warning: main(Image/Graph.php): failed to open stream: No such file or directory in /usr/local/oreon/www/include/home/pie_chart_service.php on line 17
            
            Fatal error: main(): Failed opening required 'Image/Graph.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/oreon/www/include/home/pie_chart_service.php on line 17
            So I tried:
            Code:
            # pear install Image_Graph
            Failed to download pear/Image_Graph within preferred state "stable", latest release is version 0.7.2, stability "alpha", use "channel://pear.php.net/Image_Graph-0.7.2" to install
            Cannot initialize 'Image_Graph', invalid or missing package file
            Package "Image_Graph" is not valid
            install failed
            I tried installing the alpha versions of Image_Graph and Image_Canvas, but pear ultimately complained that gd was not installed. It IS installed (both libgd1 and libgd2) along with libgd-tools and python-gd. Both libgdtools and p[ython-gd work correctly.

            I've either got a version conflict or php can't see the libraries. I'm stumped. Any more suggestions?

            Comment


            • #7
              Solved!

              After a little more Googling of the error I found references to the Ubunto packages hp-image-canvas and php-image-graph. After installing them with apt-get, the graph started working!

              Thanks or all the responces and suggestions, they put me on the right track.

              Comment

              Working...
              X