Announcement

Collapse
No announcement yet.

packages requis avant installation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • packages requis avant installation

    Bonjour,

    je viens tout juste de faire fonctionner Nagios correctement et je voudrais installer Oreon par dessus maintenant pour voir ce que ca donne.

    Je suis sous Red Hat ES 4. J'ai installé Nagios et les dépendances avec RPM mais pour Oreon, je n'ai pas le choix, c'est un tar.gz.
    Le fichier INSTALL dit :
    Code:
    To use graphic plugins, you need to have on your server :
    - RRDTOOL
    - perl/RRDTOOL (RRDs.pm)
    - Net::SNMP
    
    To use Oreon, you need to have on your server :
    - php4 ( php5 not supported yet )
    - php-snmp
    - php-gd
    - perl-GD
    mais je n'arrive pas à installer tout ca.
    J'ai le package rrdtool-1.2.15-1.el4.rf.i386.rpm mais il nécessite des dépendances :
    Code:
    # rpm -ivh ../rrdtool-1.2.15-1.el4.rf.i386.rpm
    warning: ../rrdtool-1.2.15-1.el4.rf.i386.rpm: V3 DSA signature: NOKEY, key ID 66
    error: Failed dependencies:
            perl(RRDp) is needed by rrdtool-1.2.15-1.el4.rf.i386
            perl(RRDs) is needed by rrdtool-1.2.15-1.el4.rf.i386
    et je ne les trouve pas.

    j'ai pas trouvé de package perl/RRDTOOL et pour php, j'ai pour l'instant installé :
    php-4.3.9-3.8
    php-pear-4.3.9-3.8

    Ou trouver le reste ??
    Comment avez vous installé tout cela ?

    Vous le voyez, je n'en suis qu'au debut mais je bloque deja.
    Merci de votre aide

  • #2
    il y a une histoire de perl-rrdtool et de rrdtool-perl en rpm à installer
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Il faut installer rrdtool en -force, et apres perl-rrdtool. Les deux packages s'appellent tout simplement donc faut faire un choix en premier :wink:
      Romain Le Merlus
      Centreon Forge
      MERETHIS

      Comment


      • #4
        Les deux packages s'appellent tout simplement donc faut faire un choix en premier
        Ou les installer tous les 2 en même temps:
        Code:
        rpm -ivh packet1.rpm packet2.rpm

        Comment


        • #5
          J'ai eu mon diplome Etape 4 !

          J'en suis donc à l'étape 5 et là.....
          Code:
          PHP Pear Extension
             
             DB                                                        OK 
             DB_DataObject                                      Failed 
          Need DB_DataObject-1.8.4 
             DB_DataObject_FormBuilder                   Failed 
          Need DB_DataObject_FormBuilder-1.0.0RC4 
             MDB2                                                    Failed 
          Need MDB2-2.0.0 
             Date                                                      Failed 
          Need Date-1.4.6 
             Numbers_Roman                                    Failed 
          Need Numbers_Roman-1.0.1 
             Numbers_Words                                     Failed 
          Need Numbers_Words-0.14.0 
             HTML_Common                                      Failed 
          Need HTML_Common-1.2.2 
             HTML_QuickForm                                    Failed 
          Need HTML_QuickForm-3.2.5 
             HTML_QuickForm_advmultiselect              Failed 
          Need HTML_QuickForm_advmultiselect-1.1.0 
             HTML_Table                                            Failed 
          Need HTML_Table-1.6.1 
             Archive_Tar                                            OK 
             Auth_SASL Failed 
          Need Auth_SASL-1.0.1 
             Console_Getopt                                      OK 
             HTTP OK 
             Image_Canvas                                       Failed 
          Need Image_Canvas-0.2.4 
             Image_Color                                          Failed 
          Need Image_Color-1.0.2 
             Image_Graph                                         Failed 
          Need Image_Graph-0.7.1 
             Image_GraphViz                                     Failed 
          Need Image_GraphViz-1.1.0 
             Mail                                                       OK 
             Mail_Mime                                              Failed 
          Need Mail_Mime-1.3.1 
             Net_SMTP                                              OK 
             Net_Socket                                            OK 
             Net_Traceroute                                      Failed 
          Need Net_Traceroute-0.21 
             Net_Ping                                               Failed 
          Need Net_Ping-2.4.1 
             Validate                                                Failed 
          Need Validate-0.6.2 
             XML_RPC                                              OK
          j'ai le package php-pear-4.3.9-3.8 correctement installé.
          Les composants Pear... comment je les installe ?? (je n'ai rien trouvé sous forme de package)

          Comment


          • #6
            euh non rien je m'a trompé de post

            Comment

            Working...
            X