Announcement

Collapse
No announcement yet.

Call to undefined method DB_Error::fetchInto()

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Call to undefined method DB_Error::fetchInto()

    When clicking on "Oreon' views" there isn't any graph being displayed and the only error I see is this one:
    Fatal error: Call to undefined method DB_Error::fetchInto() in /usr/local/oreon/www/include/views/graphs/simpleRenderer/simpleRenderer.php on line 57
    anybody that got the same error, and maybe fixed it or knows how to fix it...I'm using the latest version...

  • #2
    Re: Call to undefined method DB_Error::fetchInto()

    I am having the exact same error. It only appears on the page of the "simple Graphs renderer" (which is the default when clicking the Oreon's Views"button?)

    Although I am not familiar with PHP and/or PEAR, I did notice the fetchInto function is also called in other graph-pages. So apparently the fetchInto function is available on my system.

    I have followd this page for my installation. But I have not yet defined any data that should appear in a graph... Also I do not see any error in nagios.log

    I am Using Oreon 1.3.1.1 on a Gentoo system, with the following USE-flags (but I don't thinks there is anything wrong with these flags):

    USE="-* nptl nptlonly symlink bzlib pam ssl zlib tcpd crypt perl logrotate bzip2 acl syslog kerberos apache2 mpm-prefork mysql cgi iconv xml cli pcre session gd ldap sasl nagios-dns nagios-ping nagios-ssh nagios-ntp snmp jpeg png posix openntpd berkdb mysqli"

    Comment


    • #3
      Hi Folks,

      I'va had this error once too.
      A missing PEAR module causes this one. You have to intall the DB Module with ALL his dependencies.
      If you've got problems with the perfparse then have a look at:
      http://forum.oreon-project.org/viewtopic.php?t=2653
      Or post here for further questions.
      Bye,

      Ira

      Comment


      • #4
        Originally posted by Iralein
        Hi Folks,

        I'va had this error once too.
        A missing PEAR module causes this one. You have to intall the DB Module with ALL his dependencies.
        If you've got problems with the perfparse then have a look at:
        http://forum.oreon-project.org/viewtopic.php?t=2653
        Or post here for further questions.
        Bye,

        Ira
        That was my prob too. I installed some PEAR modules using Gentoo's Emerge. This apparently does not work good!

        I installed all required PEAR-modules using:

        #pear config-set preferred_state alpha
        # pear install --alldeps <module-name>

        Now i no longer have this error, and see the pie-chart on startpage. Probably the graphs would also work, if I would be able to get some data into the perfparse db

        Comment

        Working...
        X