Announcement

Collapse
No announcement yet.

souci avec le redemarrage nagios

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • souci avec le redemarrage nagios

    Bonjour

    je suis actuellement sous debian avec un oreon v1.3-RC3-1.
    J'ai remarqué que bien souvent j'avais plusieurs process nagios qui tournait :

    nagios 28049 0.3 0.0 21392 2528 ? Ss Oct09 10:11 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
    nagios 25546 0.2 0.0 20364 2432 ? Ss 12:09 0:01 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
    nagios 5012 0.0 0.0 21396 2052 ? S 12:17 0:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
    nagios 5013 3.2 0.0 10336 7488 ? S 12:17 0:00 /usr/bin/perl -w /usr/local/nagios/libexec/check_graph_uptime.pl -H 192.168.255.229 -C public -v 1 -d -g -S 216_1354
    nagios 5143 0.0 0.0 21396 2052 ? S 12:17 0:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
    nagios 5144 4.3 0.0 10328 7544 ? S 12:17 0:00 /usr/bin/perl -w /usr/local/nagios/libexec/check_graph_traffic.pl -H 192.168.255.229 -i 16777219 -w 80 -c 100 -C public -v 1 -g -S 216_1692
    nagios 5195 0.0 0.0 21396 2052 ? S 12:17 0:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg

    J'ai constaté que ca me causait un souci apparement dans l'affichage du statut. En clair, sur la page des status, quand je force le rafraichissement de la page
    1-je vois un coup un message d'alerte
    2-je rafraichit (F5) ca disparait
    3-je rafraichit-->ca rapparait


    c'est assez pénible car on ne sais jamais quel est le vrai statut du test a moins de reforcer un check derriere.

    J'ai eu aussi pdt presque une semaine une disparition des graphs (je pense qu'un des process nagios prenait le dessus sur les autres et n'alimentait pas la base RRD)

    J'ai l'impression que cela survient qd je regenre nagios apres avoir ajouter des tests.
    y a t-il un moyen de corriger ca (en mode violent : killall nagios ? )

    merci

    ps : je sais si c'est assez clair en fait :lol:
    Oreon 1.4.1
    Debian
    90 Hosts et plus de 900 Services

  • #2
    bon personne a le meme souci on dirait
    Oreon 1.4.1
    Debian
    90 Hosts et plus de 900 Services

    Comment


    • #3
      salut math,

      j'ai rencontré le même genre de problème: j'ai supprimé un service et il apparaissait encore de temps en temps dans l'onglet monitoring..
      ou encore des désactivations de notifications non prises en compte.


      je suis tombée là dessus: http://forum.oreon-project.org/viewt...ocessus+nagios


      j'ai stoppé nagios, killer tous les processus nagios et relancé nagios..pour l'instant ca semble aller mieux...
      Nagios 2.2 - Oreon 1.3

      Comment


      • #4
        hello,

        en effet je fais ca mais ce n'est pas jouable. je passe ma journée à rajouter des tests sur le serveur.
        est ce qqch qui sera corrigé ds le futur?
        Oreon 1.4.1
        Debian
        90 Hosts et plus de 900 Services

        Comment


        • #5
          Salut Math,

          J'avais le même problème que toi avec ma Sarge et mon Nagios 1.3. Souvent, les processus Nagios ne se terminaient pas.
          Depuis que je suis passé à Nagios 2.5 sur Etch, je n'ai plus aucun problème.

          Mac.
          Debian Etch - Noyau 2.6.16-2-486
          Nagios 2.5 - Oreon 1.3.1-1 sans Perfparse.
          Apache2/ Mysql 5.0 / PHP4

          Comment


          • #6
            Salut à tous,

            hum, moi j'utilise la version 2.5 mais magrès ça, j'ai toujous le même problème (2e fois en 1semaine :? )....

            Bien à vous

            Fred

            Comment


            • #7
              Originally posted by macphisto
              Salut Math,

              J'avais le même problème que toi avec ma Sarge et mon Nagios 1.3. Souvent, les processus Nagios ne se terminaient pas.
              Depuis que je suis passé à Nagios 2.5 sur Etch, je n'ai plus aucun problème.

              Mac.
              La version Debian Etch n'est pas stable .... Correct ?
              FAN 2.0

              Comment

              Working...
              X