Announcement

Collapse
No announcement yet.

perfparse + bbase mysql vide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gwayawan
    replied
    Bon démarré manuellement, voila ce que ca donne:

    ciscpr12:/# /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
    /usr/local/nagios/bin/nagios: error while loading shared libraries: libltdl.so.3: cannot open shared object file: No such file or directory

    par contre les librairies en question existe bien!!!!!!

    Leave a comment:


  • gwayawan
    replied
    Voila le message obtenu apres la mise a jour de nagios au start:


    korn1:/# /etc/init.d/nagios start
    Starting network monitor: nagios
    CONFIG ERROR! Start aborted. Check your Nagios configuration.
    korn1:/#

    j'ai donc remplacé l'ancien binaire par le nouveau créé comme suit:

    # ./configure --enable-embedded-perl --with-perlcache --disable-statuswrl --with-default-perfdata

    # make nagios

    rien ne marche!!!

    Leave a comment:


  • gwayawan
    replied
    RE, il se peut aussi que ce soit ma mise a jour de nagios avec le support perfparse qui ait foiré!!!

    je me souviens plus ce que j'ai trifouillé, ça fait un moment que j'ai plus touché à OREON.

    Donc j'ai recompilé le binaire nagios comme il faut (sa taille est 3 fois plus grosse que la binaire nagios de base!!!!)

    mais quand je remplace l'ancien par celuici dans le /usr/local/nagios/bin/ ca foire au start du daemon!!!!!

    qq'un a une idée!!!

    Leave a comment:


  • gwayawan
    replied
    HELLO Surcouf, mes fichiers .dat se remplissent bien surtout le service.

    dans mon fichier perfparse.cfg:

    Server_Port = "1976"
    Service_Log = "-"
    Service_Log_Position_Mark_Path = "/usr/local/nagios/var/serviceperf.log/"
    Error_Log = "perfparse.log"
    Error_Log_Rotate = "Yes"
    Error_Log_Keep_N_Days = "7"
    Drop_File = "/tmp/perfparse.drop"
    Drop_File_Rotate = "Yes"
    Drop_File_Keep_N_Days = "7"
    Lock_File = "/var/lock/perfparse.lock"
    Show_Status_Bar = "Yes"
    Do_Report = "Yes"
    Default_user_permissions_Policy = "rw"
    Default_user_permissions_Host_groups = "rw"
    Default_user_permissions_Summary = "rw"
    Output_Log_File = "Yes"
    Output_Log_Filename = "/var/log/perfparse_output_log"
    Output_Log_Rotate = "Yes"
    Output_Log_Keep_N_Days = "7"
    Use_Storage_Socket_Output = "No"
    Storage_Socket_Output_Host_Name = "localhost"
    Storage_Socket_Output_Port = "1974"
    Use_Storage_Mysql = "Yes"
    No_Raw_Data = "Yes"
    No_Bin_Data = "No"
    DB_User = "gayne"
    DB_Pass =
    DB_Name = "perfparse"
    DB_Host = "localhost"
    Dummy_Hostname = "dummy"
    Storage_Modules_Load = "mysql"

    voili voilo, merci pour l'aide

    Leave a comment:


  • surcouf
    replied
    Re: perfparse + bbase mysql vide

    Originally posted by gwayawan
    j'obtiens un fichier de log perfparse: qui ne m'indique que les valeurs suivantes:

    2006/10/25 13:45:26 [ storage.c:95 18848 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:29 [ storage.c:95 18857 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:33 [ storage.c:95 18898 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:37 [ storage.c:95 18910 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:39 [ storage.c:95 18916 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:49:01 [ storage.c:95 19918 ] Initialisation du module storage_mysql effectuée avec succès

    Cependant ma base mysql est toujours vide!!!!

    quelqu'un à une idée?
    Et ton fichier « service-perfdata.dat » se remplit de données ?
    Et pense à fournir ton fichier « perfparse.cfg » aussi, le wiki ne précise rien à ce sujet alors qu'il est plutôt capital.

    Leave a comment:


  • gwayawan
    started a topic perfparse + bbase mysql vide

    perfparse + bbase mysql vide

    j'obtiens un fichier de log perfparse: qui ne m'indique que les valeurs suivantes:

    2006/10/25 13:45:26 [ storage.c:95 18848 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:29 [ storage.c:95 18857 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:33 [ storage.c:95 18898 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:37 [ storage.c:95 18910 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:45:39 [ storage.c:95 18916 ] Initialisation du module storage_mysql effectuée avec succès
    2006/10/25 13:49:01 [ storage.c:95 19918 ] Initialisation du module storage_mysql effectuée avec succès

    Cependant ma base mysql est toujours vide!!!!

    quelqu'un à une idée?
Working...
X