Announcement

Collapse
No announcement yet.

PB entre nrpe et xinetd !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PB entre nrpe et xinetd !

    Salut à toutes et à tous :wink:

    J'ai un beau pépin pour lequel même un ingé système Unix s'est cassé les dents !

    J'ai un premier serveur sous RedHat pour lequel je dois installer le démon nrpe...(install de la version 2.5.1 sans pb, création du fichier nrpe dans le répertoire /etc/xinetd.d avec pour infos
    service nrpe
    {
    flags = REUSE
    socket_type = stream
    wait = no
    user = nagios
    group = nagios
    server = /usr/local/nagios/nrpe-2.5.1/src/nrpe
    server_args = -c /usr/local/nagios/nrpe-2.5.1/nrpe.cfg --inetd
    log_on_failure += USERID
    disable = no
    only_from = IP de l'hôte Nagios
    }


    Le PB est qu'à l'arrêt/démarrage de xinetd, j'obtiens dans la log les erreurs suivantes.
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute flags - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=3]
    Nov 28 10:24:47 slhsit101 xinetd[18249]: attribute socket_type expects 1 values and 2 values were specified [file=/etc/xinetd.d/nrpe] [line=4]
    [file=/etc/xinetd.d/nrpe] [line=5]249]: Bad value for wait: no
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute wait - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=5]
    [file=/etc/xinetd.d/nrpe] [line=6]249]: Unknown user: nagios
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute user - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=6]
    [file=/etc/xinetd.d/nrpe] [line=7]249]: Unknown group: nagios
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute group - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=7]
    is not executable [file=/etc/xinetd.d/nrpe] [line=8]local/nagios/nrpe-2.5.1/src/nrpe
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=8]
    [file=/etc/xinetd.d/nrpe] [line=10]49]: Bad log_on_failure flag: USERID
    Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute log_on_failure - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=10]
    [file=/etc/xinetd.d/nrpe] [line=11]49]: Bad value: no
    Nov 28 10:24:48 slhsit101 xinetd[18249]: Error parsing attribute disable - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=11]

    Avez-vous une idée ?

    Merci.
    RedHat AS4, Oreon 1.4, Nagios 2.8

  • #2
    Ton fichier nrpe semble tout pourris d'après le parseur.

    Je vois 2 solutions possibles :
    - Vieux copier - coller avec des caractères invisibles qui trainent (pages de codes différentes généralement)
    - Bon copier - coller mais le fichier de conf est prévu pour une autre distribution &| version.
    Dans ce cas là "man xinetd" sur ta distrib et suivre les instructions de formattage du fichier.
    Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
    Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
    Fedora Core 5 - 2.6.20-1.2320

    Comment


    • #3
      Re: PB entre nrpe et xinetd !

      Originally posted by Nounours
      Salut à toutes et à tous :wink:

      J'ai un beau pépin pour lequel même un ingé système Unix s'est cassé les dents !

      J'ai un premier serveur sous RedHat pour lequel je dois installer le démon nrpe...(install de la version 2.5.1 sans pb, création du fichier nrpe dans le répertoire /etc/xinetd.d avec pour infos
      service nrpe
      {
      flags = REUSE
      socket_type = stream
      wait = no
      user = nagios
      group = nagios
      server = /usr/local/nagios/nrpe-2.5.1/src/nrpe
      server_args = -c /usr/local/nagios/nrpe-2.5.1/nrpe.cfg --inetd
      log_on_failure += USERID
      disable = no
      only_from = IP de l'hôte Nagios
      }


      Le PB est qu'à l'arrêt/démarrage de xinetd, j'obtiens dans la log les erreurs suivantes.
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute flags - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=3]
      Nov 28 10:24:47 slhsit101 xinetd[18249]: attribute socket_type expects 1 values and 2 values were specified [file=/etc/xinetd.d/nrpe] [line=4]
      [file=/etc/xinetd.d/nrpe] [line=5]249]: Bad value for wait: no
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute wait - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=5]
      [file=/etc/xinetd.d/nrpe] [line=6]249]: Unknown user: nagios
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute user - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=6]
      [file=/etc/xinetd.d/nrpe] [line=7]249]: Unknown group: nagios
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute group - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=7]
      is not executable [file=/etc/xinetd.d/nrpe] [line=8]local/nagios/nrpe-2.5.1/src/nrpe
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute server - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=8]
      [file=/etc/xinetd.d/nrpe] [line=10]49]: Bad log_on_failure flag: USERID
      Nov 28 10:24:47 slhsit101 xinetd[18249]: Error parsing attribute log_on_failure - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=10]
      [file=/etc/xinetd.d/nrpe] [line=11]49]: Bad value: no
      Nov 28 10:24:48 slhsit101 xinetd[18249]: Error parsing attribute disable - DISABLING SERVICE [file=/etc/xinetd.d/nrpe] [line=11]

      Avez-vous une idée ?
      Ton « ingénieur système Unix » devrait consulter le manuel de xinetd.
      Visiblement, il y a plusieurs options pour lesquelles xinet n'arrive pas à comprendre les arguments, il désactive donc le service.
      Vérifie donc les arguments de ton fichier de configuration.
      Raphaël 'SurcouF' Bordet
      Je ne teste pas mes plugins en root, tu ne testes pas tes plugins en root...
      Dons Paypal

      Comment


      • #4
        PB entre nrpe et xinetd !

        Merci pour la soluce

        C'était le fichier nrpe qui était formatté à la mord moi le noeud.
        En le mettant d'équerre, j'ai bien de démarré le service nrpe.

        Reste plus qu'un souçaille : le service nrpe pointe vers le port 0 au lieu d'être sur le port 5666 (nrpe.cfg bien défini sur 5666, et "nrpe 5666/tcp" défini dans le fichier /etc/services).
        RedHat AS4, Oreon 1.4, Nagios 2.8

        Comment


        • #5
          PB entre nrpe et xinetd !

          HELP ! :cry:

          Je craque.
          Quel que soit le check que je lance sur le serveur RedHat, j'obtiens le message suivant :
          ./check_xxx : cannot execute binary file


          Pouvez-vous me dire d'où çà vient SVP.
          RedHat AS4, Oreon 1.4, Nagios 2.8

          Comment


          • #6
            chmod 777 :idea:
            Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
            Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
            Fedora Core 5 - 2.6.20-1.2320

            Comment


            • #7
              PB entre nrpe et xinetd !

              J'avais déjà mis les permissions sur l'ensemble des checks mais rien n'y fait :!:

              çà commence sérieusement à me :twisted:
              RedHat AS4, Oreon 1.4, Nagios 2.8

              Comment


              • #8
                Re: PB entre nrpe et xinetd !

                Originally posted by Nounours
                J'avais déjà mis les permissions sur l'ensemble des checks mais rien n'y fait :!:

                çà commence sérieusement à me :twisted:
                Bon aller Promis on regardera ca ensemble ètrs bientot
                Laisse moi le temps de finir mes cluster Veritas, et ensuite je m'occuperai en direct live de ton pb :wink:
                Ubuntu 8.04
                Nagios 3.2 + nagios-plugins-1.4.14
                ndoutils-1.4b9
                Centreon 2.1.8
                centreon-syslog-frontend-1.2.1 + centreon-syslog-server-1.1

                Comment


                • #9
                  Re: PB entre nrpe et xinetd !

                  Originally posted by Nounours
                  Merci pour la soluce

                  <coupe>

                  Reste plus qu'un souçaille : le service nrpe pointe vers le port 0 au lieu d'être sur le port 5666 (nrpe.cfg bien défini sur 5666, et "nrpe 5666/tcp" défini dans le fichier /etc/services).
                  Bonjour,
                  Le port défini dans nrpe.cfg n'a aucune importance avec xinetd. Dans mon fichier nrpe.cfg il est écrit :
                  Code:
                  # PORT NUMBER
                  # Port number we should wait for connections on.
                  # NOTE: This must be a non-priviledged port (i.e. > 1024).
                  # NOTE: This option is *ignored* if NRPE is running under either inetd or xinetd
                  
                  # server_port=5666
                  Tu peux constater que la ligne concernant le port est commentée
                  On voit que xinetd ( pas nrpe ), écoute bien sur le port 5666, cf commande nestat ci-dessous champ "Adresse Locale"
                  Code:
                  [email protected]:/home/nagios# netstat -tpan
                  Connexions Internet actives (serveurs et etablies)
                  Proto Recv-Q Send-Q  Adresse locale  Adresse distante  Etat        PID/Program name
                  ....
                  tcp        0      0 0.0.0.0:5666            0.0.0.0:*               LISTEN     12005/xinetd
                  ....
                  Et si on s'adresse au service nrpe depuis le PC 192.168.2.2
                  Code:
                  /usr/local/nagios/libexec/check_nrpe -H 192.168.2.1 [-n] -c check_disk
                  Réponse :
                  Code:
                  DISK OK - free space: / 32062 MB (89%);| /=4042MB;36083;36093;0;36103
                  Je relance la commande netstat, je constate que nrpe a bien répondu sur le port indiqué dans /etc/services
                  Code:
                  ...
                  tcp        0      0 0.0.0.0:5666            0.0.0.0:*               LISTEN     12005/xinetd
                  ...
                  tcp        0      0 192.168.2.1:5666        192.168.2.2:58830       TIME_WAIT  -
                  ...
                  Cordialement
                  La beauté n'est que la promesse du bonheur ...

                  Comment


                  • #10
                    PB entre nrpe et xinetd !

                    Merci DevNull pour ton explication

                    Par contre malgré désinstallation et re-compilation de NRPE, j'obtiens les choses suivantes :

                    netstat -tpan me donne :
                    tcp 0 0 0.0.0.0:5666 0.0.0.0:* LISTEN 12678/xinetd

                    En lançant un nrpe via une autre machine
                    ./check_nrpe -H 192.208.16.180 -p 5666 -c check_disk


                    j'obtiens : CHECK_NRPE: Error receiving data from host.

                    Le fait d'avoir de déclarer dans /etc/services la ligne...
                    nrpe 5666/tcp # NRPE

                    ...et dans /etc/hosts.allow NRPE : ALL ne me permet pas de faire fonctionner correctement me démon.

                    Directement lancée sur le serveur la commande donne
                    [[email protected] libexec]# ./check_nrpe -H 192.208.16.180
                    CHECK_NRPE: Error - Could not complete SSL handshake.


                    [[email protected] libexec]# ./check_nrpe -H 192.208.16.180 -n
                    CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.



                    HELP
                    RedHat AS4, Oreon 1.4, Nagios 2.8

                    Comment


                    • #11
                      Re: PB entre nrpe et xinetd !

                      Originally posted by Nounours
                      Merci DevNull pour ton explication

                      Par contre malgré désinstallation et re-compilation de NRPE, j'obtiens les choses suivantes :

                      netstat -tpan me donne :
                      tcp 0 0 0.0.0.0:5666 0.0.0.0:* LISTEN 12678/xinetd

                      En lançant un nrpe via une autre machine
                      ./check_nrpe -H 192.208.16.180 -p 5666 -c check_disk


                      j'obtiens : CHECK_NRPE: Error receiving data from host.

                      Le fait d'avoir de déclarer dans /etc/services la ligne...
                      nrpe 5666/tcp # NRPE

                      ...et dans /etc/hosts.allow NRPE : ALL ne me permet pas de faire fonctionner correctement me démon.
                      Bonjour,

                      Essaye de mettre pendant les tests ALL: ALL dans /etc/hosts.allow
                      Perso je n'ai rien dans /etc/hosts.allow et j'ai ALL: PARANOID dans /etc/hosts.deny. Pourtant tout fonctionne correctement. Mon xinetd n'utilise pas tcpwrapper visiblement


                      Originally posted by Nounours
                      Directement lancée sur le serveur la commande donne
                      [[email protected] libexec]# ./check_nrpe -H 192.208.16.180
                      CHECK_NRPE: Error - Could not complete SSL handshake.


                      [[email protected] libexec]# ./check_nrpe -H 192.208.16.180 -n
                      CHECK_NRPE: Received 0 bytes from daemon. Check the remote server logs for error messages.
                      Pourrais-tu essayer comme ça par pour voir :
                      Code:
                      /usr/local/nagios/libexec/check_nrpe -H 192.208.16.180 -n -p 5666 -c check_users là j'ai pris check_users, mais utilise une commande que tu as définies dans ton /etc/nrpe.cfg ou equivalent
                      As-tu quelques lignes dans /var/log/xinetd/ ? sinon dé-commente la ligne
                      # log_type = SYSLOG daemon info
                      du fichier /etc/xinetd.conf
                      rajoute ces lignes dans ton fichier /etc/xinetd.d/nrpe
                      Code:
                      log_type        = FILE /var/log/xinetd/defaults
                      log_on_success  = HOST RECORD
                      log_on_failure  += USERID
                      et relance xinetd. Normalement ça doit loguer les accès dans /var/log/xinetd/defaults (moi j'ai créé le repertoire /var/log/xinetd le fichier default se crée automatiquement


                      Originally posted by Nounours
                      HELP
                      Bonne chance
                      La beauté n'est que la promesse du bonheur ...

                      Comment

                      Working...
                      X