Announcement

Collapse
No announcement yet.

pb installation oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pb installation oreon

    Bonjour,

    J'ai un gros problème avec oreon j'ai installer nagios sans poblème il supervise mon parc informatique mais quand je lance le script install.sh il me retourne le message suivant :

    Make sure you have root permissions !

    WARNING : Setup will delete all previous information in your OREON DATABASE.

    install.sh: line 71: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    gcc ... yes
    group nagios ... yes
    user nagios ... yes
    group nagiocmd ... yes

    Configure Apache server ...

    Apache version : 2
    Saving your old configuration : /etc/httpd/conf/httpd.conf >
    /etc/httpd/conf/httpd.conf.initial
    install.sh: line 215: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 222: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    user apache added to nagios group
    Apache is now ready for OREON
    Arrêt de httpd : [ OK ]
    Démarrage de httpd :[Mon Apr 11 15:48:09 2005] [warn] The Alias
    directive in /etc/httpd/conf/httpd.conf at line 494 will probably
    never match because it overlaps an earlier AliasMatch.
    [ OK ]

    install oreon ...
    install.sh: line 274: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 275: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    chown: ne peut accéder `/usr/local/oreon/': Aucun fichier ou
    répertoire de ce type
    install.sh: line 277: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 278: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 280: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 284: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 285: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 288: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    install.sh: line 289: /root/oreon-v1.0/log/install_oreon.log: Aucun
    fichier ou répertoire de ce type
    cp: `/usr/local/nagios/libexec': répertoire cible spécifié n'exite pas
    Pour en savoir davantage, faites: « cp --help ».
    chown: ne peut accéder `/usr/local/nagios/libexec': Aucun fichier ou
    répertoire de ce type
    chmod: ne peut accéder `/usr/local/nagios/libexec/*': Aucun fichier ou
    répertoire de ce type
    sudo is already configurate
    Restart Mysql server ...
    Arrêt de MySQL : [ OK ]
    Démarrage de MySQL : [ OK ]

    ##################################################
    # Go to the URL : http://your-server/oreon/ #
    # to finish the setup #
    # #
    # Report bugs at [email protected] #
    # #
    # Thanks for using OREON. #
    # ----------------------- #
    # Contact : [email protected] #
    # www.oreon.org #
    ##################################################
    [[email protected] oreon-v1.0]#

    Pourriez vous m'aider ?

    Merci d'avance

  • #2
    Bonjour,

    A ce que je vois, tu as 3 problèmes :

    - fichier de log : il n'arrive pas à écrire dans le fichier de log de l'install, il faudrait vérifier que le répertoire /root/oreon-v1.0/log/ existe bien. Ce n'est pas bloquant pour l'installation.

    - apache : The Alias directive in /etc/httpd/conf/httpd.conf at line 494 will probably never match because it overlaps an earlier AliasMatch.
    Tu dois avoir 2 fois la même déclaration dans ta conf. C'est juste un warning, dc pas bloquant non plus.

    - cp: `/usr/local/nagios/libexec': répertoire cible spécifié n'exite pas
    Pour en savoir davantage, faites: « cp --help ». chown: ne peut accéder `/usr/local/nagios/libexec': Aucun fichier ou répertoire de ce type chmod: ne peut accéder /usr/local/nagios/libexec/*': Aucun fichier ou répertoire de ce type

    le répertoire par défaut `/usr/local/nagios/libexec' n'existe pas. Tu as du faire une install via RPM de nagios je pense.

    Donc :
    > vérifie que le répertoire /root/oreon-v1.0/log/ existe
    > corrige le double alias ligne 494 dans ton httpd.conf
    > crée le répertoire `/usr/local/nagios/libexec` si il n'existe pas.
    > tiens nous au courant

    Comment


    • #3
      Bonjour,

      Merci pour ta réponse, l'installation à bien fonctionner mais quand j'entre des serveurs oreon ne les affiches pas pourtant j'ai bien appliquer générer et enregistrer comme indiqué dans la doc, les serveurs apparaissent bien dans les hosts mais il ne s'affiche pas dans le monitoring de plus je ne vois pas mes serveurs nagios que j'ai déjà entré dans nagios avent l'installation de oreon ( qui pourtant était monitoré par nagios ) j'ai vérifié les permissions d'écritures tout est bon mais je ne vois pas de solutions, peux tu m'aider ?

      Merci d'avance

      Nicolas

      Comment


      • #4
        les hosts qui etaient entrés avant avec nagios ne sont pas repris automatiquement par oreon. Il faut tout refaire.

        Est ce que les fichiers ont été modifié ? Est ce que le serveur nagios a bien redémarré avec oreon ? est ce que sudo est bien configuré ?

        deja avec cela on sera plus eclairés .

        Merci
        Julien Mathis
        Centreon Project Leader
        www.merethis.com |

        Comment


        • #5
          Pb Lors de la génération des fichier de configuration

          Bonjour,

          Merci pour t réponse;

          J'ai encore une petite question qui est la suivante ;

          Lors de la génération des fichier et du déplacement j'ai une erreur qui est la suivante :

          Reading configuration data...
          Error in configuration file '/usr/local/oreon/./etc/nagios.cfg' - Line 63 (UNKNOWN VARIABLE)

          Quand je regarde la ligne 63 du fichier nagios.cfg je voit que le probléme vient de :

          inter_check_delay_method=n

          Je ne comprend pas pkoi cette erreur ?

          Merci d'avance
          Cordialement
          Nicolas

          Comment


          • #6
            Tu as installe Nagios 2 ? Car cette variable effectivement n'existe plus avec Nagios 2, et la tu generes pour un Nagios 1.

            La prochaine version d'Oreon prendra en compte Nagios 1 et 2, mais d'ici la, patience !
            Romain Le Merlus
            Centreon Forge
            MERETHIS

            Comment


            • #7
              Pb Lors de la génération des fichier de configuration

              Merci pour ta réponse;

              Oui j'ai installer Nagios 2, donc si je comprend bien pour l'instant il vaudrai mieux que je réinstall un Nagios 1 pour que Oreon Fonctionne correctement ?

              Merci d'avance
              Nicolas

              Comment


              • #8
                Voila c ca !

                Mais ne t'inquiete pas, Oreon pour Nagios 2 arrive bientot.
                Romain Le Merlus
                Centreon Forge
                MERETHIS

                Comment


                • #9
                  Pb Lors de la génération des fichier de configuration

                  Ok merci

                  Nicolas

                  Comment

                  Working...
                  X