Announcement

Collapse
No announcement yet.

Probléme avec PERFPARSE

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Probléme avec PERFPARSE

    Bonjour, Ma config Debian 3.1r4

    J'ai suivi à la lettre l'installation de Nagios 2.5, ORION 1.3.2 et PerfParse 0.105.6 celon le tuto en ligne via le Wiki http://wiki.oreon-project.org/wakka.php?wiki=WorkShopFR.
    Tout fonctionne sauf pour l'onglet vu Oreon " Impossible de grapher.
    Les onglets du choix des Hotes et Services sont présent mais rien à l'interieur.
    Au début j'avais un probléme avec la connexion à la base mais je l'ai résolu en créant la base dans mysql est en le spécifiant dans le fichier de config "PerfParse.CFG" est tout est rentré dans l'ordre.

    J'ai consulté le gestionnaire d"événements et jai comme info:

    -File '/var/nagios/service-perfdata.dat' could not be opened - service performance data will not be written to file!

    - File '/var/nagios/host-perfdata.dat' could not be opened - host performance data will not be written to file!

    Effectivement les fichiers ne sont pas présents dans /var/nagios. En plus le répertoire n'existe même pas!
    Alors ma question est la suivante:
    Est ce normale ou je dois créé le répertoire manuellement?
    Ou se trouve les fichiers service-perfdata.dat et host-perfdata.dat?
    comment faire pour le faire fonctionner?
    Merci de l'aide
    Cordialement,

  • #2
    Bonjour,

    Ma config: Oreon 1.3.3
    Nagios : 2.5
    mysql : 4.1

    J'ai exactement le même problème que toi !!! J'ai également suivi le tuto à la lettre.

    Au début pareil, la base perfparse n'était pas créer parce que cela n'est pas dit dans le tuto d'intallation mais bon c'est pas le plus grave. En le disant ils penseront à le rajouter.

    Ce serait bien si un membre d'oreon pouvait nous dire d'où peut venir ce problème.
    Je reste néamoins un peut floue sur la finalisation de l'installation du fait que les paramètres ci desous ne sont pas vraiment les mêmes dans ce fichier de config "/usr/local/oreon/cron/deleteDB.pl" :



    J'ai modifié ces champs :

    Code:
    my $Userpp = "users";
    my $Passwordpp = "avec_mdp";
    my $DataBasepp = "perfparse";
    my $Hostpp = "localhost";
    my $dbh;
    my $dbpp;
    
    sub     connect_db()
    {
        my $User = "users";
        my $Password = "avec_mdp";
        my $DataBase = "oreon";
        my $Host = "localhost"
    Donc le problème ne vient pas de là.

    Sinon pour ça :

    J'ai consulté le gestionnaire d'événements et j'ai comme info:

    -File '/var/nagios/service-perfdata.dat' could not be opened - service performance data will not be written to file!

    - File '/var/nagios/host-perfdata.dat' could not be opened - host performance data will not be written to file!
    C'est pareil pour moi et c'est fichiers sont nul part.

    Si une personne pouvait nous venir en aide ce serait sympa.

    Merci
    Max
    Nagios : 2.5
    Oreon : 1.3.3
    Mysql : 4.1

    Comment


    • #3
      Re: Probléme avec PERFPARSE

      Originally posted by makensy13
      Bonjour, Ma config Debian 3.1r4
      -File '/var/nagios/service-perfdata.dat' could not be opened - service performance data will not be written to file!

      - File '/var/nagios/host-perfdata.dat' could not be opened - host performance data will not be written to file!
      Bonjour,

      Je dirais tout simplement que Nagios n'est pas installé dans /var/nagios mais dans un autre répertoire comme /usr/local/nagios. Dans ce cas, il te suffit d'indiquer comme chemin pour tes performance data '/usr/local/nagios/var/host-perfdata.dat' et '/usr/local/nagios/var/service-perfdata.dat', l'écriture pourra alors se faire.
      Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
      Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

      Comment


      • #4
        Bonjour,

        Ok merci ! Maintenant j'ai les fichiers dans /usr/local/nagios/var/, cependant il y a seulement le fichier des hosts qui se rempli !!!

        Sinon, j'ai toujours le message d'erreur dans "vue oreon" concernant la connexion à la base perfparse. Dans l'interface d'oreon, Configuration --> Nagios --> Perfparse CFG, j'ai bien renseigné le login/mdp de connexion et j'ai revu la configuration du fichier /usr/local/oreon/cron/deleteDB.pl qui est décrite lors de l'installation d'oreon : http://wiki.oreon-project.org/wakka....tupOreon13FR#5

        Si quelqu'un a une petite idée !!! Merci :wink:

        Sinon petite remarque sur le wiki, à cette adresse : http://wiki.oreon-project.org/wakka....pPerfParseFR#4 , il faut revoir les path /var/nagios par /usr/local/nagios/var

        Max
        Nagios : 2.5
        Oreon : 1.3.3
        Mysql : 4.1

        Comment


        • #5
          non ca depend du type d'installation
          Julien Mathis
          Centreon Project Leader
          www.merethis.com |

          Comment


          • #6
            Originally posted by Max
            Sinon, j'ai toujours le message d'erreur dans "vue oreon" concernant la connexion à la base perfparse.
            Bonjour,

            Essaie de voir si la connexion à la base est fonctionnelle au moins en ligne de commande "mysql -u nagios -p -D nagios", en considérant dans cet exemple que ton utilisateur perfdata s'appelle nagios (-u) et que ta base perfdata s'appelle nagios également (-D), puis effectue un "show tables;" pour voir si toutes les tables sont bien présentes. Dans le cas contraire c'est que la création de la base n'est pas correcte ou que le script .sql n'a pas été importé.

            Tu n'as d'ailleurs pas besoin normalement de modifier le script /usr/local/oreon/cron/deleteDB.pl pour y inclure tes informations de connexion, elles sont lues directement à partir des données entrées dans l'interface Oreon. Seules les deux variables indiquées dans le wiki ou lors de l'install doivent l'être ($path_oreon et $NagiosPathArchive).
            Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
            Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

            Comment


            • #7
              Bonjour,

              Merci de me guider dans ce petit souci mais malheureusement je comprends pas ce qui ne va pas !

              Originally posted by -Archi-
              Bonjour,

              Essaie de voir si la connexion à la base est fonctionnelle au moins en ligne de commande "mysql -u nagios -p -D nagios"
              Oui c'est bon, j'ai même un accès en phpmyadmin, mais j'ai contrôlé en ligne de commande et voilà ce que cela me donne :

              Code:
              mysql> show tables;
              +---------------------------------+
              | Tables_in_perfparse             |
              +---------------------------------+
              | perfdata_bin_summary            |
              | perfdata_bin_summary_data       |
              | perfdata_bin_summary_del_policy |
              | perfdata_bin_summary_header     |
              | perfdata_delete_policy          |
              | perfdata_graphs                 |
              | perfdata_host                   |
              | perfdata_host_group             |
              | perfdata_prefs                  |
              | perfdata_raw_summary            |
              | perfdata_raw_summary_data       |
              | perfdata_registry               |
              | perfdata_service                |
              | perfdata_service_bin            |
              | perfdata_service_metric         |
              | perfdata_service_raw            |
              | perfdata_state                  |
              | perfdata_users                  |
              +---------------------------------+
              18 rows in set (0.00 sec)
              D'ailleurs à ce sujet, la base est vide ça je comprends mais je me pose la question suivante : Est ce logique pour la table perfdata_users ???

              D'autre part,
              Originally posted by -Archi-
              Tu n'as d'ailleurs pas besoin normalement de modifier le script /usr/local/oreon/cron/deleteDB.pl pour y inclure tes informations de connexion, elles sont lues directement à partir des données entrées dans l'interface Oreon. Seules les deux variables indiquées dans le wiki ou lors de l'install doivent l'être ($path_oreon et $NagiosPathArchive).
              Ok j'ai vérifié les paths, tout est OK. De ce fait si je comprends bien avant cela était demandé mais pour les précédentes versions de perfparse pour oreon ????

              En résumé :
              J'en suis toujours avec un problème de connexion avec perfparse via oreon !!! La configuration a été faite dans l'interface d'oreon, ainsi que dans les fichiers de configuration sités précédement. Si quelqu'un a une idée, merci de me guider.

              Max
              Nagios : 2.5
              Oreon : 1.3.3
              Mysql : 4.1

              Comment


              • #8
                Originally posted by Max
                D'ailleurs à ce sujet, la base est vide ça je comprends mais je me pose la question suivante : Est ce logique pour la table perfdata_users ???
                Tes tables sont bien les bonnes donc tout est OK niveau installation. La table perfdata_users est vide chez moi aussi, je ne me suis pas penché en détail sur le fonctionnement de perfparse donc je ne saurais pas dire à quoi elle sert exactement. Les données à proprement parlé sont stockées dans perfdata_service_bin (pour la version metric/valeur) et perfdata_service_raw (pour la version brute renvoyée par la commande).

                Originally posted by Max
                Ok j'ai vérifié les paths, tout est OK. De ce fait si je comprends bien avant cela était demandé mais pour les précédentes versions de perfparse pour oreon ????
                C'était effectivement nécessaire dans les précédentes versions d'après les docs, mais ici le script renseigne automatiquement les variables à partir du fichier de configuration de l'interface web en récupérant les couples clés/valeurs entre ' ' et " ".

                /usr/local/oreon/www/oreon.conf.php
                Code:
                $conf_oreon['host'] = "localhost";
                $conf_oreon['user'] = "oreon";
                $conf_oreon['password'] = "xxx";
                $conf_oreon['db'] = "oreon";
                Originally posted by Max
                J'en suis toujours avec un problème de connexion avec perfparse via oreon !!! La configuration a été faite dans l'interface d'oreon, ainsi que dans les fichiers de configuration sités précédement.
                J'ai rencontré un problème du même genre hier, tout était bien renseigné dans Oreon mais l'export du fichier perfparse.cfg ne voulait pas se faire. Regarde dans l'interface Oreon dans Options > Options Générales > Nagios si "Utilisation de PerfParse" est à "Oui" et effectue un nouvel export des fichiers de configuration ("Déplacer les fichiers" à "Oui"). Une exécution en ligne de commande de /usr/local/nagios/bin/perfparse-log2mysql peut par ailleurs te faire voir les erreurs qui n'apparaissent pas autrement.
                Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                Comment


                • #9
                  Originally posted by -Archi-
                  Regarde dans l'interface Oreon dans Options > Options Générales > Nagios si "Utilisation de PerfParse" est à "Oui" et effectue un nouvel export des fichiers de configuration ("Déplacer les fichiers" à "Oui").
                  Oui ça c'est bon ! Je demande toujours à déplacer les fichiers !

                  Originally posted by -Archi-
                  Une exécution en ligne de commande de /usr/local/nagios/bin/perfparse-log2mysql peut par ailleurs te faire voir les erreurs qui n'apparaissent pas autrement.
                  J'ai testé mais rien ne s'affiche sauf lorsque je tape sur entrée !


                  Sinon j'ai remarqué ce warning lorsque je redémarre Nagios :
                  Code:
                  Warning: Host 'Meta_Module' has no services associated with it!
                  Est-ce normal ?

                  Et j'ai une petite question dans le fichier de configuration de perfparse, j'ai devant la directive "Storage_Socket_Output_Host_Name" la valeur "localhost" et moi je renseigne devant la directive "DB_Host" le nom de ma machine !! L'erreur pourrait venir de là ? Je serais quand même assé surpris parce qu'en ligne de commande la connexion fonctionne bien !!!

                  Merci de votre soutien
                  Max :wink:
                  Nagios : 2.5
                  Oreon : 1.3.3
                  Mysql : 4.1

                  Comment


                  • #10
                    Originally posted by Max
                    Oui ça c'est bon ! Je demande toujours à déplacer les fichiers !
                    [snip]
                    Sinon j'ai remarqué ce warning lorsque je redémarre Nagios :
                    Code:
                    Warning: Host 'Meta_Module' has no services associated with it!
                    Est-ce normal ?
                    Tant mieux si c'est bon, sans le fichier perfparse.cfg ça marche nettement moins bien :P J'ai également ce warning mais je ne sais pas trop à quoi correspondent les "meta" associés à perfparse, néanmoins tout marche très bien malgré ça.

                    Originally posted by Max
                    Et j'ai une petite question dans le fichier de configuration de perfparse, j'ai devant la directive "Storage_Socket_Output_Host_Name" la valeur "localhost" et moi je renseigne devant la directive "DB_Host" le nom de ma machine !! L'erreur pourrait venir de là ? Je serais quand même assé surpris parce qu'en ligne de commande la connexion fonctionne bien !!!
                    La directive Storage_Socket_Output_Host_Name n'est prise en compte que si Use_Storage_Socket_Output est à Yes. Par contre l'erreur pourrait en effet venir de DB_Host, regarde dans ton fichier /etc/hosts si le nom de ta machine est associé à 127.0.0.1 ou bien à une autre adresse IP. Dans ce dernier cas la connexion à la base de données a de fortes chances d'être bloquée car les utilisateurs ne sont autorisés qu'en "localhost" par défaut.
                    Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                    Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                    Comment


                    • #11
                      Originally posted by -Archi-
                      J'ai également ce warning mais je ne sais pas trop à quoi correspondent les "meta" associés à perfparse, néanmoins tout marche très bien malgré ça.
                      Normal ! Suffit de chercher un peu sur le forum pour savoir ce que sont ces meta services :wink:
                      Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                      Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                      Fedora Core 5 - 2.6.20-1.2320

                      Comment


                      • #12
                        Originally posted by DonKiShoot
                        Normal ! Suffit de chercher un peu sur le forum pour savoir ce que sont ces meta services :wink:
                        Je vais chercher la clé de ce mystère découvert hier lors de la génération de la conf perfparse :wink: Je ne suis sur Oreon que depuis une semaine environ (après 6 mois de Nagios "traditionnel") car il est bien plus adapté au cahier des charges du projet. Je découvre peu à peu ce nouveau monde
                        Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                        Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                        Comment


                        • #13
                          Originally posted by -Archi-
                          Par contre l'erreur pourrait en effet venir de DB_Host, regarde dans ton fichier /etc/hosts si le nom de ta machine est associé à 127.0.0.1 ou bien à une autre adresse IP. Dans ce dernier cas la connexion à la base de données a de fortes chances d'être bloquée car les utilisateurs ne sont autorisés qu'en "localhost" par défaut.
                          Dans mon fichier hosts c'est bon, tout est nikel. Pour la boucle local j'ai le nom de ma machine + localhost et pour mon IP local j'ai juste le nom de ma machine.

                          Je vais passer à nouveau en revu tout les fichiers de config parce que là je tourne en rond et j'aime pas ça et je reviendrai mettre un post !!!

                          Merci pour toutes les pistes
                          Nagios : 2.5
                          Oreon : 1.3.3
                          Mysql : 4.1

                          Comment


                          • #14
                            Bonjour,

                            Malheureusement j'aurais bien aimé annoncer une bonne nouvelle mais nan ! :x

                            Pour récapituler :

                            J'ai vérifié le fichier de configuration de perfparse --> OK
                            J'ai vérifié que les fichiers de config sont bien déplacé --> OK
                            La connexion à la base en ligne de commande --> OK

                            J'ai remarqué que la connexion à la base ne fonctionne pas non plus avec le script deleteDB.pl !!!!

                            N'y aurait-il pas un souci quelque part ??? Dans le script j'ai bien remarqué la recherche des paramètres de connexion à la base pour oreon mais pour perfparse nan !!! Je vois juste ligne 148 qu'il va chercher les paramètres via la variables cfg_perfparse mais à aucun endroit je ne renseigne cette variable. Mais bon il arrive quand même à récupérer le nom de la base !!!!

                            Voici le message d'erreur :
                            Code:
                            DBI connect('database=perfparse;host=serveursup','oreon',...) failed: Access denied for user 'oreon'@'serveursup' (using password: YES) at ./deleteDB.pl line 158
                            Si quelqu'un a encore un peu de courage pour m'aider à résoudre le problème, c'est cool !!!

                            Sinon, c'est quoi : Dummy_Hostname = "dummy" dans le fichier de configuration de perfparse ?

                            Merci
                            Max
                            Nagios : 2.5
                            Oreon : 1.3.3
                            Mysql : 4.1

                            Comment


                            • #15
                              Originally posted by Max
                              J'ai remarqué que la connexion à la base ne fonctionne pas non plus avec le script deleteDB.pl !!!!

                              N'y aurait-il pas un souci quelque part ??? Dans le script j'ai bien remarqué la recherche des paramètres de connexion à la base pour oreon mais pour perfparse nan !!! Je vois juste ligne 148 qu'il va chercher les paramètres via la variables cfg_perfparse mais à aucun endroit je ne renseigne cette variable. Mais bon il arrive quand même à récupérer le nom de la base !!!!
                              Bonjour,

                              Dans ce cas si ça ne fonctionne pas non plus dans le script c'est qu'il y a réellement un problème de configuration. Le script deleteDB.pl va chercher les paramètres de connexion perfparse directement dans la base de données Oreon via la table associée.

                              Ligne 147 :
                              Code:
                              my $cmd_access = "SELECT DB_user, DB_pass, DB_name, DB_host from cfg_perfparse";
                              Je te conseillerai de modifier partout le nom de ton serveur par localhost, s'il est associé à la fois à 127.0.0.1 et à ton IP locale il peut y avoir confusion selon quelle adresse est présente en premier dans le fichier. D'autant plus si la connexion en ligne de commande fonctionne parfaitement, vu que dans ce cas l'hostname "localhost" est implicite si tu ne précises pas autre chose.
                              Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                              Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                              Comment

                              Working...
                              X