Announcement

Collapse
No announcement yet.

[Résolu] problème à la toute fin d'installation d'Oreon

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Résolu] problème à la toute fin d'installation d'Oreon

    Bonjour à tous, je tiens d'abord à signaler que je suis débutant sur Linux donc pas de moqueries
    J'ai tout d'abord installé nagios 2.5 sans soucis je pense car je peux accéder à l'interface graphique (mais il met met un message d'erreur quand je veux aller dans les différentes sections, problème de fichiers de conf??). J'ai ensuite installé Oreon 1.3.3, j'ai un peu galéré pour les composants Pear mais j'ai réussi à les installer. Mais arrivé à la toute fin du setup de l'installation, là ou je suis censé arriver à la page de loggin d'oreon, j'obtiens le message suivant :

    Forbidden
    You don't have permission to access /oreon/install/setup.php on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


    ça fait un moment que je galère dessus, quelqu'un peut-il m'éclairer?
    Merci d'avance

    PS : je suis sous Debian
    Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

  • #2
    bonjour ,

    as tu redemarré apache ?

    merci
    Julien Mathis
    Centreon Project Leader
    www.merethis.com |

    Comment


    • #3
      Originally posted by julio
      bonjour ,

      as tu redemarré apache ?

      merci
      oui oui j'ai bien relancé ça vient pas de là. Je suis en stage dans une boite et personne ne sait pourquoi l'interface graphique d'oreon ne se lance pas alors que pour nagios c'est bon. C'est pour ça que je vous demande de l'aide
      Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

      Comment


      • #4
        Je dit peut-être une connerie mais tu as vérifier les utilisateurs des dossiers d'oreon ? Si c'est bien www-data (utilisateur de Apache2 dans mon cas) qui est utilisateur et le groupe?

        Sinon fait un:

        chown -R www-data.www-data /usr/local/oreon

        puis un autre chown pour mettre le répertoire rrd avec l'utilisateur nagios:

        chown -R nagios.nagios /usr/local/oreon/rrd

        Je te certifie pas que sa va arranger ton probléme mais à 1ère vue sa viens d'un probléme de droit d'accés donc... En espérant t'avoir aidé un peu.

        Cordialement

        Lawecal

        Comment


        • #5
          j'ai exactement fait ce que tu as proposé, mais après avoir relancé apache et réactualisé la page, j'ai toujours le même message d'erreur. Comme je débute sous linux je suis sûr que j'ai fait une erreur toute bête mais je trouve quand même bizarre que je n'ai aucun problème pour afficher nagios alors que j'en ai pour oreon
          Merci quand même pour ton aide Lawecal
          Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

          Comment


          • #6
            Tu pourrai poster les droit du dossier oreon et des dossier à l'intérieur s'il te plait? Peut-être que un tout bête chmod pourrait résoudre ton probléme...

            Enfin bon je pense qu'il faut travailler dans cette vois pour résoudre ton probléme. Dans mon cas j'obtiens celà si je fais un "ls -ali" :

            394337 drwxrwxr-x 9 www-data www-data 4096 2007-01-09 10:57 oreon

            Vérifie avec ton dossier si sa correspond.

            Comment


            • #7
              voici les droits du dossier oreon :

              drwxrwxr-x 9 www-data www-data 4096 2007-01-16 10:18 oreon


              et voici les droits des dossiers à l'intérieur du dossier oreon :

              drwxrwxr-x 9 www-data www-data 4096 2007-01-16 10:18 .
              drwxrwsr-x 12 root staff 4096 2007-01-16 10:18 ..
              drwxrwxr-x 2 www-data www-data 4096 2007-01-16 10:18 cron
              drwxrwxr-x 5 www-data www-data 4096 2007-01-16 10:18 filesGeneration
              drwxrwxr-x 4 www-data www-data 4096 2007-01-16 10:18 filesUpload
              drwxrwxr-x 7 www-data www-data 4096 2007-01-16 10:18 GPL_LIB
              drwxrwxr-x 2 www-data www-data 4096 2007-01-16 10:18 log
              drwxrwxr-x 2 nagios nagios 4096 2007-01-16 10:18 rrd
              drwxrwxr-x 11 www-data www-data 4096 2007-01-16 12:22 www
              Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

              Comment


              • #8
                Je viens de vérifier sa à l'air pourtant correcte. Je vois pas pourquoi tu as pas accés à oreon. C'est embêtant celà

                Car les utilisateur et les droits semble correcte et après redémarrage de apache... Je suis vraiment désolé pour une fois que je pensai aidé quelqu'un je trouve pas la solution lol ^^"

                Je vais continuer d'y réfléchir et si j'ai une idée je posterai entre 2-3 problémes à régler de mon côtés avec nagios et oreon

                Comment


                • #9
                  j'ai peut-être une piste et j'avais pas pensé à ça...
                  au tout début après avoir installé oreon, j'ai lancé l'interface graphique pour la première fois et cela ne marchait pas non plus. J'ai donc effectué la manip suivante pour faire un lien:

                  cd /var/www
                  mkdir oreon
                  ln -d -s /usr/local/oreon/www/* ./oreon/

                  est-ce là que j'ai merdé? et si oui que faire à la place?
                  Merci d'avance
                  Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                  Comment


                  • #10
                    Essaie de regarder les fichiers de logs d'Apache, peut-être qu'ils indiqueront plus précisément ce qui pose problème :

                    Code:
                    tail /var/log/apache2/access.log
                    tail /var/log/apache2/error.log
                    [Edit]
                    Ah oui effectivement ce n'est pas la procédure d'installation standard, pour bien faire tu devrais supprimer le lien et rajouter dans Apache la configuration suivante :

                    Fichier /etc/apache2/conf.d/oreon.conf
                    Code:
                    AddType application/x-java-jnlp-file .jnlp
                    Alias /oreon/ /usr/local/oreon/www/
                    <Directory "/usr/local/oreon/www">
                        Options None
                        AllowOverride AuthConfig Options
                        Order allow,deny
                        Allow from all
                    </Directory>
                    Redémarre Apache (/etc/init.d/apache2 reload) et avec un peu de chance ça devrait mieux marcher.
                    Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                    Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                    Comment


                    • #11
                      dans error.log :

                      [Tue Jan 16 12:25:48 2007] [error] [client 192.168.x.x] Symbolic link not allowed: /var/www/oreon/install


                      je vois que ça...
                      Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                      Comment


                      • #12
                        Originally posted by -Archi-
                        Fichier /etc/apache2/conf.d/oreon.conf
                        il n'y est pas
                        Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                        Comment


                        • #13
                          Originally posted by ptinico44
                          il n'y est pas
                          Justement il faut le créer avec le contenu que je t'ai collé :wink:
                          Le message d'erreur d'Apache montre que le lien symbolique n'est pas la bonne méthode.
                          Système : Debian Etch 4.0r8 / Apache 2.2.3 / PHP 5.2.0 / MySQL 5.0.32
                          Monitoring : Nagios 2.12 / Plugins 1.4.13 / Centreon 1.4.2.7

                          Comment


                          • #14
                            Originally posted by ptinico44
                            j'ai peut-être une piste et j'avais pas pensé à ça...
                            au tout début après avoir installé oreon, j'ai lancé l'interface graphique pour la première fois et cela ne marchait pas non plus. J'ai donc effectué la manip suivante pour faire un lien:

                            cd /var/www
                            mkdir oreon
                            ln -d -s /usr/local/oreon/www/* ./oreon/

                            est-ce là que j'ai merdé? et si oui que faire à la place?
                            Merci d'avance
                            Je ne sais pas quelle est le résultat de cette command mais ca ne doit pas être trop bon :lol:
                            Intel(R) Xeon(TM) CPU 3.4GHz - MemTotal : 1034476 kB
                            Centreon 2.4.1 - Nagios 3.2.1 - Nagios Plugins 1.4.15 - Manubulon Plugins tuné
                            Fedora Core 5 - 2.6.20-1.2320

                            Comment


                            • #15
                              elle est bonne pour le début de l'install, pas après. Je vais tester ça cet après le repas, je vous tiens au courant
                              Debian 3.1 - Nagios 2.5 - Nagios plugins 1.4.3 - oreon 1.3.3

                              Comment

                              Working...
                              X